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About PrintShop Mail 
 

PrintShop Mail User Guide 
 

 
 
Leverage the real potential of your data by printing variable images and text based 
upon unique information on each individual recipient! 
 
Overview 
PrintShop Mail is a fast, efficient and very easy to use professional software tool that makes personalized printing quick 
and easy. It allows you to optimize the process of merging variable database information with a design. For 
advertisements, direct mailing, flyers or any other type of promotional documents, you can rely on PrintShop Mail. 
PrintShop Mail enables users to perform simple and complex Variable Data Printing jobs for medium to high volume 
output quantities. 
 
By simply dragging and dropping database fields onto the document layout, PrintShop Mail creates a link between the 
database field and your document. PrintShop Mail gives you an instant preview and provides you with a powerful 
resource checking option to ensure proper printing. Utilize the comprehensive set of conditional rules for database driven 
composition. 

• Verify Document before printing. 
• Preview repetition settings. 
• Support for vertical text and double byte characters.  

During the printing process, the variable information from the database is sent to the printer on the fly. The static portion 
of the job does not need to be re-ripped. This greatly shortens the printing process and prevents network congestion.  
 
PrintShop Mail then allows your PostScript® printer to print at or near rated speed, depending on RIP capability. This 
makes variable information printing an efficient process. 
 
Benefits 

• Easy to use: no programming experience needed  
• No need to change your design application, database, PostScript RIP or printer  
• Variable Information Printing at rated speed of the printer!  
• Reduced print cost and print wastage  
• Efficient production process saves time and money  
• Open architecture - plugs in easily into your existing workflow  
• Instant preview to see results before printing to facilitate accuracy  
• Layout and database can be created separate from each other  
• Resource check on print stream reliability  
• Finishing options per record or per set  
• Nine free bar code fonts included! 

 
Business applications 

• Targeted Advertisements 
• High Speed Mail Merges 
• Direct Mailings 
• Discount Coupons 
• Postcards 
• Flyers 
• Tickets 
• Certificates 
• Letters and more… 
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Contact Information 
 

PrintShop Mail User Guide 
 
 

To find an Objectif Lune office near you and for more information on our products and services, visit 
www.objectiflune.com.  
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Using PrintShop Mail Help 
  
Getting Started with PrintShop Mail 
  

 
Here are some tips on how to use this PrintShop Mail on-line Help. 
 
About the Help Display 
 
You can use several navigation tools in this Help system. The Help is divided into a left-hand and right-hand frame. The 
right-hand frame shows the actual texts and some navigational aids, the left-hand frame is the mainstay for the 
navigational aids. You can select four options above the left-hand frame: 

• Hide/Show :To display or hide the Contents.  
• Back :To display the previous topic you selected.  
• Forward :To display the next topic you selected.  
• Print :To print one or more topics. 

 
Contents, Index, Search, and Glossary Tabs 
 
The left-hand frame contains the following tabs, which access these navigation aids: 

• Contents 
• Index 
• Search 
• Glossary 

 
Hyperlinks and Related Topics 
 
The right-hand frame contains the following navigation aids: 

• Hyperlinks 
• Related topics 

 
To use the Help navigation tools 
 
Contents 
 
Note: The Contents are displayed by default. Click the other tabs to access the corresponding navigational aids. 

1. If not selected, click the Contents tab.  
The table of contents appears in the left-hand frame. It is represented in the form of a tree structure with book 
icons. These books are  structured hierarchically. 

2. Click a book icon. 
3. Click a page icon.  

The corresponding Help text appears in the right-hand frame. 
 
Index 
 

1. Click the Index tab.  
2. In the text box, begin to type the first letters of the keyword you want information on or the entire keyword. 

The list below will jump to the first word beginning with the letters you typed.  
The selected keyword is highlighted. 

3. Continue to type more letters to narrow down the choice, or click the correct keyword if you can identify it. 
4. Click Display.  

The corresponding Help text is shown in the right-hand frame. 
Search 
 

1. Click the Search tab. 
At the top of the Search tab sheet, there is a box in which you can type the keyword.  

2. Click List Topics. 
A list with topics containing the keyword is displayed. 

3. Click the topic you want. 
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4. Click Display. 
The Help text is displayed in the right-hand frame. The selected keyword is highlighted. 

Glossary 
 

1. Click the Glossary tab to display PrintShop Mail terms.  
2. Click a term in the list to display its definition. 

 
Hyperlinks 
 
The Help texts contain hyperlinks. These are underlined texts. Click the underlined text to view the Help topic. 
 
Related topics 
 
The Related Topics buttons provide access to topics that deal with similar subjects. 
 
Click the Related Topics button. 

• If there is only one related topic, it is displayed straightaway. 
• If there are more than one related topics, a menu appears where you can make your selection.  
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Getting Started 

 

Installing PrintShop Mail 
  
Getting Started with PrintShop Mail 
  

 
Before you start 
 
If you are installing PrintShop Mail on a computer with Windows 2000, XP, 2003 or Vista,  make sure you are logged in 
with full administrative rights before running the installation program. 
 
To install PrintShop Mail 
 
Windows  
 

1. Locate the setup.exe file on the CD-ROM.  
2. Double click this file to start the installation wizard. 
3. Select the language you want to use for the installation. 
4. Click OK. 
5. Click Next. 
6. Read the license agreement and select I accept the terms in the license agreement. (If you select I do 

not accept the terms in the license agreement, the installation stops). 
7. Click Next. 
8. Specify whether you want PrintShop Mail to be available for all users on the computer, or just for the current 

user. 
9. Click Next. 
10. Choose between a Complete or Custom setup.  
• If you select Complete, all necessary program features will be installed. This option automatically installs all 

available languages. 
• If you select Custom, use the next screen to select or clear program features. 

 
To create a custom installation 
 

1. Click the hard disk icon to view four choices for the selected feature: 
This feature will be installed on local hard drive. 
This feature, and all subfeatures, will be installed on local hard drive. 
This feature will be installed when required. 
This feature will not be available. 

2. Select the options you want. 
3. To change the default installation directory, click the Change button and select the directory for the PrintShop 

Mail installation. 
 
With either selection you have the option to verify your installation settings.  
  
       11. After you have set the option you want, click Next. 
       12. Press Install to continue the installation wizard. 
       13. Click Finish. 
 
Mac OS 
 

1. Locate the PrintShop Mail 5.4.dmg file on the CD-ROM.  
2. Double click on this file. 
3. Select the language you want to use for the installation. 
4. Read the license agreement and select " Agree". (If you select " Disagree" , the installation will be canceled). 
5. A window will be displayed " Opening PrintShop Mail 5.4.dmg". 
6. You can drag the PrintShop Mail icon to the Applications folder or to any other location on your computer. 



 

12 

  

 

What is New in PrintShop Mail 
  
Getting Started with PrintShop Mail 
  

 
Click a heading to display information on these new features: 
 
Windows 
 
Printing 

• The Print Dialog has been further improved, for example: 
-It is possible to print a selected range of records and pages. 
-It is possible to create a PDF file by selecting the SoftProof PDF option. 

• Through PrintShop Mail Preferences panel it is possible to add archiving, emailing and faxing options for the 
PlanetPress Suite, allowing you to send PrintShop Mail output to a queue being watched by PlanetPress Watch. 

• Duplex printing in n-up documents has been further optimize.  
Variables 

• PDF files are now supported as variable image. For PDF files with multiple pages, you can select a page within 
a PDF. 

 
Documents 

• Color Management support has been added. 
• The Expression Editor has been further improved, allowing advanced users to enter expressions themselves 

and new users to start the Expression Assistant to compose their expressions. 
• It is possible to use Barcode plugin. 
• Layouts can be Centered on the page or you can create a Custom Offset. 
• It is possible to add bleed margin at Page Level, which is speciallyuseful for n-up documents. 
• It is possible to open a database without first closing the current database. When you open a new database, 

the currently opened database will be closed automatically. 
• Relative object position (anchoring) is now supported. 

 
 
User Interface 

• In the Edit menu a new Spot Colors submenu has been added. Spot Colors are special premixed inks used 
instead of, or in addition to CMYK inks. 

• In the Database menu a new Recent Files.. submenu has been added. 
 
 
 
Mac OS 
 
Printing 

• The Print Dialog has been further improved for user friendliness. 
• HotFolder log file can be opened from the Preferences. 
• Support for printing technology AHT has been implemented. 

 
Variables 

• USPS OneCode barcode support has been implemented. 
• Database handling has been further optimized. 

 
Documents 
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• Editing text properties (attributes) of multiple text objects at a time is now possible. 
• You can now store your favorite expressions in PrintShop Mail, making it possible to reuse expressions easily in 

other documents and export/import your favorites to other computers. 
 
User Interface 

• The user interface has been further improved, for example: 
-Text toolbar has been added. 
-Layout toolbar has been added. 

• From the PrintShop Mail menu, it is possible to change PrintShop Mail interface language, independent of the 
current operating system language. 
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Upgrading PrintShop Mail 
  
Getting Started with PrintShop Mail 
  

 
To use certain features in PrintShop Mail, for example automated printing which enables scripting of PrintShop Mail with 
API, Scripting or DDE , your hardware key must be upgraded before you are allowed to use this feature. When requesting 
an upgrade, the application will detect the upgrade options available. 
 
Single-user licenses as well as multi-user, or Network License are available. 
 
Single-User Licenses:  
 
Single-user license versions that are programmed for either an unlimited or a specified number of records are available:  

1. Unlimited or Production version, allows unlimited records to be printed.  
2. Limited or Standard version, allows 200,000 records to be printed.  

 
Multi-User Licenses (Windows only) 
 
A Multi-user license is a license that will allow multiple users to print a PrintShop Mail job simultaneously to a printer that 
is found within the Local Area Network (LAN).  
 
All Multi-user license versions allow for an unlimited number of database records to be merged.  
 
PrintShop Mail upgrade options 
 
Upgrade Options PrintShop Mail 6 Upgrades 

PrintShop Mail Version 
Upgrade 

Windows                   Macintosh  

PrintShop Mail 98                        Yes                       Not 
available 

 

PrintShop Mail 4.X                        Yes             Yes  
PrintShop Mail 5.X                         Yes             No  
     
PrintShop Mail Product 
Upgrades 

                       Windows                          Macintosh  

Standard or Production                       Yes                             Yes  
     
Technology Upgrade                        Windows                          Macintosh  
 Standard Production Standard Production 
Automated Printing Not available Yes Not available Not 

available 
 
To upgrade your hardware key  
 
From the Help menu, you can select from three different upgrade menu items: 

• Voucher   
• Upgrade request 
• Activate dongle 

 
Voucher 
 
If you have a PrintShop Mail voucher number, click on the "Voucher" option. A PrintShop Mail voucher web page will 
open. Here you need to enter the voucher number and some additional information to confirm the request.  
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Upgrade 
 
If you want to add credits, upgrade the version, add OL CARE or any other option to your hardware key click on the 
"Upgrade" option. The PrintShop Mail Upgrade page will open. Here you select the options you want and some 
additional information to confirm the request. 
 
Activate dongle 
 
If you have receive an Authorization code back from your voucher or upgrade request (by email), you have to copy that 
code into the Activate dongle screen. Then click "Activate". 
 
To view the hardware key  information, select Help/Credit Information. 
 
The Upgrade options are only enabled when the PrintShop Mail hardware key is attached to the computer where the 
upgrade procedure is performed. 
 
Older PrintShop Mail  documents 
 
The new versions of PrintShop Mail can read your existing PrintShop Mail documents, but PrintShop Mail documents 
created in older versions  will not be able to interpret the new PrintShop Mail document format. For more information, see 
How to Save a Document . 
 

 
To recognize new versions of PrintShop Mail, you  need to upgrade the hardware key. 
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Getting Started 
 

PrintShop Mail User Guide 
 
 
These are the basic steps to install PrintShop Mail and create PrintShop Mail documents.  
 
Click each topic to follow this step by step guide. 
 
Installing PrintShop Mail 

• Installation Procedure 
 
Step by Step Guide 
 

• Starting a New Document 
• Opening the Database  
• Inserting Static and Variable Images 
• Creating Variable Text 
• Layout Conditioning (also known as "page picking" ) 
• Selecting Paper Trays  
• Layout Repetitions 
• Print Preview 
• Verifying the Layout 
• Saving Your Document 

 
After you create and verify the PrintShop Mail document, it is ready to print or publish to PrintShop Web. 
 

• Choosing Your Printing Technology 
• Setting the Print Options 
• Publishing Documents 
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Installing a Printer Driver 
  
Getting Started with PrintShop Mail 
  

To produce PostScript output, PrintShop Mail must communicate with a PostScript printer driver. We recommend that you 
use either the Adobe or the Microsoft PostScript printer driver. 
 
Adobe PostScript Driver 
 
Printer installation using the Adobe PostScript driver requires the AdobePS installer and a PPD (PostScript Printer 
Description) file.  
 
The PrintShop Mail CD-ROM includes both the AdobePS installer and a set of commonly used PPD files. 
 
For more information about Adobe PostScript Driver, please visit www.adobe.com. 
 
Microsoft PostScript Driver (Windows only) 
 
You can install a printer using the Microsoft PostScript driver with the Add Printer wizard in the Windows Control 
Panel. The wizard prompts for an INF file containing printer specific information.  
 
The PrintShop Mail CD-ROM does not include INF files, but you should be able to acquire the correct files by contacting 
your printer manufacturer. 
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Installing the Hardware Key 
  
Getting Started with PrintShop Mail 
  

 
About the hardware key 
 
Without a hardware key, also known as "Dongle", PrintShop Mail runs in Designer mode. In this mode, all PrintShop Mail 
functions are available, but you can only print up to 25 records per session and PrintShop Mail is printed over each layout.  
 
If you have a hardware key from older versions of PrintShop Mail, it will need to be upgraded. Otherwise, PrintShop Mail 
will run in Designer mode. For more information, see Upgrading PrintShop Mail. 
 
This is a picture of the USB hardware key (though your key may differ slightly in appearance).  

      
You can use each credit on your hardware key to print one record.  
 
To install the hardware key  
 
Windows 
 
Attach the hardware key to the USB port on your computer.  
 
To view the amount of credits available on the hardware key: 
 

1. Start PrintShop Mail. 
2. From the Help menu, select Credit Information. 

 
Mac OS 
 
Attach the hardware key to the USB port on your computer.  

1. Start PrintShop Mail 
2. From the Help menu, select Install Dongle Software... 
3. Follow the instructions on the screen 

To view the amount of credits available on the hardware key: 
1. Start PrintShop Mail. 
2. From the Help menu, select Credit Information. 
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How to... 

 

Create a New Document 
 

How to... 
 
Windows 
 
You can create a new PrintShop Mail document in two ways: 

• Start with a blank layout 
• Base the contents and size of your layouts on a PDF or an image file.  

 
To start with a blank document 
 
On startup, PrintShop Mail always starts out with a blank layout. You can also instruct PrintShop Mail to create a new 
blank document by selecting New Blank Document from the File menu, or press CTRL+N. 
 
The size of this blank layout is set to Fit to Page. For more information on layout sizes, see How to Specify the Layout 
Size. 
 
Now you can use the design tools in PrintShop Mail to add static and variable objects to your layouts. For more 
information, see How to open a database, How to add images and How to add variable text. 
 
To base the layout contents on a PDF or image file 
 
From the File menu, select New PDF based Document, or press CTRL+SHIFT+N. This option also offers the possibility 
to import a Microsoft Word document, which will automatically be converted to a PDF file, using the current selected 
printer driver. This will create layouts that match the pages in the PDF file.  
 
Note: After you create a new PDF based document, the PDF pages are treated as separate objects. It is possible to scale 
the PDF pages around on the layout.  You can also place a PDF by choosing PDF from the Insert menu or click the 
Place PDF button in the Tools toolbar. Importing a PDF in this way allows you to not only proportionally scale, but also 
place the PDF anywhere on the layout. 
 
PrintShop Mail Templates 
 
PrintShop Mail allows you to create PrintShop Mail templates. Templates are PrintShop Mail documents that you can 
design for later use, for example for Publishing to PrintShop Web.  These templates contain the (background) layout and 
the document settings. 
 
Creating a template 
 
You can create a PrintShop Mail template in two ways: 

• From a PrintShop Mail document: 
 
1. Start PrintShop Mail. 
2. Create the desired PrintShop Mail document. 
3. From the File menu, select Save as Template. 
  

• New Template document: 
 
1. Start PrintShop Mail. 
2. From the File menu, select New Template-based Document. 
3. Browse for a template file. 
4. Click Open. 
5. Make the desired changes. 
6. From the File menu, select Save As Template. 

 
PrintShop Mail templates are saved with the extension ".PSMT". By default PrintShop Mail templates will be saved in the 
Template folder which is located in the PrintShop Mail application folder. 
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Modifying the template 
 
It is possible to modify PrintShop Mail templates to change the document settings or content. 

1. From the File menu, select Open Template.  
2. Make the desired changes. 
3. From the File menu select Save As Template. 

  
Note: A template does not save the link to the database you may have used in the designed stage of the PrintShop Mail 
document. 
 
Mac OS 
 
On startup, PrintShop Mail always starts out with a blank layout. The size of the blank layout is set to Automatic. To 
change the layout size, see How to Specify the Layout Size. 
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Default Settings 
 

How to... 
 
Default settings in PrintShop Mail are time savers. If the default settings don't fit the way you work, you may find yourself 
repeatedly customizing each document individually before you can get started.  
 
In PrintShop Mail it is possible to reset the default settings in the Preferences, to do that: 
 

1. Start PrintShop Mail.  
2. From the File menu, select Close. On startup, PrintShop Mail always starts out with a blank layout. 

(Windows): From the Edit menu (Ctrl+K), select Preferences. 
(Mac OS): From the PrintShop Mail menu (Command,), select Preferences. 

3. Make the appropriate changes. 
 
Note: Adjust the settings while no documents are open and those settings become the default for all new documents. 
Changes made while a document is open affect that document only. 
 
The  default settings that can be fine tuned for all documents are:  

• Program 
• Colors  
• Print Job  
• Repetition 
• Imposition 
• PrintShop Web 
• PlanetPress Suite 
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Specify the Layout Size 
 

How to... 
 
 
Windows 
 
A PrintShop Mail document may consist of one or more layouts, which can be of different sizes. PrintShop Mail supports 
multiple layout sizes within one document.  
 
On startup, PrintShop Mail always starts out with a blank layout. The size of this blank layout is set to Fit to Page. The 
layout size and shape (tall or wide) can be specified per each layout by selecting Size in the Layout menu or by 
selecting the layout in the Layouts Panel. 
 
Locating this dialog box 

Layout > Size 
 

 
 
The table below shows more information on the options in the Layout Size dialog. 
 
Setting Description 
Size Select a standard size for the PrintShop Mail document, A3, A4, A5, B5, US Letter, US Legal. Select 

Custom Size to enter customized settings. 
Width Enter custom width. This setting is editable if you select "Custom Size". 
Height Enter custom height. This setting is editable if you select "Custom Size". 
Shape Select either Tall or Wide. 
Apply to Current Layout 

This point forward 
Whole document 

 

 
PrintShop Mail supports mixed layout sizes, except when layout repetition is used. When using 
layout repetition, the first layout size will be the layout size for the complete document. 

 
 
Mac OS  
 
A PrintShop Mail document may consist of one or more layouts, all having the same size. There are two ways to specify 
the layout size and orientation. 
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Automatic Layout Size 
 
You can choose to base your layout size on the currently selected paper size in the Print Setup dialog, by selecting 
Layout Size Automatic in the Layout menu. This will cause PrintShop Mail to dynamically resize your layouts to fit on 
the paper, even when you are using layout repetition. 
 
Fixed Layout Size 
 
You can specify a fixed layout size in the Layout Size dialog. This will force your layout size to stay the same, 
independent of the currently selected printer and paper size. 
 
Locating this dialog box 

Layout > Size > Fixed 
 

 
 
The table below shows more information on the options in the Layout Setup dialog. 
 
Setting Description 
Size Select a standard size for the PrintShop Mail document, A4, A5, B5, US  Letter, US Legal. Select 

Custom Size to enter customized settings. 
Width Enter custom width. This setting is editable if you select "Custom Size". 
Height Enter custom height. This setting is editable if you select "Custom  Size". 
Orientation Select either Tall or Wide. 
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Specify Spot Colors 
 

How to... 
 
Spot Colors 
 
Spot Colors are special premixed inks used instead of, or in addition to CMYK inks. Spot Colors are used in offset printing 
to reduce printing cost or to provide solid colors that can not be exactly reproduced using process colors (such as CMYK). 
For example to be able to print colors like gold and silver,  some printers can accommodate an extra toner or cartridge 
filled with that dedicated ink.  
 
PrintShop Mail allows you to enable Spot colors in order to print the document with the desired colors. 
 
To define Spot Colors 

1. From the Edit menu, select Spot Colors. 
The Spot Color window is shown  
 
Spot Color " Name": A descriptive name is defined here. 
Separation "Name": The name of the ink/cartridge as known on the device (printer/RIP). 
Note:This must be identical to the name configured on the device. 
Alternate color: The Alternate color will be used at printing if the Spot Color is not available on the device 
and it will be used as the displayed color on the screen preview at design time. This color may be complete 
different from the actual Spot Color. 
  

 
2. Add a new Spot Color, click the New button. 
3. Type the Separation name. The actual name of the Spot Color as it is defined on your device. 
4. Select the desired Alternate color from the drop down list or create a Custom color. 
5. Click  Save. 

Spot Colors can be deleted via the Remove button. When a predefined color is used in the document it won't be 
possible to delete it from the color window list, it can only be modified.  
 
Note: Your specified Spot Colors will be saved with the document you defined the Spot Color for. The Spot Color will not 
be saved as an application setting. 
 
Spot Colors in EPS files 
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Spot Colors defined in EPS files are recognized and loaded in the Spot Color dialog as though it is defined in the 
document itself.  If a Spot Color defined in an EPS file has the same name as an already existing Spot Color definition but 
is in fact a different Separation, a warning will be shown. As a result the used Spot Color will be sent to the printer 
(unmodified) and depending on the availability of the Spot Color on the printer, the Spot Color or the Alternate color will 
be printed. 
 
Limitations 
 
There are some limitations based on the printer and PrintShop Mail capabilities. 

• Spot Color functionality in PrintShop Mail has as a limitation that only one Spot Color can be used per text 
object.  

• The number of Spot colors used in a document is limited to the printer capabilities. PrintShop Mail cannot 
determine if a Spot Color is available on the device. 

• Support for EPS with DCS (Desktop Color Separation) is limited to one separation in the DCS. If the EPS 
exceeds this limitation, PrintShop Mail will return a warning: "«filename».eps is a color separated file and might 
not print correctly. 

• When verifying a document, the verification results show all used Spot Colors in the document.  
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Link a Database to a Document 

 

Open a Database 
 

How to... 
 
 

 
For a list of supported database formats, see Support Database Formats. 

 
Traditional databases are organized by fields, records and files. A field is a single piece of information, a record is one 
complete set of fields and a file is a collection of records.  
   
Database example  
 

ZIP CAR CAR TYPE 
91335 Mustang A 
75038 Explorer B 
60173 Windstar C 
33351 Explorer B 

 
 Where ZIP, CAR, and CAR TYPE are fields and the rest are the records.  
 
To open a database 
 
Windows 

1. From the Database menu, select Open or press Ctrl+D..  
2. Browse for a database file.  
3. Alternatively to connect to a server based data source, in the left pane click the Data Sources (ODBC) icon. 
4. Double click a data source name. 

 
Note: You can define new data sources or modify existing data sources in the Data Sources (ODBC) dialog box. This 
dialog box is located in the Control Panel/Administrative Tools.  
   
Limitations:  

• PrintShop Mail only supports one active table at a time. If a database contains multiple tables, you will be 
presented with another dialog box prompting you to select one of the tables.  

• PrintShop Mail does not support relational databases.  
 

 
Data Fields 
For the purpose of publishing PrintShop Mail documents  to PrintShop Web, you can design a 
PrintShopMail document with or without linking it to a database. The entries you will find in the 
Data Fields panel in PrintShop Mail, represent data fields that occur in the document. These 
fields are either referred to in expressions (for variables or layout conditions, without the need 
to be directly linked to a database), or they refer to actual database fields (when the document 
is already linked to a specific database). Data Field Properties are relevant for Publishing to 
PrintShop Web. For more information about Data Fields, see Publishing Documents. 
 

To browse the contents of your database 
   
After you open the database, the contents are displayed in the Data Fields panel. You can view the complete path of the 
database location, by placing the mouse on the database name in the Data Fields panel. You can browse the records in 
the database by clicking the browse buttons in the Database toolbar, or by making the following selections from the 
Database menu:  

• First Record (ALT+Up) 
• Previous Record (ALT+Left)  
• Next Record (ALT+Right)  
• Last Record (ALT+Down)  
• Go to...Allows you to select an specific record. 
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To sort the database 
1. Select from the menu Database : Sort > Edit. 
2. Specify your sort conditions by selecting a database field from the drop down menu and specifying the sort 

order. 
3. Click OK.  

 
 
To filter the database 
You can set up a filter in the Database by selecting Filter > Edit from the Database menu, for example if you only need 
to print a certain range of ZIP codes (10000 up to 19999). 
   

 
 
You can choose from:  
 
Equals  
Does not equal  
Is less than  
Is less than or equal to  
Is greater than  
Is greater than or equal to  
Is empty  
Is not empty  
 
If you have more than one filter rule and you want ALL to be applicable, select AND to combine them.  
 
If you want either one or the other, select OR.  
 
Another way to filter the database is using Extended Scripting. See Extended Scripting for more information.  
   
Mac OS  

1. From the Database menu, select Open. 
2. Browse for the database file. 
3. Select the database file and click Open. 
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Using a Text File as Database 
 
The following rules apply when using a text file as database: 

• The first line in your text file should contain the field names. 
• Field names should only contain alphanumeric characters and underscores. 
• The records should be listed on the following lines. 
• The field separator is either a tab, a comma, a space, a semicolon or a user-defined character (not 

alphanumeric or underscore) and these separators cannot be used in field contents. 
• If a field contains a field separator character, it should be enclosed in double quotes in order to be treated as 

one string. 
• Two adjacent field separators  imply that an empty field is placed between them. 
• The record separator is a newline character. 
• Any missing fields at the end of a line are left empty. 

 
Opening a Text File as Database 
 

1. From the Database menu select Open. 
2. Browse to the folder where the database file is located. 
3. Select the text database file and click Open. 
4. Select the Separation mark you wish to use in the dialog box. 

To Sort the database 
 
You can define a large number of sort keys, which are applied to the opened database. Defining the sort keys and their 
precedence is done independently of switching on or off, as explained below. 

1. Open the Database floater and click the Edit button next to Sort checkbox. 
 

 
 

2. Select a database field in the list to the left and press Add button to copy it to the Sort Order list to the right. 
Double clicking the field name has the same effect. Repeat the steps with all the fields that you want to use as 
further sort keys. 
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3. It is possible to specify the Sort Order per selected field, which is either Ascending or Descending by 
selecting a sort key in the list to the right and dragging it up or down, or remove a sort key by selecting it and 
clicking Clear, or double click the sort key. 

4. Press Sort to sort the database and Ready to close the dialog. 
To Filter the database 
 
PrintShop Mail allows you to filter the database to which you wish to link a document. This implies that only a selection of 
the database is going to be used. 

1. Open the Database window and click Edit button next to the Filter checkbox. 
 

 
 

2. Enter an expression of which the result can only be true or false. 
3. Select Filter from the Database menu or click the Filter checkbox in the database window to apply your filter 

settings. Selecting or deselecting the filter option, toggles between using the entire database or using only the 
filtered records. The filter option is enabled only when the database is currently open. 
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Connect to SQL Server 
 

How to... 
 
Before you can connect to an SQL Server, you need to setup an SQL Server ODBC Data Source, as follows. 

1. In the Windows Control Panel , select ODBC Data Source Administrator. (In Windows  2000,  XP and 
2003 this panel is located under Administrative Tools). 
The ODBC Data Source Administrator window appears.  

 
 

2. On the User DSN tab, click Add. 
The Create New Data Source window appears.  
 
You are prompted to specify which driver to use for the data source. 
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3. Double click SQL Server. 
  

 
 

4. Type the data source name and description.  
5. Specify the SQL server name or IP address. 
6. Click Next. 
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7. Select With SQL Server authentication using a login ID and password entered by the user. 
8. Specify the logon ID and the password.  
9. Click Client Configuration. 

 
 

10. On the Add Network Library Configuration window, under Network Libraries, select TCP/IP. 
Note: Do not change the server name or port number unless otherwise specified by your system administrator.  

11. Click OK.  
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12. Select Change the default database to: and choose SQL Test (or the name you gave the data source).  
13. Click Next. 

 

 
 

14. Click Finish.  
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15. On the Microsoft SQL Server Setup window, review the options and click Test Data Source... to test the 
connection. 

16. To begin to use the data source in PrintShop Mail, click OK. 
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Add Text 

 

Add Variable Text 
 

How to... 
 
About variable text 
 
Text objects in PrintShop Mail can contain both static and variable text, separated by delimiters. By default, the @ 
character delimits variables. Each variable is associated with an expression. An expression is a calculation that is usually 
based on the contents of your database.  
   
To add variable text 
 
Note: As an alternative to the steps outlined below, you can also drag and drop directly fields from your database onto 
your layout. This automatically creates a text box and a variable name. 
 

 
1. In the Tools toolbar click the Place Variable Text button, or from the Insert menu select 

Variable Text. 
(Windows): From the Window menu, select Data Fields (Ctrl+3), or select Data Fields panel 
in the Properties Window. 
(Mac OS): From the Window menu, select Show Variables.  

2. Begin typing. Whenever you want to include variable information, type a meaningful name 
between two delimiting characters. By default, the @ character delimits variables. It is possible to 
change the delimiting characters in the Preferences. 

3. When you are finish click outside the text box. 
 
Variables you have defined, automatically appear in the Variables panel (Windows), or in the Variables floater (Mac 
OS). 

 
 
To assign database fields to the variables 
 
The next step is to connect the variables to fields in the database. To do this,  
   

1. (Windows): Double click on a variable in the Variables Panel to display the Expression Editor, or right 
click on the text object and select the variable in the Edit Expression submenu. 
(Mac OS): Double click on a variable in the Variables floater.  
Use the Expression Editor to assign an expression to the variable. 
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2. Double click on the database field to which to associate the variable.  
3. Click OK to close the window.  

 
Note: You can check the result of the expression in the Variables panel, or in the Variables floater (Mac OS).  
 
To preview the variables 
   
 In Preview mode, you can view the result in the text box itself. 
 

 
To toggle between Preview and Design modes, click this button in the View toolbar. Alternatively from the 
View menu, select Preview or press F2(Windows). 
From the View menu, select Preview or press Command + Y (Mac OS). 

 

 
 
You can change the text style (for example, font name, size, color and style properties) of any part of the text object 
from the Text Formatting toolbar, or from the Text menu. 
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Mac OS 
 

 
The "Remove Empty Lines" feature can be switched on using a checkbox in the Expression Editor 
Window. 
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Formatting Variables 
(Windows Only) 
How to... 

 
About formatting variables 
 
Formatting variables allows you to set how numbers, currencies and dates are displayed and printed. You can set this for 
each variable text object in the document, according to regional preferences. 
 
To format variables 
Choose the Variables panel and select a variable to specify its format settings. You can select the following format 
categories: 

• Number 
• Currency 
• Date 
• Text  
• E-mail 

 
 
Number  
 
The Number category has all number formatting options available on the system. 
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Set this option... To de this... 
Decimal Symbol Specifies the symbol that indicates decimal values. 
Decimals Places Specifies how many digits appear to the right of the decimal symbol. 
Digit Grouping Symbol Specifies the symbol that groups the digits in large values (for example: 

1,000,000). 
Digit Grouping Specifies how digits are grouped. 
Negative Symbol Specifies the symbol that indicates a number is negative. 
Negative Format Specifies how negative values are formatted. 
Leading Zeroes Specifies whether a zero appears before the decimal symbol in decimal values 

(for example, 0.7 or .7) 
 
 Currency  
 
The Currency category allows you to format a numeric value to be represented in currency format. 

 
 
Set this option... To do this... 
Locale This affects how number, currencies and dates are formatted. 
Currency Symbol Specifies the symbol that identifies the currency of a particular region. 
Positive Format Specifies how positive currency values are formatted. 
Negative Format Specifies how negative currency values are formatted. 
Decimal Symbol Specifies the symbol that indicates decimal values. 
Decimal Places Specifies how many digits appear to the right of the decimal symbol. 
Digit Grouping Symbol Specifies the symbol that groups the digits in large values. 
Digit Grouping Specifies how digits are grouped. 
 
Date  
 
The Date category lets you format a date when it is in the expected input format. The expected input format is 
"YYYYMMDD" 

 
 
Set this option... To do this... 
Locale This affects how number, currencies and dates are formatted. 
Date Format Specifies how dates will be formatted. 
Sample dd/MM/yyyy 
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Text  
 
The Text category is the default option a variable is set to. Setting the format to this category will have PrintShop Mail 
treat variable numeric content as a text string. 
 
E-mail  
 
Setting the format to this category will have PrintShop Mail to check if there is something missing in the format like "@" 
and "." 
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Creating Serial Numbers 
  
How to... 

 
About serial numbers 
 
Serial numbers are linked to the COUNTER function.  
 
To create a serial number 

1. In the Tools toolbar click the Place Variable Text button, or from the Insert menu select Variable Text. 
2. Insert a variable in the text box, for example @COUNTER@. 

(Windows): In the Variables panel, double click the variable you just created, or right click on the variable 
text box and select Edit Expression to open the Expression Editor. 
(Mac OS): From the Window menu, select Show Variables. 

3. Double click on the COUNTER function in the function list. The expression will be pasted into the Expression 
Edit field.  
  

 
 

4. Fill in the values you want the counter to generate. 
5. Click OK.  

 
For example: 
COUNTER(1, 100) creates a counter that starts with 1 and ends with 100.  
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Note: To create an indefinite COUNTER, simply double click the COUNTER function, after the expression is 
pasted into the Expression Edit field, click OK; the operator COUNTER() creates a counter that starts with 1 
and ends with whatever is set as the maximum number of "Items without Database" as set in the Programs 
Settings. 

 
To view the results, browse the records using the buttons of the Database toolbar. The counter displays 1, 
2, 3, and so on as you scroll through the records. 

 
Note: You do not need to open a database to use this function. 
       

 
When no database is open, you can change the total number of records, in the Database toolbar. 
To do this, enter the desired number of records and press Enter. 

 
To view an example that uses customized serial numbers, see Custom Serial Numbers. 
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Add Images 

 

Add Static and Variable Images 
 

How to... 
 
In PrintShop Mail, image objects can contain either static or variable images. Using variable images with PrintShop Mail 
allows you to personalize your documents with pictures. 
 

 
For a list of supported image formats, see Support Image Formats. 

 
About static images 
 
Static images are not linked to a variable, which means that they are always associated with the same image file. Print 
technologies use this fact to optimize print process time by only spooling static images once per job.  
 
To insert a static image 
 

 
1. In the Tools toolbar, click the Insert Image File button, or from the Insert menu, select Image 

File. 
2. In the dialog box, browse to the image to insert. 
3. Click Open. 

 
About bounding boxes 
 
The bounding box of a static image reflects the image size. When you resize the object, it retains its original aspect ratio. 
The initial size of an image depends on its resolution. PrintShop Mail assumes an image resolution of 96 DPI (Dots Per 
Inch), except for EPS (72 DPI) and TIFF files. The resolution of a TIFF image is stored in the file itself.  
 
About variable images 
 
Variable images are linked to variables in the same way as variable text. The result of the expression associated with a 
variable image should be an image file name. Print technologies optimize print process time by only spooling recurring 
variable images once per job.  
 
To insert a variable image 
 

 
1. In the Tools toolbar, click the Insert Image Box button, or from the Insert menu, select Image 

Box. 
2. Double click the name of your variable image in the Variables panel to display the Expression 

Editor. Alternatively right click on the variable image and choose Edit Expression. 
3. In the Expression Editor, define an expression or select a database file that contains the image 

filename. 

 
 
PrintShop Mail can use field information from the database to create variable images. This information is used in two 
ways:  
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• "As is" handling, uses field data to tell the Image Box what the image file name is. 
• "Trigger" handling, uses field data combined with a logic expression to create the image file name result. Both 

are used regularly for generating variable data. 
 
To insert variable images "As is" 
 
Database Setup  
  

ZIP CAR CAR PIC 
91335 Mustang Mustang.jpg 
75038 Explorer Explorer.jpg 
60173 Windstar Windstar.jpg 
33351 Explorer Explorer.jpg 

                                                      
Expression  
 
The "CAR PIC" field is used to tell the image box what the file name is: 
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To insert variable images "Trigger" 
 
Data Triggers can be alpha, numeric or symbol characters. The simplest way to setup a Trigger field is to use short 1 to 3 
digit character strings. 
 
Database Setup 
 

ZIP CAR CAR TYPE 
91335 Mustang A 
75038 Explorer B 
60173 Windstar C 
33351 Explorer B 

    
Expression  
 
IF([CAR TYPE] = "A", "Mustang.jpg", 
IF([CAR TYPE] = "B", "Explorer.jpg', 
IF([CAR TYPE] = "C", "Windstar.jpg",""))) 
 
The "CAR TYPE" field is used with a conditional logic formula to generate the image file name. 
 
To check and preview the results 
 
You can check the result in the Variables panel. The image is displayed in Preview mode. 
 

 
To toggle between Preview and Design modes, click this button in the View toolbar. Alternatively from the 
View menu, select Preview or press F2(Windows). 
From the View menu, select Preview or press Command + Y (Mac OS). 

 
Note: EPS images display in Preview only when they contain a TIFF-preview. This TIFF-preview may differ in quality from 
the printed output.  
 

 
To view the image objects properties, see Image Properties. 

 
To insert a PDF image 
 
You can insert a PDF file as a static PDF object or as a variable image object. The later allows for using variable pages 
within a (single) PDF document. 
 
To insert a PDF image as a static PDF object, you can: 

1. Drag and drop a PDF file to your layout, or 
2. from the File menu, select New PDF based document, or 
3. in the Tools toolbar, click the Insert PDF button, or from the Insert menu, select PDF... 

 

 
To view the PDF objects properties, click here. 

 
To insert a PDF file as a variable image object, you can:  

1. In the Tools toolbar, click the Insert Image File  button, or from the Insert menu, select Image File.  
2. In the Tools toolbar, click the Insert Image Box  button, or from the Insert menu, select Image Box. 

Click here to see how to insert a static or variable image. 
 

 
To view the image objects properties, click here. 
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Note: An image object can be linked to a single PDF file. As PDF files can contain multiple pages you can specify the 
page(s) to be used in your document through an expression, in this way you can use variable pages within that PDF file. 
 

 
 To learn about Color Management in PrintShop Mail, click here. 

 
 
Mac OS 

1. In the Tools toolbar, click the Place Variable Image button and drag a rectangle to the desired size on your 
layout, or from the Insert menu, select Variable Image.  

2. Double click the name of your variable image in the Variables window, to display the Expression Editor.  
3. In the Expression Editor, define an expression or select a database field that contains the image filename.  

 

 
PrintShop Mail for Macintosh converts the color space that is embedded in the image to the color 
space of the printer driver. You can check the color space of the printer driver, selecting from 
the File menu, Print/ColorSync.  
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Layout Conditioning 
 

How to... 
 
 
About layout conditioning 
 
Use layout conditioning to conditionally skip certain pages of your document or to leave them blank during the printing 
process. The PRINT and BLANK commands will not influence the amount of pages printed. 
 
There are three options for applying a condition to a layout: 

• PRINT: The layout will be printed (default). 
• BLANK: A BLANK page will be printed instead of the layout. 
• SKIP   : The layout will be skipped. 

 
To specify layout conditioning  
 
Select the layout for which you want to set the condition: 

• (Windows): It is possible to specify layout condition in three ways: 
 
1. From the Layout menu, select Edit Condition. 
2. Right click on the layout and select Edit Layout Condition. 
3. In the Layouts panel, select the layout and click on Action to Edit Condition. 
  

• (Mac OS): 
 
1. From the Windows menu, select Show Layout Conditions. 
2. From the Windows menu, select Show Variables and click on Layout Conditions.   

For example:  
 
Your document consists of two layouts:  

• Male audience target 
• Female audience target 

You want to create a one page newsletter. PrintShop Mail can use information from your database to determine whether 
to print a page, skip it, or leave it blank. 
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The expression used is: 
 
IF( [GENDER] = "M", Print, Skip)  
 
In other words, 
 
If the GENDER field equals "M", print the page, otherwise skip the page.  
 
Conversely, the expression for the layout that targets the female audience is:  
 
IF( [GENDER] = "F", Print, Skip)  
 
 

 
FreeForm does not fully support layout conditioning. In particular, it does not allow you to 
conditionally Skip layouts. When SKIP is used, a BLANK page will be printed instead. 
FreeForm 2 does not support SKIP in combination with layout repetition, the skipped layout will 
be left BLANK. 

 
 
When using layout condition in combination with layout repetition and SKIP is activated, the next layout will move to the 
position where the previous would have been positioned. 
 
To print Through-the-stack, set top priority (1) to Front to back, priority (2) to Top to bottom and priority (3) to Left 
to right. This way the first record is printed on the top left corner of the first page, the second record is printed on the 
top left corner of the second page, etc. This eliminates the need for collating after the job is printed. 
 

 
When you use layout condition SKIP for your PrintShop Mail documents with multiple layouts, or 
when you have applied variable Number of Copies, this may cause that the size of the record 
sets (the number of actual printed layouts per record) will be different per record set. This in 
turn may cause that some record sets will be split across  different stacks. 
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When Layout Conditions should be applied? 
• Output of multiple versioned documents within one PrintShop Mail file. 
• Layout Condition is an alternative for setting up text heavy variables (multiple variable paragraphs). Creating an 

expression formula within the  Variable text box using 1000s characters can be tedious. A simpler way is to 
create multiple static pages in native Desktop Publishing or Word processing programs, convert the documents 
into a usable PrintShop Mail file format (EPS or PDF) and from PrintShop Mail setup the conditions for the 
output. 

• Inserting blank pages 

 
For more information on expressions, see Expression Overview. 
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Layout Repetition 
 

How to... 
 
About layout repetition 
 
PrintShop Mail can print multiple layouts on media that has a larger format than the layout. For example, a postcard that 
is 5.5" x 4.25" can be printed 2 by 2 on letter-size paper (11" x 8.5"). 
 
To achieve this result, you can create a layout that is the size of 1 personalized document in this case, a postcard that is 
5.5" x 4.25". 
 
For a document with multiple layouts, you can print different layouts on the same page. 
 

 
PrintShop Mail supports mixed layout sizes, except when layout repetition is used. When using 
layout repetition, the first layout size will be the layout size for the complete document. 

 
 
To specify layout repetition 

1. (Windows): From the Edit menu (CTRL+K), select Preferences. 
(Mac OS): From the PrintShop Mail menu, select Preferences. 

2.  In the left pane, click on the icon Repetition. 
3.  Specify the number of repetitions for the layout, as well as the horizontal and vertical spacing between each 

layout. 
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Note: The maximum number of repetitions is displayed between brackets. This is dependent on the size of the layout 
and the selected media in the Page Setup. 
 
About priorities 
 
Priorities affect the order in which your database is going to be printed. Specify the priorities (1,2,3) and direction (Front 
to Back, Back to Front, Left to Right, Right to Left, Top to Bottom, Bottom to Top) to define the database order. 
 
 You can change priorities for each of the three dimensions: 

• Front to Back, Back to Front: To print Through-the-stack, set top priority (1) to Front to back, priority (2) 
to Top to bottom and priority (3) to Left to right. This way the first record is printed on the top left corner of 
the first page, the second record is printed on the top left corner of the second page, etc. This eliminates the 
need for collating after the job is printed. 

• Left to Right, Right to Left: Influences the horizontal repetition. 
• Top to Bottom, Bottom to Top: Influences the vertical repetition. 

 
When you use layout condition SKIP for your PrintShop Mail documents with multiple layouts, or 
when you have applied variable Number of Copies, this may cause that the size of the record 
sets (the number of actual printed layouts per record) will be different per record set. This in 
turn may cause that some record sets will be split across different stacks. 

 
When using layout repetition in combination with layout condition and SKIP is activated, the next layout will move to the 
position where the previous would have been positioned.  
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Select Paper Trays.... 
  
How to... 

 
About paper tray selection 
 
If your printer supports different paper trays and your document consists of multiple layouts, you can send different 
layouts to different trays. 
   
To associate a layout with a paper tray 
 
Windows 

1. From the File menu select Page Setup, or right click on the layout and choose Page Setup. Alternatively in 
the Properties panel, select Page Size.  
  

 
 

2. From the Tray box, select the desired paper tray. 
3. In the Apply to box select: 

 
Current layout: layout or layouts selected in the Properties Panel. 
This point forward: current layout and all layouts below it. 
Whole document: all layouts in the document. 
  

4. Click OK. 
 
If your printer supports more trays but they are not available in the Page Setup window, use the following steps to 
select a tray in the Advanced properties of the printer driver: 

1. From the File menu select Page Setup, or right click on the layout and choose Page Setup. 
2. Click on the Advanced tab. 
3. In the Printer Document Properties select Advanced. 
4. In the Printer Advanced Options select Printer Features. 

Note: The options outline above, must be repeated for each layout, if each layout need a different tray. 
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Another way to associate a layout with a paper tray is by selecting the layout in the Layouts panel, then select the 
Paper Tray property and choose the desired tray from the drop down menu. 

   
 
Mac OS  

1. From the Window menu, select Show Document Layouts. 
2. Select the desired layout. 
3. From the Layout menu, select Paper Tray. Depending on the selected PPD, a list with the available paper 

trays will be displayed. 
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Number of copies 
(Windows only) 

How to... 
 
 
PrintShop Mail allows you to print a number of copies per page. The Expression Editor can be used to generated 
multiple copies of each page in your document. 
 
To setup the number of copies 

1. Select the Layouts panel. 
2. Select the desired layout and click on Number of Copies, to open the Expression Editor. 

 

 
   
Data fields can be used to specify the number of copies per page. Field data not containing number strings can 
be used with logic functions such as the IF statement.  

 
Number Text String 
 

 
 
Once the Expression Editor is open: 

1. Double click on the VAL function from the function list. The expression will be pasted into the Expression Edit 
field. 

2. Select the string value of the database field containing the number of copies. 
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Non-numerical Text String 
  

 
  
In this case, the data field does not contain a number string, but it does have a field to be used as "Trigger". 
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In the expression "IF([TRIGGER]="A",VAL("12"),IF([TRIGGER]="B",VAL("8"),VAL("1"))) ", the field name "TRIGGER" has 
either an "A" or a "B" in it. The number of copies for "A" would be 12, and the number of copies for "B" would be 8. At 
the end of the expression, you need to add VAL("1"), because the function must result in a numeric value. 
 

 
When you use layout condition SKIP for your PrintShop Mail documents with multiple layouts, or 
when you have applied variable Number of Copies, this may cause that the size of the record 
sets (the number of actual printed layouts per record) will be different per record set. This in 
turn may cause that some record sets will be split across  different stacks. 

 
Limitations 

• The output result will be one copy if a single zero ("0") is used in any part of the Expression. 
• For multi-page documents, you need to set the number of copies per each individual  page. 
• Number of copies can not be used in combination with Layout Repetition. 
• Number of copies can not be used when FreeForm Print Technology is selected, use FreeForm 2 instead. 
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Verify a Document 
 

How to... 
 
About document verification 
 
Before printing your document, you can verify that it is ready to print.  
 
Verify document checks the document at two levels: 

• Layout level: Warnings at layout level will show the layout number in the Warnings panel. 
• Record level: Warnings at record level will show the layout number and record number in the Warnings panel. 

PrintShop Mail performs the following checks:  
• Are any images or PDF files missing? 
• Are all items placed within the printable area? 
• Does a text object contain more text than the text box can hold? For example, the following warning is 

displayed: "Text does not fit in its bounding box". You can prevent this warning from appearing again by 
resizing the text box or by linking the text box to another text box. For more information about linking text 
boxes, see Linking text objects. 

 
To perform document verification 
 
Warnings 
 
While you are working, PrintShop Mail will dynamically check for any possible errors on the layout and will display any 
occurring error in the Warnings panel, like: 
 

 
 
Verify Document 
 
When you select from the Layout menu, Verify Document, a progress bar will be displayed, showing the amount of 
records being checked. The warnings for the whole document will be listed in the Verification Results panel. 
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Note: Verify document will be stopped when 1000 warnings are found or when you press the Cancel button on the 
progress bar. 
 
Here is a list of a few possible messages: 
 
Object is placed beyond the printable area 
Object is not entirely placed on the layout 
Text file not found 
Variable X  is not linked to an expression 
Text does not fit in its bounding box 
Image X not found 
Error loading image 
Page number X is invalid; this PDF only contains Y pages 
Variable X: argument Y is invalid 
Variable X: barcode input string Y is invalid 
Variable X: date format Y is invalid 
X contains at least one TrueType font that is not embedded in 
the PDF 
Variable X: database field Y not found 
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Save a Document 
 

How to... 
 
 
About saving documents 
 
When saving a document, it is recommended to use one folder for both the document file and its supporting files that is, 
the image files and the database. The reason for this is because the supporting files for a PrintShop Mail document are 
not included in the document file. This file only contains references, stored as paths relative to the document folder.  
   
For example:  
If you save your document in...  
 "C:\My Documents"  
 
and it contains an image...  
"C:\My Documents\Images\Car.tif",  
 
the reference to this image is stored as...  
 "Images\Car.tif"  
 
If you move the Documents folder and its subfolders to another drive, PrintShop Mail will still be able to locate the 
image.  
   
Windows   
 
Note: PrintShop Mail 6.1 documents can be opened in all PrintShop Mail 6.X versions (downward/upward compatibility). 
You can import PrintShop Mail 98, 4.x, 5.x and 6.x documents into new versions of PrintShop Mail, but PrintShop Mail 98, 
4.x and 5.x will not be able to interpret documents saved by the new version of PrintShop Mail . If you try to overwrite an 
existing PrintShop Mail 98/4.x/5.x/6.x document in the new PrintShop Mail  format, PrintShop Mail will issue a warning.  
 
Mac OS 
 
Note: You can open PrintShop Mail documents created in PrintShop Mail 4.3.X or older, but PrintShop Mail 4.3.x will not 
be able to interpret documents saved by the new version of PrintShop Mail. If you open an existing PrintShop Mail 4.3.x 
document in the new PrintShop Mail format, PrintShop Mail will issue a warning, asking you whether you really want to 
save this document as soon as you close the document, even if you have not changed anything. 
 
To save your documents 
 
You can save a PrintShop Mail document in two ways: 

1. As a PrintShop Mail document, with the extension ".PSMD". 
From the File menu, select Save as. 

2. As a PrintShop Mail template, with the extension ".PSMT". 
From the File menu, select Save as Template. For further guidance in saving PrintShop Mail templates, see 
Create a New Document. 

To revert to the last saved version of the document, from the File menu, select Revert. 
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Publish to PrintShop Web 

 

Publishing Documents 
 

How to... 
 
 
PrintShop Web is an easy to use, powerful and open Web to print application that allows for printing over the Web. 
 
PrintShop Mail allows to prepare and add documents to PrintShop Web. PrintShop Mail documents are used as the basis 
for print jobs, meaning that it is possible to reuse the documents by uploading new databases. The designer can publish 
(upload) an existing or new document and customers will be able to use PrintShop Web to order print jobs based on this 
document. Print jobs can be previewed and validated before they are submitted to the printer. 
 
How to create PrintShop Mail documents for publishing 
 
You, "the designer"  create documents and templates in PrintShop Mail. 
 
When the document is ready for publishing, you can start the upload process by clicking on Publish to PrintShop Web 
selecting the File menu or clicking the Publish to PrintShop Web button in the Standard toolbar. 
 
You can design a document with or without linking it to a database. The variable data in the document preview in 
PrintShop Web will be based upon Data Fields that you assign in PrintShop Mail.  
 
Note: Keep in mind that when you design a template, the template does not save the link to the database. 
 
Data Fields are representatives for the variable data that can be provided either directly through a database that you 
link to a PrintShop Mail document, or through any other data source, for example a database which is uploaded by a 
PrintShop Web client or a web form. 
 
The entries you will find in the Data Fields panel in PrintShop Mail, represent data fields that occur in the document. 
These fields are either referred to in expressions (for variables or layout conditions, without the need to directly being 
linked to a database), or they refer to actual database fields (when the document is already linked to a specific database).  
 
When a data field is used in the PrintShop Mail document, it will have a check mark in the Data Fields panel.  
 
Example 
 

 
 
The Type column displays the type of data in the data field. "Default" means that at the moment no data source is 
available for this field. Once there is a data source available, the Type column will display the data type for that field, as 
specified in the data source, like number, text, etc. 
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Example 
 

 
 
By selecting a Data Field, you can view and edit its properties: 
 

 
 
Name: A unique identifier. You can not modify this value here. 
Default Value:  You can set a Default Value here, this will be a string value that will be displayed in PrintShop Web, 
once the document is published, as a placeholder when no data source is available (yet) for this Data Field. You will find 
this string value back in PrintShop Web, after the document has been selected (before the stage where a data source is 
provided). 
 
Note: When no database is (yet) available, this Default Value will be displayed as the current value in the Data Fields 
panel and in the text object in the layout, in case the data field is in use in the document: 
 

 
 
How to create a Data Field without opening a database? 

1. Create a variable: @variable@. 
2. Enter the Expression Editor by double clicking on the @variable@ in the Variables panel. 
3. Type: [My data field]. 
4. Click OK. 

Now you will find the data field back in the Data Fields panel. 
 

 
 
Remarks: You can define a Remark here, this will be a string value that will be displayed in PrintShop Web once the 
document is published. You can use this, for example, to give clients a hint about this variable data field. 
Source: The data source can be either "Database", a database uploaded by the PrintShop Web client, or "User input", 
data provided by for example a web form. 
 
Note:These Data Fields properties are only relevant for PrintShop Web, they will not affect the behavior of PrintShop 
Mail.  
 
How to publish documents from PrintShop Mail 
 
Publishing PrintShop Mail documents to PrintShop Web can be done from PrintShop Mail directly. 
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When publishing documents the first time, you will need to specify the URL and the login account for your company Web 
Server. 

1. Launch PrintShop Mail. 
2. From the Edit menu, select Preferences and click the PrintShop Web icon. To tell PrintShop Mail how to log 

on to your company Web Server, specify: 
URL: The Web address of your company.  
Login : The user name and password assigned by the administrator.  

 
 
Once you have specify all the necessary information to login to your company Web server, you can start publishing 
documents to PrintShop Web. The connection can be tested clicking the Test Connection button. It verifies only if all 
three options (URL, Username, Password) are valid. If no PrintShop Web Server address has been defined in the 
PrintShop Mail Preferences, the document and its attributes (images and fonts) will be saved in a zip archive (Publish to 
zip) for later publishing. 

1. From the File menu, select Publish to PrintShop Web or click the Publish to PrintShop Web button in the 
Standard toolbar.  
 
Before publishing PrintShop Mail documents, a document designer can add a note containing Operator 
Instructions about for example, duplex settings, paper weight etc. 
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2. A dialog Publish to PrintShop Web opens.  
3. Select the Publication Type where you want to place the document.  

 
In PrintShop Web documents are organized within Publications Types. Publication Types are a way to mark a 
document as being in a particular category (such as envelop, business cards, invitation etc). Each Company can 
have a range of Publication Types. Within the Company each Publication Type is unique. Each Publication Type 
can contain one or multiple documents.  
 
When a customer of a company logs on to the PrintShop Web web site all Publication Types available for that 
Company will be shown. 
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4. Click Next. 
5. On the next dialog click the Show Browser button to display the folder containing the image files.   

 
Note: Adding files is only necessary when variable images and txt/rtf files are used. If the document does not 
contain variable images or txt/rft files, the wizard will take you to step 7. 
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6. Select the additional files for the document and click the Add button.  
 
Note: In this dialog, you can choose to add variable image and .txt/.rtf files that belong to the document. The 
PrintShop Mail document, its used fonts and static images are added automatically. 
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7. Click Next.   
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8. Click Finish to publish the document. 
9. Once the message Successfully uploaded the new document appears, click OK. 

 

 
It is possible to upload documents made in older versions of PrintShop Mail WE to PrintShop 
Web through PrintShop Mail 5.2 and higher. 

 
If you have enough access privileges you can create a "New Company" and "Publication Type" from the Publish to 
PrintShop Web dialog in PrintShop Mail. 
 
How to create a New Company 
 
To create a New Company, do the following: 

1. In the Publish to PrintShop Web dialog click the New Company button. The New Company dialog appears. 
2. Enter the name for the company and click OK.  

 
New Company dialog 
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How to create a New Publication Type 
 
To create a New Publication Type, do the following: 

1. In the Publish to PrintShop Web dialog, select the company. 
2. Click the New Publication Type button. The New publication type dialog appears. 
3. Enter the name for the Publication Type.  

 
New Publication Type dialog 

 
 
More information about managing uploaded documents, Companies and Publication Types can be found in PrintShop Web 
Help. 
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Print a Document 

 

Printing Basics 
 

Printing your document 
 
About printing 
 
Print Preview 
 
While you are working on your document, it is possible to view an on screen representation of the printed output. In this 
Print Preview it is possible to browse through pages and view multiple layouts and records at the same time. 
 
You can enter the Print Preview mode in two ways: 

1. From the File menu, select Print Preview. 
2. Click the Print Preview toolbar button in the Standard toolbar. 

 
In Print Preview mode, four menu items are shown: 

• Page combo box: Allows you to select the view of a single page or multiple pages at the same time. By 
default you will see two pages horizontally and one vertically. 

• Print button: When you click this button, PrintShop Mail returns to the design view and the Print Dialog will 
be opened. 

• Close button: When you click this button, PrintShop Mail returns to the design view. Alternatively, you can 
close the Print Preview by pressing Esc, or by pressing Alt+F4. 

• Color softproof:  Allows you to display an on-screen preview of how your documents colors will look when 
reproduced on a particular output device. This feature is enabled when Color Management is activated. 

 
Zoom in on or out of a document 
 
You can "zoom in" to get a close up, more detailed view of your document or "zoom out" to see more of the page. 
 
To zoom in: 

• Left click inside the page, the pointer becomes a magnifying glass with a plus sign in its center. 
• Alternatively, press Ctrl++. 

To zoom out: 
• Press Ctrl while left clicking inside the page, the pointer becomes a magnifying glass with a minus sign in its 

center. 
• Alternatively, press Ctrl+-.  

   
You can also zoom in on or out of a document by holding down the Ctrl key while turning the mouse wheel.  

 
Browsing through the pages 
 
Pages will be automatically scaled to fit inside the window area (fit to window mode), unless you zoom in on one 
specific page (zoom in mode).  
 
In fit to window mode, only the vertical scroll bar will be active, this scroll bar controls which pages are currently 
visible. When you drag the thumb track control of the vertical scroll bar, PrintShop Mail will show a tool tip containing the 
page number associated with the current position of the thumb track. The scroll responds to PageUp, PageDown, up 
arrow, down arrow, Ctrl+Home, Ctrl+End and the mouse wheel. 
 
In zoom in mode, both the horizontal and vertical scroll bars can be active. These scroll bars control which part of the 
page is visible. They respond to up arrow, down arrow, Ctrl+Home, Ctrl+End, and the mouse wheel. By pressing PageUp 
you will jump to the previous page and by pressing PageDown you will jump to the next page. 
 
After you have finished designing and  verifying your document, the document is ready to be printed. Before you do the 
actual printing,  PrintShop Mail offers different ways to optimize your output, allowing you to select how many pages or 
records you want to print. Additionally, you may wish to print the currently selected record, or proof your document in 
PDF format before printing. To do this, click on the File menu and select Print to open the Print Dialog. 
 



 

70 

Print Dialog Options 
1. Operating System Default Print Options 

 
Printer: The printer you wish to print to. 
Printer Properties: Controls printer options, for example layouts options and paper quality. 
Print to File: Instruct the printer driver to print to a file on the disk, instead of the printer. 
Number of copies: Indicates the number of copies you wish to print of each page. If the value is set to one, 
only the original page will be printed. The Collation option will be ignored by PrintShop Mail. 
  

2. PrintShop Mail Print Options 
 
Print: From the drop down menu you can select the following options: 
 

 
 
All Records: By default "All Records" is selected. This option allows you to print the complete job. Behind this 
selection the amount of available records is displayed. 
Record Range: This option allows you to print a certain range of records. 
Note: If the range of records you wish to print exceeds the number of records available, a message will be 
displayed until the amount of records is equal or less than the total amount of records available. 
Page Range: This option allow you to print a certain range of pages. 
Note: When using layout repetition and you select this option the complete number of pages need to be 
calculated to output the correct pages. 
Current Record: This option allows you to print the selected record, using Standard PostScript print 
technology. No Credits will be charged from your hardware key. 
SoftProof PDF: This option generates a PDF file of the current record. No Credits will be charged from your 
hardware key. 
Note: SoftProoof PDF requires a PostScript printer driver in order to work properly.    
Report Page: This option allows you to print a Report Page. No Credits will be charged from your hardware 
key.  
Split job: This option allows you to split the job in several outputs. 
  

3. PrintShop Mail specific Print Technologies Options 
 
Print Technologies 
 
Because every print technology uses PostScript Level 2, PrintShop Mail requires the use of a PostScript printer driver and 
a PostScript Level 2 compatible RIP. 
 
Some technologies are based on the PostScript standard, which means that they are supported by every type of RIP 
available. Other technologies are based on extensions of PostScript, which are only supported by specific RIP types. 
 
Printing  Technologies: 
 
Standard PostScript             
Optimized PostScript 
 
RIP type and vendor dependent technologies: 
 
AHT                        
Creo VPS  
EVIPP 
Fiery FreeForm 
Fiery FreeForm 2 
PPML 
PPML/VDX 7           (Windows only) 
PrintStreamer         (Mac OS only) 
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To select a print technology 

1. (Windows): From the Edit menu (Ctrl+K), select Preferences.  
(Mac OS): From the PrintShop Mail menu (Command,), select Preferences.   

2. In the left pane, click the Print job icon.  
The Print job settings dialog box appears. 

3. Check if your RIP supports one of the RIP type and vendor dependent technologies. If so, you can select that 
specific technology. If not, it is advisable to select Optimized PostScript.  

 
To specify technology specific options 

1. From the File menu, select Print.  
2. On the Print dialog box, specify technology specific options .   

 
Print dialog box settings  
 
Use OPI, don't spool images: Most print technologies support OPI (Open Prepress Interface), allowing you to use an 
image substitution server to speed up the printing process. OPI only supports the image formats EPS and TIFF. 
 
Store forms on printer's hard disk: Storing PostScript forms (cached reusable content) on hard disk will prevent out 
of memory conditions if your document contains large high resolution images. Only use this option if your RIP has access 
to a hard disk. 
 
Custom cache size: Increasing the PostScript form cache size can help to improve performance. You may want to 
experiment in order to determine the optimum value. Specifying a custom cache size only works if the system settings of 
your RIP are not password protected. 
 
Note: If you use the options "Store forms on printer's hard disk" or "Custom cache size", and the RIP is password 
protected you might get a printer error. Consult the RIP manual or consult the system administrator to change the 
settings on the RIP. 
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Print Technologies 

 

Standard PostScript 
 

Print Technologies 
 
Standard PostScript does not use any special optimization mechanism, except that you can use  OPI  to speed up 
spooling.  
 
Use this technology if your system does not support any of the other technologies. 
 
Print dialog box settings 

1. Use OPI, don't spool images 
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Optimized PostScript 
 

Print Technologies 
 
Optimized PostScript caches image data in reusable PostScript forms. This speeds up the printing process, since each 
unique image is only sent once. 
 
Note:Some printer drivers offer the  possibility to change the PostScript Output Options: "Optimize for Speed" or " 
Optimize for Portability".  For a maximum print speed, change the PostScript Output Option to "Optimize for Speed". 
You can find this property, in the Printer driver/Advance Options. 
 
Print dialog box settings 

1. Store forms on printer's hard disk 
2. Custom cache size 
3. Use OPI, don't spool images 
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AHT 
 

Print Technologies 
 
Select this technology if you have an AHT RIP. AHT uses an optimization mechanism similar to Optimized PostScript. 
 
Print dialog box settings 

1. Store forms on printer's hard disk 
2. Custom cache size 
3. Use OPI, don't spool images 
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Creo VPS 
 

Print Technologies 
 
VPS (Variable Print Specifications) is a PostScript language extension, created and maintained by Creo.  
 
It allows PrintShop Mail to classify each element on a page as either reusable (occurring more than once) or inline 
(occurring only once). This distinction allows the VPS RIP to decide when image data can be reused. This avoids 
unnecessary repeated processing and speeds up the print process. 
 
One of the main differences between Optimized PostScript and VPS is that VPS reuses rasterized data instead of 
PostScript. 
 
Print Technology specific settings 

1. Generate booklets:  Booklets enable the printer to apply finishing (for example, stapling or binding) to every 
subset. A subset is a set of pages belonging to the same record. If your document contains three layouts, every 
subset will consist of three pages,  assuming that you're not using layout conditioning or layout repetition. 

2. Use Automatic Picture Replacement:  Automatic Picture Replacement (APR) allows you to speed up the 
printing process by using the image substitution capabilities of your VPS RIP. The image format support of APR 
is limited to EPS, but some RIP versions support other formats like TIFF and JPEG. 
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Fiery FreeForm 
 

Print Technologies 
 
FreeForm makes use of the fact that the data in your document is divided in two layers, which contain the text and image 
objects in the document. 
 
The master layer in a FreeForm job consists only of "static" objects, but the variable layer can contain a mix of both 
variable and static objects, depending on the order of the objects on your layout. This is a consequence of the fact that 
FreeForm does not allow data in the master layer to be printed on top of data in the variable layer. 
 
These layers are sent to the FreeForm RIP in two separate jobs, not necessarily at the same time. The master data job is 
rasterized first, and stored under a user defined numeric ID. The RIP overlays the rasterized master data with the 
rasterized data of any variable data job that references the same ID. In this way, you can reuse the same master data for 
different variable data jobs. 
 
How the objects are separated 
 
Static objects have content that remains constant throughout the entire record set. An image object is static when it has 
an expression with a constant result. A text object is static when it does not contain any variable markers. A PDF object is 
always static. All other objects are considered to be variable. A variable object is reusable when its content is the same 
for at least two different records in the record set. 
 
At printing, PrintShop Mail tries to assign as many static objects to the master layer as possible, starting with the object 
at the back of your layout, and working towards the front. All static objects up to (but not including) the first variable 
object are put in the master layer. All other objects make up the variable layer. Any reusable data in the variable layer will 
be cached in PostScript forms. 
 
Note: When using Freeform, try to make sure that static objects are not placed on top of variable objects in the object 
order on your layout. 
 

 
FreeForm does not fully support layout conditioning. In particular, it does not allow you to 
conditionally skip layouts. When SKIP is used, a BLANK page will be printed instead. 

 
Preference settings 
Form number: A numeric ID used to identify the master data job. 
 
Print dialog box settings 

1. Store forms on printer's hard disk 
2. Custom cache size 
3. Use OPI, don't spool images 

 
Print Technology specific settings 

1. Send Master data 
2. Send Variable data 
3. Send Master and Variable data 
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Fiery FreeForm 2 
 

Print Technologies 
 
FreeForm 2 makes use of the fact that the data in your document is divided in two layers, which contain the text and 
image objects in the document. 
 
The master layer in a FreeForm 2 job consists only of "static" objects, but the variable layer can contain a mix of both 
variable and static objects, depending on the order of the objects on your layout. This is a consequence of the fact that 
FreeForm 2 does not allow data in the master layer to be printed on top of data in the variable layer. 
 
These layers are sent to the FreeForm 2 RIP in two separate jobs, not necessarily at the same time. The master data job 
is rasterized first, and stored under a user defined numeric ID. The RIP overlays the rasterized master data with the 
rasterized data of any variable data job that references the same ID. In this way, you can reuse the same master data for 
different variable data jobs. 
 
How the objects are separated 
 
Static objects have content that remains constant throughout the entire record set. An image object is static when it has 
an expression with a constant result. A text object is static when it does not contain any variable markers. A PDF object is 
always static. All other objects are considered to be variable. A variable object is reusable when its content is the same 
for at least two different records in the record set. 
 
At printing, PrintShop Mail tries to assign as many static objects to the master layer as possible, starting with the object 
at the back of your layout, and working towards the front. All static objects up to (but not including) the first variable 
object are put in the master layer. All other objects make up the variable layer. Any reusable data in the variable layer will 
be cached in PostScript forms. 
 
Note: When using Freeform 2, try to make sure that static objects are not placed on top of variable objects in the object 
order on your layout. 
 
FreeForm 2 is an extension of FreeForm. The difference are: 

1. FreeForm 2 fully supports layout conditioning. 
2. The FreeForm 2 master ID consist of a name instead of a number. 

 
Preference settings 
Master ID: A name used to identify the master data job. 
 
Print dialog box settings 

1. Store forms on printer's hard disk 
2. Custom cache size 
3. Use OPI, don't spool images 

 
Print Technology specific settings 

1. Send Master data 
2. Send Variable data 
3. Send Master and Variable data 
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PPML 
 

Print Technologies 
 
PPML is short for Personalized Printing Markup Language . A PPML file describes the entire personalized printing job and 
contains all necessary elements to print the contents (layout and variable data). 
 
The technology PPML in PrintShop Mail is very similar to PPML/VDX. The difference is that the content (PDF) and page 
layout description (PPML) are sent separately. 
 
Windows 
 
Print Technology specific settings  

1. Create ZIP archive: When checked, the PDF and PPML files will be zipped before being sent to the printer. 
This option is used for specific printers, which expect a PPML-ZIP file. The ZIP file contains the PPML and the 
PDF file. 

2. Embed images in PDF: When checked, only the following images formats are supported: pdf, eps, tiff, jpeg 
and gif. 

3. Environment: The path specified in the Environment setting will place the images with a "Global Scope" in the 
Environment. The Consumer (RIP) stores and/or caches the images for later use. 

4. Send. 
 
4.1- Send "All Images": A PDF file will be created containing images that have a "Global Scope" or a "Local 
Scope". This option also creates a PPML job, using this PDF, with instructions to use the Local and the Global 
images. Images with a "Global Scope" are stored in the specified Environment. After this job the "Global 
images" can be reused for recurring print projects, for example with the option "Send Local Images". 
 
4.2- Send "Global Images": A PDF file will be created containing images that have a "Global Scope". This 
option also creates a PPML job, using this PDF, with instructions for storing these images into the specified 
Environment. 
 
4.3- Send "Local Images": A PDF file will be created containing images that have a "Local Scope". This option 
also creates a PPML job, using this PDF, with instructions to use these Local images and the Global Images that 
are stored in the specified Environment. For that reason, images that have a "Global Scope" should be present 
in the specified Environment. Images with a "Global Scope" will only be referenced in the PPML job. 

Note: The settings "Environment" and "Send" should not be changed when you are not familiar with PPML terms! 
 
For more information about PPML, visit the Website of PODi (Print On Demand Initiative), http://www.podi.org. 
 
PrintShop Mail offers an option to define if an image should have a "Global Scope". If the Global Scope of an image is 
set to "Yes" in the Properties Panel, the image will have a "Global Scope". For recurring print projects, a central benefit 
of PPML is its ability to reference Reusable Objects using Global Scope. This feature allows for transmitting smaller 
datasets and eliminates repetitive processing of the reusable content.  
 
Note: Please make sure that your RIP supports at least PPML 1.5, including the "application/pdf" source format. 
 
Printing speed can be improved by using a "Global Scope" for one or more images, or possibly (depending on your RIP) 
by unchecking the "Embed images in PDF’" checkbox in the Print dialog. 
Using a "Global Scope" or unchecking "Embed images in PDF" requires that your RIP supports the image formats used in 
your document. Please consult the following table and your RIP documentation, or contact the RIP manufacturer. If you 
are not sure, send a small test job before submitting a larger job. 
 
Image Source Format 
PDF an EPS application/postscript 
TIFF image/tiff 
JPEG image/jpeg 
GIF image.gif 
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Mac OS 
 
For Macintosh there is an option "PPML.zip" in the print dialog (File > Print > PrintShop Mail). This option will include all 
images. It will make a copy of all the images used in the PrintShop Mail job. If the option "PPM.zip" is unchecked you will 
output a PPML file that has a reference to the images that are used in the job. 
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PPML/VDX 7 
(Windows only) 

Print Technologies 
 
PPML/VDX is an abbreviation for Personalized Print Markup Language/Variable Data Exchange. The output consists of an 
optimized PDF in which reusable content elements occur only once. The PDF also contains a block of PPML data that 
describes the page layout. 
 
Note: PPML/VDX 7 requires both Adobe Acrobat(r) and Distiller(r) to be installed on your system.  
 
To help ensure correct output there are "PSMail joboptions" files for the Acrobat Distiller versions 5, 6, or 7  in the 
Printshop Mail installation folder. 
These settings will tell Acrobat Distiller how to handle fonts, color, images, etc., when it creates the optimized PDF. 
If so desired, you can change these output options for PPML and VDX by changing the Distiller joboptions. Double click on 
the "joboptions" file you want to modify, change and save it.  
 
Note:  PSMailx.joboptions files should be saved in the PrintShop Mail installation folder, next to the executable. The "x" 
specifies the Acrobat Distiller version that the file corresponds to. 
 
More information about the Acrobat Distiller joboptions can be found in the online Help of the Acrobat Distiller. 
 
Print Technology specific settings 

1. Environment: The path specified in the Environment setting will place the images with a "Global Scope" in the 
Environment. The Consumer (RIP) stores and/or caches the images for later use. 

2. Send  
 
2.1- Send "All Images": A PDF file will be created containing images that have a "Global Scope" or a "Local 
Scope". This option also creates a PPML job, using this PDF, with instructions to use the Local and the Global 
images. Images with a "Global Scope" are stored in the specified "Environment". After this job the "Global 
images" can be re-used for recurring print projects, for example with the option "Send Local Images". 
 
2.2- Send "Global Images: A PDF file will be created containing images that have a "Global Scope". This 
option also creates a PPML job, using this PDF, with instructions for storing these images into the specified 
Environment. 
 
2.3- Send "Local Images": A PDF file will be created containing images that have a "Local Scope". This 
option also creates a PPML job, using this PDF, with instructions to use these Local images and the Global 
Images that are stored in the specified Environment. For that reason, images that have a "Global Scope" should 
be present in the specified Environment. Images with a "Global Scope" will only be referenced in the PPML job. 
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PrintStreamer 
(Mac OS only) 

Print Technologies 
 
This printing technology sends two separate files to the RIP, one master file and one with variable data. 
 
Print dialog box settings 

1. Use OPI, don't spool images 
Print Technology specific settings 

1. Send Master and variable data 
2. Send Master data 
3. Send Variable data 
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VIPP 
 

Print Technologies 
 
VIPP is an acronym for Variable data Intelligent PostScript Printware. The output of this technology consists of a 
PostScript stream in which reusable images occur only once. 
 
The main difference between VIPP and Optimized PostScript is that images are cached using a proprietary VIPP specific 
mechanism instead of PostScript forms. The cached images are stored in print ready format. 
 
Print Technology specific settings 

 
1. Don't spool images (EPS, TIFF, JPEG): This option allows you not to send the recurring images twice to the 

RIP. The output will only contain references (by filename) to images stored in the project folder.  
2. Project Folder:This option allows you to store recurring images on the fly, and before printing the job, to a 

"project folder" on the (VIPP enabled) RIP. The folder name can be specified in the Print Dialog. 
Encapsulated VIPP supports the following image formats: JPEG, TIFF, EPS and PDF. 
 
Note: This technology requires a RIP that has been enabled for Encapsulated VIPP, and a hardware key that has been 
upgraded to enable  VIPP. For more information on how to upgrade the hardware key, see Upgrading PrintShop Mail. 
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Page Setup 
 

Printing your document 
 
The Page Setup of your document, allows you to specify which printer to print to, the paper size, source, and other 
characteristics of your print media. 
 
The settings in the Print dialog are applied to the current print job only, but the settings in the Page Setup dialog will 
be stored in your document file. 
You can specify a different Page Setup for each layout, but you can only send layouts to one printer. This allows you to 
mix paper sizes (Windows only), orientations, media types, and finishing options throughout your document, provided 
that this is supported by your printer. 
 
Windows 
 
There are different ways of changing the Page Setup: 

1. From the File menu, select Page Setup, and choose either:  
 
Selected Layouts: layouts selected in the Layouts window. 
Current layout: layout selected in the Layouts window. 
This point forward: current layout and all layouts below it. 
Whole document: all layouts in the document. 
  

2. Select the Layouts tab in the Properties panel, select one or more layouts, select Page Size, and click on 
the [...] button. 

3. Right click on the layout and select Page Setup to open the dialog. 
Use the Page Setup dialog box to specify printer options, as well as the media your job will be printed on. 
 
Mac OS 
 
To change the Page Setup: 

1. From the File menu, select Page Setup. 
2. In the dialog box, you can change: 
• Settings 
• Format 
• Orientation 
• Scale 

Use this dialog box to specify printer options, as well as the media your job will be printed on. 
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Subset Finishing 
 

Printing your document 
 
About subset finishing 
 
Subset finishing is the process of applying a finishing option (such as stapling or binding) to each subset in a print job. 
 
PrintShop Mail defines a subset as a set of pages belonging to the same record. If you are not using layout repetition or 
layout conditioning, the number of pages in each subset will equal the number of layouts in your document. 
 
To use subset finishing 
 
You can specify a finishing option in the printer driver, using the Properties button in the Print dialog or using the 
Advanced button in the Print Setup dialog box. 
 
PrintShop Mail can embed certain PostScript instructions in the output to signal that the finishing option should be 
applied.  
 
You can specify which instructions to embed in the Embed PostScript dialog box.  
 
It is possible to write your own PostScript set and save them. If you go to New you can give the PostScript set a name. 
The given instructions at the "Start of Page", "Start of Job" and "Between Sets" will be saved. You can also turn it to the 
default setting by selecting the button "Set Default". 
 
Locating this dialog box 

File > Embed PostScript 
 
There are 4 options: 

1. General: This option can be used to give the PostScript set a "Name" and write a "Description". 
2. Start of Page: These instructions will be injected at the start of each page. 
3. Start of Job: Instructions given there will be injected in the header of the job. 
4. Between Sets: Instructions given in this field will be injected between the sets. 

For stapling or binding, the default setting (Generic Subset Finishing) should suffice. 
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Automated Printing 

 

Automated Printing Overview 
 

Printing a Document 
 
About automated printing 
 
PrintShop Mail allows you to automate certain tasks, such as opening and printing documents. 
 
Windows 
 
When you right click on a PrintShop Mail document file in a Windows Explorer window, you will notice that the menu 
contains the submenu Print. You can print the document without starting PrintShop Mail, and you can drag a PrintShop 
Mail document to a specific printer. 
 
More advanced ways of automate the printing process is to use one of the next available features: 

• Automated Printing using Command-line Arguments 
• Automated Printing using Extended Scripting 
• Automated Printing using DDE 

 

 
To be able to use this feature, you need to activate the automated printing option. See 
Upgrading PrintShop Mail to learn how to add this feature to your license. 

 
Note: When using automated printing, any errors will be logged in the Autoprint.log file, which usually is located in: 
C:\Documents and Settings\User\Application Data\PrintShop Mail.  
 
If you have installed .NET Framework 2.0, the errors will be logged in the Event Viewer.  
To open the  Even Viewer: 

• Start/Run/eventvwr.msc, or 
• Start/Control Panel/Administrator tools/Event Viewer 

 

 
Automated printing allows you to print PrintShop Mail documents and PrintShop Mail templates 
automatically through the Command line or script file . Make sure to use the appropriate 
extension (<document name>.psmd or <document name>.psmt) in the Command line or in the 
script file. 

  
Mac OS 
 
PrintShop Mail allows you to automate the printing process to a high extend. Instead of opening a document in PrintShop 
Mail and selecting the "Print" submenu, the program can be told to monitor a HotFolder and execute print jobs as soon as 
the necessary files (a PrintShop Mail document and/or a database file) are found there. 

• Automated Printing using the HotFolder 
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Command Line Arguments 
(Windows only) 

Automated Printing 
 
You can order PrintShop Mail to perform certain actions by specifying them on the command line.  
 
Supported command line arguments 
 
Argument Description 
<document name> Filename of a PrintShop Mail document. 

Example: Mailing November.psmd 
-p Prints the specified document to the default printer. 

Example: Mailing November.psmd -p 
-pt Prints the specified document to a specific printer, enclosed in quotes.  

Example: Mailing Novembert.psmd -pt "Laserwriter 16/600" 
-db <database> Links the specified document to a certain database.  

Example: Mailing November.psmd -db "Database.mdb" 
       
How to use command line arguments 
 
A simple example using command line arguments can be created by following the next steps: 

1. Create a PrintShop Mail document, for example "Sample.psmd" 
2. Create a database you wish to use with this document, or copy an existing database to the folder where you 

saved the PrintShop Mail document. 
3. Create a shortcut to the PrintShop Mail executable usually located at "C:\Program Files\PrintShop Mail6 

\PSMail6x.exe". Copy this shortcut to the same folder as you saved the document you created in step 1. 
4. Right click on the shortcut and choose Properties. In the field Target, specify the document name by adding 

it to the target. It should look something like "C:\Program Files\PrintShop Mail6\PSMail6x.exe" Sample.psmd". 
If you double click on the shortcut you've just created, PrintShop Mail will be started and the specified document will be 
opened. You are now ready to use any of the other supported command line arguments by adding them to the target. 
 
A few examples 
 
"C:\Program Files\PrintShop Mail6\PSMail6x.exe" Sample.psmd -db "Database.mdb" 
 
"C:\Program Files\PrintShop Mail6\PSMail6x.exe" Sample.psmd -p 
 
Dropping a database on a shortcut 
 
You can create a shortcut that will make PrintShop Mail open any supported database you drop on it, by specifying the 
next text in the target field of the Shortcut's properties: 
 
"C:\Program Files\PrintShop Mail6\PSMail6x.exe" Sample.psmd -db 
 
If you drop a database on the shortcut, PrintShop Mail will be started, opening the document "Sample.psmd"  with the 
database you just dropped. 
 

 
Automated printing allows you to print PrintShop Mail documents and PrintShop Mail templates 
automatically through the Command line or script file . Make sure to use the appropriate 
extension (<document name>.psmd or <document name>.psmt) in the Command line or in the 
script file. 
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Extended Scripting 
(Windows only) 

Automated Printing 
 
Extended Scripting is a fast and flexible way of automating your print jobs. This feature allows you to print any PrintShop 
Mail document, combined with any database to any printer. You can even schedule an Extended Scripting job on a certain 
date and/or time where your printer is usually idle. 
 
You specify a certain action, or a range of actions, in a plain text file and tell PrintShop Mail to use that file by adding it to 
a shortcut: 

1. Create a shortcut to the PrintShop Mail executable usually located at "C:\Program Files\PrintShop 
Mail6\PSMail6x.exe".  

2. Add "-script scriptfile.txt" to the Target in the properties of the shortcut. 
Note: When the script file has a name with spaces ("My<space>Script.txt") be sure to enclose this file name with quote 
marks ("") in the Target line of the PrintShop Mail shortcut: "C:\Program Files\PrintShop Mail 6\PSMail6x.exe” -script “My 
Script.txt”. Include the quote marks if you copy this line. 
 
In the script you can specify a set of predefined commands to perform certain actions. 
 
Supported Commands 
 
Command Description 
FileOpen name Opens the specified document. If another document is opened, it will be closed by 

PrintShop Mail. Example: FileOpen C:\Documents\MassMailing.psmd 
Opens the PrintShop Mail document MassMailing.psmd from the folder C:\Documents. 

FileClose Closes the currently opened document. 
Example: FileClose 

FilePrint Prints the currently opened document to the default printer. 
Example: FilePrint 

FilePrintTo printername Prints the currently opened document to the specified printer. 
The name of the printer should equal the name specified in the Printer's properties. 
Example: FilePrint Adobe PDF 
Prints the currently opened document to the Adobe PDF printer. 

SetPrintTech technology Will change the current print technology. 
Example: SetPrintTech Standard 
If the document was saved using Optimized PostScript as PrintTechnology, SetPrintTech 
Standard will print the document using Standard PostScript as Print Technology. 

FilePrintRange start stop Prints the specified record range to the default printer. 
Note: It is not possible to print a record range to a non-default printer. 
Example: FilePrintRange 5 10 
Prints record 5 to 10 from the currently opened document. 

FileExit Quits PrintShop Mail. No other scripting commands followed by this command are 
executed. 
Example: FileExit 

DatabaseOpen file Opens the specified database. If any other database is opened, it will be closed by 
PrintShop Mail. 
Example: DatabaseOpen C:\Documents\Example.mdb 
Opens the Microsoft Access database "Example" from the folder C:\Documents. 

DatabaseOpenODBC 
source 

Opens the specified data source. If any other database is opened, it will be closed by 
PrintShop Mail. 
Example: DatabaseOpenODBC MyDSN 
Opens the data source called "MyDSN" 

DatabaseFilter filter Filters the database according to the specified filter. 
Example: DatabaseFilter [CITY] = 'New York' 
Filters the database, only records where the value of field "CITY" equals "New York" will 
be used. 

DatabaseClose Closes the currently opened database.  
Example: DatabaseClose 

 
The argument <technology> must have one of the following predefined values. 
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Print Technology Script Value 
Standard PostScript SetPrintTech Standard 
Optimized PostScript SetPrintTech Optimized 
AHT SetPrintTech AHT 
Creo VPS SetPrintTech VPS 
FreeForm SetPrintTech FreeForm 
FreeForm2 SetPrintTech FreeForm2 
PPML SetPrintTech PPML 
PPML/VDX SetPrintTech PPMLVDX 
VIPP SetPrintTech VIPP 

  
How do I create an Extended Scripting job? 
 
You create an extended scripting job by following the next steps: 

1. Create a PrintShop Mail document and save it, for example "ScriptTest.psmd". 
2. Create a textfile containing all commands you want to perform. 
3. Create a shortcut to PrintShop Mail.  
4. Add the argument "-script scriptfile.txt" to the command line (where "scriptfile.txt" is the textfile containing the 

commands)  
Note: It is advised to save your script file as "UNICODE" encoding. 
 

 
Automated printing allows you to print PrintShop Mail documents and PrintShop Mail templates 
automatically through the Command line or script file . Make sure to use the appropriate 
extension (<document name>.psmd or <document name>.psmt) in the Command line or in the 
script file. 

 
 
In the script file, you specify all commands you want to perform: 
 

FileOpen ScriptTest.psmd 
FilePrint 
FileExit 
 

This simple scriptfile opens the document "ScriptTest.psmd", prints it to the default printer and quits PrintShop Mail.  
 
You can create a batch process by telling PrintShop Mail to use another document: 
 

FileOpen ScriptTest.psmd 
FilePrint 
FileOpen AnotherDocument.psmd 
FilePrint 
FileExit 

 
PrintShop Mail first opens the document, "ScriptTest.psmd" and prints it to the default printer. When this is done, 
PrintShop Mail opens the second document, "AnotherDocument.psmd" and prints it to the same default printer. Of 
course, you can choose to specify a different printer by using the command "FilePrintTo". Finally, PrintShop Mail exits. 
 
It's possible to use the same document with different databases: 
 

FileOpen ScriptTest.psmd 
FilePrint 
DatabaseOpen AnotherDatabase.MDB 
FilePrintTo Printer2 
FileExit 

 
This opens the document "ScriptTest.psmd" and prints it to the default printer. When this is done, PrintShop Mail opens 
the database "AnotherDatabase.MDB" and prints it to another printer, called "Printer2". Finally, PrintShop Mail exits. 
 
A combination of the commands is also possible: 
 

FileOpen ScriptTest.psmd 
FilePrintRange 5 10 
DatabaseOpen AnotherDatabase.MDB 
FilePrintRange 10 15 
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DatabaseOpen ThirdDatabase.XLS 
FilePrintTo Printer2 
FileOpen Document2.psmd 
FilePrint 
FileExit 

 
This opens the PrintShop Mail document "ScriptTest.psmd" and prints records 5 to 10 to the default printer. When this is 
finished, it opens the database "AnotherDatabase.MDB" and records 10 to 15 are printed to the default printer. Then, the 
database "ThirdDatabase.XLS" is opened and all records are printed to printer "Printer2". Eventually, the PrintShop Mail 
document "Document2.psmd" is opened, printed to the default printer and PrintShop Mail exits. 
 
It's possible to change the Print Technology used when the document was created, or print the same document using 
different Print Technologies: 
 
               FileOpen ScriptTest.psmd 
               SetPrintTech Optimized 
               FilePrint 
               FileOpen ScriptTest.psmd 
               SetPrintTech Standard 
               FilePrint 
 
Database Filters 
 
A database filter consists of a field name, an operator and a condition. Suppose you have the following database: 
 

NAME CITY GENDER 
Eddy New York M 

Pamela Los Angeles F 
Tim Washington M 

Robert New Jersey M 
 
The available field names in this database are "Name", "City" and "Gender". The database has 4 records. 
 
An operator should be one of the ANSI SQL operators listed in the table below. 
 
Operators Definition 
= Equal 
<> Not equal 
< Less than 
> Greater than 
<= Less than or equal 
>= Greater than or equal 
 
A filter is used to construct the WHERE clause of an SQL statement. It does not include the reserved word WHERE to 
filter the record set. 
 
Except for "Distinct", "Like" and "Between", all SQL commands are supported. For more information about the SQL 
commands, please visit www.sql.org. 
 
If you want to select and print the records where the field name "City" equals "New York", the following line should be 
added to the script file: 
 

DatabaseFilter [CITY] = 'New York' 
 
Result: One record will be printed. 
 
Note: Please notice that we have used single quotes around the conditional values 'New York'. SQL uses single quotes 
around text values. Numeric values should not be enclosed in quotes. 
 
Suppose you want to send a mailing to all persons in the database where [GENDER] does not equal 'F'. The filter should 
look like: 
 

DatabaseFilter [GENDER] <> 'F' 
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Result: Three records will be printed. 
 
Or, you want to print all records where the [GENDER] equals 'F' OR where [CITY] does not equal 'Washington': 
 

DatabaseFilter [GENDER] = 'F' OR [CITY] <> 'Washington' 
 

Result: Three records will be printed 
 
These are just three examples of a database filter. You can create very advanced and powerful database filters. Please 
refer to your SQL manual or an online resource for advanced examples. 
 
If you need to have data from more than one table in the database, you can make a query in SQL or MS Access and 
export the result of this query into Excel, Access or a text file. This file can be used as a database in PrintShop Mail. 
 
Scheduling a job 
 
It is possible to schedule a certain job on a certain date and time. This can be achieved by using the Windows Scheduler. 
For more information about the Windows Scheduler and how to create a scheduled task, please refer to your Microsoft 
Windows® manual. 



 

91 

  

 

DDE 
(Windows only) 

Automated Printing 
 
DDE Dynamic Data Exchange is a more flexible way to automate printing than using command line arguments, but it 
requires knowledge of a programming language that supports DDE, such as Visual Basic or C++. Please refer to the 
Win32 API  documentation to learn how to establish a DDE connection. 
 
To connect to the PrintShop Mail DDE Server, make sure PrintShop Mail is running and open a DDE-connection to server 
"PrintShopMail6". 
 
Visual C++ 6.0 
 
// include "ddeml.h"  
UINT iReturn = DdeInitialize(&idInst, (PFNCALLBACK)DdeCallback, 
   APPCLASS_STANDARD | APPCMD_CLIENTONLY, 0 );  
HSZ hszApp =   ::DdeCreateStringHandle(idInst, "PrintShopMail6", 0); 
HSZ hszTopic = ::DdeCreateStringHandle(idInst, "C:\\untitled.psmd", 0); 
HCONV hConv = ::DdeConnect(idInst, hszApp, hszTopic, NULL); 
::DDEExecute(idInst, hConv, "[FileExit]"); 
 
Visual Basic 6.0 
 
TextBox.LinkTopic = "PrintShopMail6|Connect"   ' Set link topic. 
TextBox.LinkMode = vbLinkManual                ' Set link mode. 
On Error Resume Next    'TextBox thinks DDE is not executed, 
                        'when actually it is. 
TextBox.LinkExecute "[FileExit]" 
On Error GoTo 0 
 
PrintShop Mail accepts the following DDE commands: 
 
Command Description 
[FileNew] Closes the current document (if any) and creates a new 

document. 
[FileOpen "filename"] Opens the specified document. 
[FileClose] Closes the current document. 
[FilePrint] Prints the current document to the default printer. 
[FilePrintRange "start", "end"] Prints a range or records to the default printer. 
[FileExit] Closes PrintShop Mail. 
[DatabaseOpen "filename"] Opens the specified database. 
[DatabaseClose] Closes the current database. 
 [DatabaseOpenODBC 
"source"] 

Opens the specified ODBC data source. 

 
Note: This only applies to PrintShop Mail 6.x or later. PrintShop Mail  4.x and 5.x are slightly different. If desired, the text 
can be adapted for 4.x and 5.x by changing the word “PrintShopMail6” to “PrintShopMail4.x” or PrintShopMail5.x (all 3 
occurrences). 
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HotFolder 
(Mac OS  only) 

Automated Printing 
 
This feature allows more than one user to "drop" their database files and/or documents into the "HotFolder", causing a 
print job to start without further interaction (and without even needing access to the PrintShop Mail program from their 
computers). 
 
Initializing the HotFolder 

1. From the PrintShop Mail menu, select Preferences and click on the options group "HotFolder". 
2. In the let pane, click on the HotFolder icon. 
3. Click on Browse to select the folder containing the desire documents to monitor. 
4. Click Apply. 
5. From the File menu, select Monitor HotFolder. 
6. To stop monitoring and automatic printing of the document, click on the Cancel button. 

 
Using the HotFolder 

1. Create a PrintShop Mail document and store it in the "HotFolder". 
Since there will not be any user interaction with the program when the document is automatically printed, users 
should verify the document before saving it. 
  

2. Drop the document or/and the database file into the HotFolder.  
Within 30 seconds, PrintShop Mail combines the database with the available PrintShop Mail document and 
starts the print job. In addition to the "HotFolder" itself, three levels of subfolders can be used to drop database 
files in. This may be useful if multiple users want to produce mailings with different database files. 
  

3. After PrintShop Mail has printed the document, the database file is moved to a folder "PSMPrinted", which is 
created next to the HotFolder. The PrintShop Mail document remains in the same location and can be used 
again. 
  

4. PrintShop Mail writes a log of its actions into a log file. Since the timestamp of the log file is automatically 
adjusted every time when PrintShop Mail becomes active, this timestamp can be used to check whether 
PrintShop Mail is still running or not. If no PrintShop Mail document and/or database file was found, the log file 
is still updated. The log file is located in the folder /Users/user name/Library/Logs/PSM.log. 



 

 93

Document Fundamentals 
Item Properties 

 

Properties Window 
  
Document Fundamentals 

 
The Properties Windows 
 
The Properties window is the part of the PrintShop Mail screen that shows the properties of the currently selected 
object. 
You can hide the Properties window to see more of the layout, by double clicking on "Properties", "Layouts", 
"Variables", Data Fields", "Warnings", or "Verification Results" panel. 
 
The Properties window is a docked window that can be dragged from the properties area to become a floating window. 
 
There is a Properties window for the following categories: 

• Layouts  
• Variables  
• Data Fields  
• Warnings  
• Verification Results  

Layouts Panel 
 
The Layouts panel contains the layout(s) and their object(s). The objects are listed as a part of the layout in a tree view. 
Selecting an object will show the object properties in the Properties Panel. 
 
When you select a layout in the Layouts panel, the following properties will be displayed. 
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Option  Description 
Layout Name Name of the selected layout. 
Layout Size Size of the selected layout.  

More information about this topic , can be found in Specify the 
Layout Size. 

Description Select a standard size: Fit to Page (Default), Fit to Objects, 
Custom Size, A3, A4, A5, B5, US Letter, US Legal. 
 

Width Enter custom width. This setting is editable if you select 
"Custom Size". 

Height Enter custom height. This setting is editable if you select 
"Custom Size". 

Paper Size Size and orientation of the paper for the current layout.  
More information about this topic can be found in Page Setup. 

Description Select the paper size for the selected layout. The paper size 
depends  on the printer driver selected in the Page Setup 
dialog. 

Width The width of the page. 
Height The height of the page. 
Paper Tray If your printer supports different paper trays and your 

document consists of multiple layouts, you can send different 
layouts to different trays. 
More information about this topic can be found in Select Paper 
Trays 

Action The action to be performed for this layout, PRINT, BLANK or 
SKIP. 
More information about this topic can be found in Use Layout 
Condition.  

Number of copies Number of copies to be printed for the selected layout, must 
be at least one. 
More information about this topic can be found in Number of 
Copies. 

 
 
Variables Panel 
 
The Variables panel shows the list of variables, the Name, Expression and calculated Result. Double clicking on a 
variable will open the Expression Editor. 
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Selecting a variable will show the format category in the Properties panel, this can be: 
• Text 
• Number 
• Date 
• Currency 
• E-mail 

 
 
Detailed information about how to format variables, can be found in Formatting Variables. 
 
Data Fields Panel 
 
The Data Fields panel will show the field names , database name of the opened database and the number of records it 
contains.  
 
The entries you will find in the Data Fields panel in PrintShop Mail, represent data fields that occur in the document. 
These fields are either referred to in expressions (for variables or layout conditions, without the need to directly being 
linked to a database), or they refer to actual database fields (when the document is already linked to a specific database).  
 
When a data field is used in the PrintShop Mail document, it will have a check mark in the Data Fields panel.  
You can browse the records in the database by clicking the browse buttons in the Database toolbar, or by making the 
following selections from the Database menu:  

• First Record (ALT+Up) 
• Previous Record (ALT+Left)  
• Next Record (ALT+Right)  
• Last Record (ALT+Down) 
• Go to...Allows you to select a specific record.  
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Warnings Panel 
 
While you are working, PrintShop Mail will dynamically check for any possible errors on the layout and will display any 
occurring errors in the Warnings panel.  
 

 
 
Verification Result Panel 
 
When you select from the Layout menu,  Verify Document, a progress bar will be displayed, showing the amount of 
records being checked. The warnings for the whole document will be listed in the Verification Result panel. 
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Properties Panel 
  
Document Fundamentals 

 
You can change the properties for any object in the Properties Panel 
  
These properties are grouped as follows: 
 
Object 
This item apply to the name of the selected object 
 
Option Description 
Name The unique name that identifies an object. 
 
The following limitations apply to "objects name": 

• No white spaces leading or trailing. 
• Maximum 255 characters. 
• Not editable when multiple objects are selected. 

Content 
These items describe the properties of the object. 
 
Option Description 
Alignment Specify horizontal and vertical alignment: 

-Images 
  Horizontally: Left, Centered, Right 
  Vertically: Top, Centered, Bottom 
 -Text 
  Horizontally: Left, Centered, Right, Justified 
  Vertically: Top, Centered, Bottom 

Image Scale 
(Windows) 
 
Clipping 
(Mac OS) 

Here you can specify options on how the image is resized relative to the bounding 
box. 
Original size: The image is always shown in its original size, regardless of the size 
of the frame. If the frame is smaller the image will be cropped. Does not scale the 
images. 
Fit in Frame: The image will be resized to fill the frame, maintaining the image 
aspect ratio. Images are not clipped. 
Crop to Frame: Proportionally scales the images so that they fill the entire frame. 
Images may be clipped.  

Image Filename  
(images only) 

Displays the image filename, including the full path. The contents can only be 
changed through the Expression Editor. 

 Image Folder  
(images only) 

This points to the path where the variable images are stored. Clicking on the icon 
allows you to browse to a different search folder. 

Search Subfolders  
(images only) 

Specify whether PrintShop Mail should only look in the current folder (set to "No"), or 
if it should look in subfolders as well (set to "Yes"). 

Page Number Represents the page number in the PDF file. 
Note: An image object can be linked to a single PDF file. As PDF files can contain 
multiple pages you can specify the page(s) to be used in your document through an 
expression, in this way you can use variable pages within that PDF file. 

Two Color  
(images only) 

Control for Two Color support 
Convert to Two Colors: When set to "No" images will shown it's original color. 
Setting this option to "Yes" will convert the image to two colors. 
Background Color: Convert background color to specified color. 
Foreground Color: Convert foreground color to specified color 

Copy fitting 
(text box only) 

Copy fitting is a feature that will automatically shrink  text by reducing the font size, 
when there is more text than the text box can hold. The font size will be reduced to 
the font size needed to fit the text in the text box. However, text will not be shrunk 
beyond the specified minimum size. 

Remove Empty Lines When set to "No", empty lines will be shown in the text box. Setting this option to 
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(text box only) "Yes", will remove all those empty lines. The option "Only in variables" removes 
empty lines that appear in variables, but not empty lines in between variables. 

Vertical Layout 
 (text box only) 

This setting is specifically designed for vertical text with Asian characters which need 
to be printed vertically, other characters will simply be rotated 90°. 
This feature is supported under Windows XP,  Windows 2003 and Windows Vista. 

  
The following limitations apply to "Two Color" option for images: 

• The Two Color option does not support the image format EPS. 
• Two Color option will be disabled when using the Print Technology specific options, OPI, APR and Do no send 

images (VIPP). 
• The Print Technology PPML support the Two Color option, when you check "Embed Images in PDF" in the 

Print Dialog. 
MAC OS 
 

 
The "Remove Empty Lines" feature can be switched on using a checkbox in the Expression Editor 
Window. 

 
Frame  
These items apply to the bounding box, which is the boundary around the item. 
 
Option Description 
Lock Position Locks the position, size and rotation attributes of this object. 
Bounding Box Displays the dimensions of the bounding box using the location of the top left corner, 

and the height and width. These values can also be entered manually. 
Snap Frame to Content 
 (Windows Only) 

Snaps the frame to the proportions of the content. 
When this option is set to "Yes", the object’s bounding box (frame) will automatically 
resize to the dimensions of the image or resize vertically to accommodate larger 
amounts of variable text that would otherwise not fit in the text box. When set to 
"No", a verification warning will be shown at print time, when variables do not fit in 
the box. 

Border Size Change the border size. You can choose from hairline width, or a pixel width (1-
12px). You can also create a Custom Size. 

Border Color You can choose one of the standard colors, or create your own custom RGB, CMYK, 
Gray or Spot color for the border. To learn more about Spot Colors in PrintShop Mail 
click here. 

Border Style  
(Windows Only) 

Choose the border style. The following options are available: 
Solid —————— 
Square dot ...... 
Dash — — — — — 
Dash Dot — - — - — - 
Long Dash —— —— —— 
Long Dash Dot —— - —— - 
Long Dash Dot Dot —— - - —— - - 

Fill Color The fill color can be transparent, or it can be set to a solid fill color. The standard 
Windows palette is available, but you can also create your own custom RGB, CMYK, 
Gray or Spot color. To learn more about Spot Colors in PrintShop Mail click here. 

Rotation Shows the current rotation applied to the item. 
Anchor  Master Object: Master object name to anchor to. 

Horizontal: Horizontal aspect of the master object to anchor to. 
Vertical: Vertical aspect of the master object to anchor to. 

 
Printing 
 
Option Description 
Print Specifies whether the object will be printed or previewed only. 
Global Scope for PPML 
(images only) 

Specifies whether an image should get Global Scope. Images with a Global Scope 
can be reused on the printer across multiple PPML or PPML/VDX jobs. When set to 
"Yes" images will be stored in a specified Environment and can be reused in 
others print jobs. This property will be ignored for other technologies. 
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PDF Page Properties 
  
Document Fundamentals 

  
To specify PDF page properties 
 
Windows 

1. Click on the object representing the PDF.  
2. In the Properties panel specify the properties.  
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Mac OS 
1. Double click on the object representing the PDF, or from the Item menu select Show Object Properties. 

Alternatively right click on the object and select from the menu Show Object Properties. 
2. Specify the Properties. 
3. Click OK. 

 

 
 
Specify the name of the PDF object. 
 
Set this option... To specify... 
Name The unique name that identifies an object. 

  
Specify the PDF image attributes settings in the Content Box 
 
Set this option... To specify... 
Filename The filename and path of the PDF to which the page belongs. 
Page Number The PDF page number, represents the page number in the original PDF 

file, ranging from one to the number of pages in the PDF. 
Note: An image object can be linked to a single PDF file. As PDF files can 
contain multiple pages you can specify the page(s) to be used in your 
document through an expression, in this way you can use variable pages 
within that PDF file. 
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Specify the position settings in the Bounding Box 
 
Set this option... To specify... 
Lock Position Locks the position, size and rotation attributes of this object. 

 
Left (Windows)  
X-position (Mac OS) 

The horizontal offset from the top-left corner of your layout to the top-left 
corner of the object. 

Top  (Windows) 
Y-position (Mac OS) 

The vertical offset from the top-left corner of your layout to the top-left 
corner of the object. 

Width The object width. 
Height The object height. 
Fill Color Color of the background of the object. 

The fill color can be transparent, or it can be set to a solid fill color. The 
standard Windows palette is available, but you can also create your own 
custom RGB, CMYK, Gray or Spot color. To learn more about Spot Colors in 
PrintShop Mail click here. 

Rotation Shows the current rotation applied to the item. 
 
Note 
Edit boxes are read-only if the object is locked. 
If the PDF is placed on the layout, via File>New PDF based Document the PDF will be locked. 
  
Specify the appearance settings in the Border Box 
 
Set this option... To specify... 
Border Size Size of the border around the object frame, in pixels.  

You can choose from hairline width, or a pixel width (1-12px). You can 
also create a Custom Size. 

Border Color The color of the border around the object frame. 
You can choose one of the standard colors, or create your own custom 
RGB, CMYK, Gray or Spot color for the border. To learn more about Spot 
Colors in PrintShop Mail click here. 

Border Style  
(Windows Only) 

The style of the border around the object frame. 
Choose the border style. The following options are available: 
Solid —————— 
Square dot ...... 
Dash — — — — — 
Dash Dot — - — - — - 
Long Dash —— —— —— 
Long Dash Dot —— - —— - 
Long Dash Dot Dot —— - - —— - - 

  
Specify anchor settings 
  
Set this option... To specify... 
Anchor Master Object: Master object name to anchor to. 

Horizontal: Horizontal aspect of the master object to anchor to. 
Vertical: Vertical aspect of the master object to anchor to. 

  
Printing 
 
Set this option... To specify... 
Print Specifies whether the object will be printed or previewed only. 
 
Note: An image object can be linked to a single PDF file. As PDF files can contain multiple pages you can specify the 
page(s) to be used in your document through an expression, in this way you can use variable pages within that PDF file. 
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Image Properties 
  
Document Fundamentals 

 
To specify image properties 
  
Windows 

1. Click on the object representing the image. 
2. In the Properties panel specify the properties. 
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Mac OS 

1. Double click on the image object, or from the Item menu,  select Show Object Properties. Alternatively 
right click on the image object and select from the menu Show Object Properties. 

2. Specify the properties. 
3. Click OK. 

 
Object 
This item apply to the name of the selected object 
 
Set this option... To specify... 
Name The unique name that identifies an object. 
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The following limitations apply to "objects name": 
• No white spaces leading or trailing. 
• Maximum 255 characters. 
• Not editable when multiple objects are selected. 

Specify the image attributes settings in the Content Box 
 
Set this option... To specify... 
Alignment horizontal Horizontal alignment of the images (Left, Centered, Right). 
Alignment vertical Vertical alignment of the images (Top, Centered, Bottom). 
Scale 
(Windows) 
 
Clipping 
(Mac OS) 

Here you can specify options on how the image is resized relative to the 
bounding box. 
Original size: The image is always shown in its original size, regardless of 
the size of the frame. If the frame is smaller the image will be cropped. 
Does not scale the images. 
Fit in Frame: The image will be resized to fill the frame, maintaining the 
 image aspect ratio. Images are not clipped. 
Crop to Frame: Proportionally scales the images so that they fill the 
entire frame. Images may be clipped.  

Image Filename Displays the image filename, including the full path. The contents can only 
be changed through the expression builder. 

Image Folder This points to the path where the variable images are stored. Clicking on 
the icon allows you to browse to a different search folder. 

Search Subfolders  Specify whether PrintShop Mail should only look in the current folder (set 
to "No"), or if it should look in subfolders as well (set to "Yes"). 

Two Color  
(Windows only) 

Control for Two Color support 
Convert to Two Colors: When set to "No" images will shown it's original 
color. Setting this option to "Yes" will convert the image to two colors. 
Background Color: Convert background color to specified color. 
Foreground Color: Convert foreground color to specified color. 

  
The following limitations apply to "Two Color" option for images: 

• The Two Color option does not support the image format EPS. 
• Two Color option will be disabled when using the Print Technology specific options, OPI, APR and Do no send 

images (VIPP). 
• The Print Technology PPML support the Two Color option, when you check "Embed Images in PDF" in the 

Print Dialog. 
 

 
PrintShop Mail for Windows preserves the color space in images format EPS, TIFF and JPEG. To 
learn more about Color Management in PrintShop Mail, click here. 
PrintShop Mail for Macintosh converts the color space that is embedded in the image to the color 
space of the printer driver. You can check the color space of the printer driver, selecting from 
the File menu, Print/ColorSync.  

 
Specify the position settings in the Bounding Box 
 
Set this option... To specify... 
Lock Position Locks the position, size and rotation attributes of this object. 
Left (Windows)  
X-position (Mac OS) 

The horizontal offset from the top-left corner of your layout to the top-left 
corner of the object. 

Top  (Windows) 
Y-position (Mac OS) 

The vertical offset from the top-left corner of your layout to the top-left 
corner of the object. 

Width The object width. 
Height The object height. 
Snap Frame to Content 
 (Windows Only) 

Snaps the frame to the proportions of the content. 
When this option is set to "Yes", the object’s bounding box (frame) will 
automatically resize to the dimensions of the image or resize vertically to 
accommodate larger amounts of variable text that would otherwise not fit 
in the text box. When set to "No", a verification warning will be shown at 
print time, when variables do not fit in the box. 

 
Note: Edit boxes are read-only if the object is locked. 
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Specify the appearance settings in the Border Box 
    
Set this option... To specify... 
Border Size Size of the border around the object frame, in pixels.  

You can choose from hairline width, or a pixel width (1-12px). You can also 
create a Custom Size. 

Border Color The color of the border around the object frame. 
You can choose one of the standard colors, or create your own custom 
RGB, CMYK, Gray or Spot color for the border. To learn more about Spot 
Colors in PrintShop Mail click here. 

Border Style  
(Windows Only) 

The style of the border around the object frame. 
Choose the border style. The following options are available: 
Solid —————— 
Square dot ...... 
Dash — — — — — 
Dash Dot — - — - — - 
Long Dash —— —— —— 
Long Dash Dot —— - —— - 
Long Dash Dot Dot —— - - —— - - 

Fill Color Color of the background of the object. 
The fill color can be transparent, or it can be set to a solid fill color. The 
standard Windows palette is available, but you can also create your own 
custom RGB, CMYK, Gray or Spot color. To learn more about Spot Colors in 
PrintShop Mail click here. 

Rotation Clockwise rotation of the object frame, in degrees. 
Shows the current rotation applied to the object. 

Anchor Master Object: Master object name to anchor to. 
Horizontal: Horizontal aspect of the master object to anchor to. 
Vertical: Vertical aspect of the master object to anchor to. 

  
Printing 
 
Set this option... To specify... 
Print Specifies whether the object will be printed or previewed only. 
Global Scope for PPML 
(images only) 

Specifies whether an image should get Global Scope. Images with a Global 
Scope can be reused on the printer across multiple PPML or PPML/VDX jobs. 
When set to "Yes" images will be stored in a specified Environment and can be 
reused in others print jobs. This property will be ignored for other technologies. 
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Text Properties 
  
Document Fundamentals 

 
To change text properties 
  
Windows 

1. Click on the text object. 
2. In the Properties panel, specify the properties.  

 
Mac OS 

1.  From the Item menu,  select Show Object Properties. Alternatively right click on the text object and select 
from the menu Show Object Properties. 

2. Specify the properties. 
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3. Click OK.  

 
Object 
This item apply to the name of the selected object 
 
Set this option... To specify... 
Name The unique name that identifies an object. 
 
The following limitations apply to "objects name": 

• No white spaces leading or trailing. 
• Maximum 255 characters. 
• Not editable when multiple objects are selected. 

 
Specify the Text attribute settings in the Content Box 
 
Option Description 
Alignment horizontal Horizontal Text alignment (Left, Centered, Right, Justified). 
Alignment vertical Vertical text alignment (Top, Centered, Bottom) 
 Copy fitting Copy fitting is a feature that will automatically shrink  text by reducing the 

font size, when there is more text than the text box can hold. The font size 
will be reduced to the font size needed to fit the text in the text box. 
However, text will not be shrunk beyond the specified minimum size. 

Remove Empty Lines When set to "No", empty lines will be shown in the text box. This is useful 
where the variable is for instance an address and some records in the 
database have empty fields. If you select this function the empty lines 
caused by the empty field(s) will be preserved. 
When set to "Yes",  both  empty lines which are caused by empty fields in 
the database and white lines which are manually inserted will be removed. 
When set to "Only in variables", all empty lines will be removed in the 
variables only, static empty lines will be preserved. 

Vertical Layout This setting is specifically designed for vertical text with Asian characters 
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 which need to be printed vertically, other characters will simply be rotated 
90°. 
This feature is supported under Windows XP, Windows 2003 and Windows 
Vista. 

  
MAC OS 
 

 
The "Remove Empty Lines" feature can be switched on using a checkbox in the Expression Editor 
Window. 

  
Specify position settings in the Bounding Box 
 
Set this option... To specify... 
Lock Position Locks the position, size and rotation attributes of this object. 
Left (Windows)  
X-position (Mac OS) 

The horizontal offset from the top-left corner of your layout to the top-left 
corner of the object. 

Top  (Windows) 
Y-position (Mac OS) 

The vertical offset from the top-left corner of your layout to the top-left 
corner of the object. 

Width The object width. 
Height The object height. 
Snap Frame to Content 
 (Windows Only) 

Snaps the frame to the proportions of the content. 
When this option is set to “Yes”, the object’s bounding box (frame) will 
automatically resize to the dimensions of the image or resize vertically to 
accommodate larger amounts of variable text that would otherwise not fit 
in the text box. When set to “No”, a verification warning will be shown at 
print time, when variables do not fit in the box. 

 
Note: The Left,Top, Width and Height edit boxes are read-only if the object is locked. 
  
Specify the appearance settings in the Border Box 
 
Set this option... To specify... 
Border Size Size of the border around the object frame, in pixels.  

You can choose from hairline width, or a pixel width (1-12px). You can also 
create a Custom Size. 

Border Color The color of the border around the object frame. 
You can choose one of the standard colors, or create your own custom 
RGB, CMYK, Gray or Spot color for the border. To learn more about Spot 
Colors in PrintShop Mail click here. 

Border Style  
(Windows Only) 

The style of the border around the object frame. 
Choose the border style. The following options are available: 
Solid —————— 
Square dot ...... 
Dash — — — — — 
Dash Dot — - — - — - 
Long Dash —— —— —— 
Long Dash Dot —— - —— - 
Long Dash Dot Dot —— - - —— - - 

Fill Color Color of the background of the object. 
The fill color can be transparent, or it can be set to a solid fill color. The 
standard Windows palette is available, but you can also create your own 
custom RGB, CMYK, Gray or Spot color. To learn more about Spot Colors in 
PrintShop Mail click here. 

Rotation Clockwise rotation of the object frame, in degrees. 
Shows the current rotation applied to the object. 

Anchor Master Object: Master object name to anchor to. 
Horizontal: Horizontal aspect of the master object to anchor to. 
Vertical: Vertical aspect of the master object to anchor to. 
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Printing 
 
Set this option... To specify... 
Print Specifies whether the object will be printed or previewed only. 
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Formatting Text 

 

Text Style 
  
Document Fundamentals 

 
About text styles  
 
Windows 
 
You can change the text style (for example, font name, size, color, and style properties) of any part of the text in a text 
object. The text style of a variable depends on the style of the first delimiter, the character marking the beginning of a 
variable. 
 
PrintShop Mail offers the following font styles:  

• Regular 
• Bold (CTRL+B),  
• Italic (CTRL+I) 
• Underlined (CTRL+U)  
• Superscript 
• Subscript 
• Strikethrough 

 
Note: To select Superscript, Subscript or Strikethrough, from the Text menu, select Font. These fonts style can be 
combined. 
 
Font restrictions: 

• To use PostScript fonts in your document, Adobe Type Manager is required.  
• To use OpenType fonts in your document, you must be using Windows  2000, XP or 2003. 

 
To apply a text style to all paragraphs in one or more text objects 

1. Select the text objects. 
2. From the Text menu, select Style, or select the desired style in the Text Formatting toolbar. 

 
To apply a text style to a range of characters 

1. Enter Edit mode by double clicking in a text object. 
2. Make your selection.  
3. Click the appropriate button in the Text Formatting toolbar. Alternatively from the Text menu, select  Font, 

Size, Style or Color. 
 
To specify a custom font size 

1. From the Text menu, select the submenu Size/Other. 
2. Enter the new Font Size and click OK. 

 
Note: A font size of 10.5 points (for example) is allowed, but 10.3 is rounded to the nearest half (10.5). 
 
To specify a text color 
 
PrintShop Mail provides a number of ways for applying color to text, including the Text Formatting toolbar, the Color 
submenu in the Text menu and the Eyedropper tool in the Tools toolbar. 
 

1. In the Text Formatting toolbar, click the drop down arrow on the Text Color button. This accesses a palette of 
predefined colors. You can add your own custom colors to this palette. To do this, click the Custom button 
below the palette. A standard Color dialog box is displayed. 

2. From the Text menu, select Color..to add your own custom colors. 
3. In the Tools toolbar, click the Eyedropper tool to pick a color of a pixel anywhere on the screen and apply it 

for the text color. 
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Mac OS 
 
You can  use the Text Formatting toolbar or the Font Panel to select the font family and typeface. Other options you can 
specify from the Text Formatting toolbar or the Font Panel are to add underlining, Strikethrough lines, or apply shadows 
to text.  You can also set the background color and even adjust the spacing and alignment of text documents. 
 
To apply a text style to all paragraphs in one of more text objects 

1. Select the objects one by one. 
2. From the Text menu, select Font/Show Fonts to open the Font Panel, or select the desired style in the 

Text Formatting toolbar. 
 
To apply a text style and size to a range of characters 

1. Enter in Edit mode by double clicking on the text object. 
2. Select the text you want to change. 
3. From the Text menu, select Font/Show Fonts to open the Font panel. Select the Font and Style in the 

Family and Typeface columns. Select a font size in the Sizes column or use the slider to change font size. 
Alternatively make the changes from the Text Formatting toolbar. 

 
To specify a text color 

1. Select the text you want to change. 
2. From the Text menu, select Font/Show Colors. Alternatively click on the Text Color icon in the Text 

Formatting toolbar. 
 
Kerning  
 
Kerning refers to adjusting the space between characters, especially by placing two characters closer together than 
normal. Kerning makes certain combinations of letters, to look better. 
 
To set individual characters closer together or farther apart, adjust the kerning. 
 
From the Text menu, select  Font/ Kern. 
You can choose: 

• Use Default 
• Use None 
• Use Tighten 
• Use Loosen 

Choose Tighten to move the characters slightly together. Choose Loosen to move the characters slightly apart. You can 
choose Tighten or Loosen repeatedly to get the character spacing you want. 
 
Spelling  
 
It is possible to check the spelling for the entire document or a single word. 
 
From the Edit menu, select Spelling. Choose from: 

• Spelling...: To check the spelling of a document. 
• Check spelling: To check the spelling of a single word. 
• Check spelling As you type: To check the spelling while you type. 

If a misspelled word is found, select an alternative word in the Guess list, then click Correct to change the spelling.  If 
none of the given spellings are what you need, you can retype the word in the Spelling window and click Correct. Click 
Ignore if you do not want to correct the spelling of a word. Click Find Next to continue checking. 
If you want to check spelling in a different language, choose it from the Dictionary pop up menu in the Spelling 
window. If you want to add a word to the Spell-checking Dictionary, click Learn when the word appears in the 
Spelling window. To delete a word from the dictionary, click Forget. 
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Paragraph Style 
  
Document Fundamentals 

 
 
About paragraph styles 
 
A paragraph is a contiguous range of characters sharing formatting properties such as: 

• Alignment 
• Margins 
• Indentation 
• Tab stops 
• Formatting marks 
• Copy Fitting 

Paragraphs are separated by carriage returns. To start a new paragraph, press ENTER while you are typing text. 
 
To align text 
 
To apply alignment to all paragraphs in one or more text objects:  

1. Select the objects. 
2. (Windows): Click an alignment button in the Text Formatting toolbar. Alternatively in the Properties Panel, 

select Alignment. 
(Mac OS): Click an alignment button in the Text Formatting toolbar.  Alternatively from the Text menu, select 
Alignment. 

To apply text alignment for a specific paragraph:  
1. Double click in a text object to enter Edit mode. 
2. Select a paragraph. 
3. (Windows): Click an alignment button in the Text Formatting toolbar. Alternately, from the Text menu, select 

Paragraph. In the dialog box, you can specify alignment, margins and first line indentation values. An 
appearance sample is provided to preview the current settings.   
 
(Mac OS): Click an alignment button in the Text Formatting toolbar.  Alternatively from the Text menu, select 
Alignment. 
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Text direction 
 
To apply Right to Left text direction. 

1. Double click in the text box to enter in Edit mode. 
2. In the Text Formatting toolbar, click on the Right to Left button. 

 
Windows 
 
About tab stops 
 
Tab stops enable you to line up text to the left, right or center.  
 
You can select the following tab stops: 
 

 
Left Tab Text extend to the right from the tab stop. 

 
Center Tab Text is centered at the tab stop. 

 
Right Tab Text extends to the left from the tab stop until the tab's space is filled, and then the text 

extends to the right. 
 
To set and change tab stop positions 
 
To change default tab stop positions: 

1. From the Text menu, select Default Tab Stops.  
2. Choose your interval value. 
3. Click OK. 

To set and remove custom tab stop positions, there are two methods available: 
• Use the Tab Stops dialog box. 
• Use the horizontal ruler. 

To use the Tab Stops dialog box: 
1. Double click in a text object to enter Edit mode.  
2. Select a paragraph. 
3. From the Text menu, select Tab Stops.  

Tab stop positions are relative to the left side of the text object. 
4. To add a position, type a value in the edit box and click Set.  
5. To add alignment, you can select:  

Left:  Left text extends to the right from the tab stop.  
Center:  Center text is centered at the tab stop. 
Right:  Right text extends to the left from the tab stop until the tab's space is filled, and then the text extends 
to the right. 

6. To remove a position and alignment, select it in the list box and click Clear.  
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Formatting marks 
 
PrintShop Mail enables you to control whether formatting marks are hidden or visible in text objects. Formatting marks 
are newlines, tabs, and spaces. By default, after starting PrintShop Mail, all formatting marks will be hidden. 
 
You can tell PrintShop Mail to show formatting marks by selecting from the View menu Formatting Marks, or by using 
the button "Show or Hide Formatting Marks" on the View toolbar. This works as a toggle for all text objects. 
 
Formatting marks are just a visual aid, they will not be printed. The marks will scale to the zoom factor of your document, 
and they will scale to the font size of the surrounding text. They will also be visible while you're editing text. 
 
New line symbol: ¶ 
Space symbol: . 
Tab symbol: (right arrow) 
 
Copy Fitting 
 
The Copy Fitting  option allows you to automatically resize the used font in a text object, dependent upon the amount of 
text in the text object and the size of it's bounding box. 
 
To change this option: 

1. Select the text box. If you have multiple text boxes, you can select all of them. 
2. In the Properties Panel/ Content, select Copy Fitting. 
3. Set Reduce Font Size to Yes. 
4. Change the Minimum Font Size to the desired value. 

 
Mac OS 
  
To change Paragraph settings 
 
You can set the space between lines of text by using the Spacing pop up menu on the PrintShop Mail ruler when a text 
box is in edit mode.  

 
 
To set the line spacing, double click on the text object and select the text you want to adjust and choose Single, 
Double, or Other from the Spacing pop up menu. 
 
If you chose Other, choose options for: 

• Line height: Distance from the top of a line to the top of the line below it. 
• Inter-line spacing: Distance from the bottom of a line to the top of the line below it. 
• Paragraph spacing: Distance from the bottom of a paragraph to the top of the first line in the paragraph below 

it. 
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To change default tab stop positions: 
 
You can set margins, paragraph indentation, and text tabs by using the ruler in the edit mode of the text box.  
 
There are four kinds of tab stops and two types of margins, each indicated by a differently shaped icon: 

• A right facing triangle indicates a tab stop at which text will be left justified. 
• A diamond indicates a tab stop at which text will be centered. 
• A left facing triangle indicates a tab stop at which text will be right justified. 
• A circle indicates a decimal tab stop at which numbers will be justified around a decimal point. 
• A downward facing triangle indicates a page margin. 
• A horizontal rectangle indicates the indentation of the first line of a paragraph. 

To use the horizontal ruler: 
1. Left click on the horizontal ruler to add a paragraph marker.  

The marker type depends on the state of the paragraph marker button in the intersecting area of the two rulers 
(top-left).  

2. Left click the paragraph marker button to cycle through all possible paragraph marker types, including first line 
indentation, or right click this button to select a marker type from the menu. 

Note: You can also use the horizontal ruler to specify left and right margins. To do this, left click on the position of either 
the left or right side of the text box and drag the margin to the desired location. 
 
Copy Fitting 
 
To change this option: 

1. Select the text box.  
2. From the Item menu, select Show Objects Properties. 
3. In the Object Properties, change Copy Fitting to Yes. 
4. Change the Minimum Font Size to the desired value. 
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Layout Basics 

 

Layout Basics 
  
Document Fundamentals 

 
About layouts 
 
A PrintShop Mail document can consist of multiple layouts. 
 
To insert a layout 
 
From the Layout menu, select Insert. 
Now you can insert, remove, move or duplicate layouts. 
 

 
 
To track the layouts in your current document 
 
Windows 
 
Select the layout in the Layouts panel, or from the View toolbar browse through the layouts. 
 
Mac OS 
 
From the Window menu, select Show Document Layouts, or from the document layout toolbar browse through the 
layouts. 



 

117 

 
  
To duplicate a layout 
  
Windows 

1. Go to the layout which needs to be duplicated. To do this, from the View toolbar select the layout. 
2. From the Layout menu, select Duplicate.  

Alternatively, in the Layouts panel, right click on the layout you want to duplicate and from the submenu 
select Duplicate. 

 
Mac OS 

1. Go to the layout which needs to be duplicated. 
2. From the Layout menu, select Duplicate.  

Alternatively, from the Window menu, select Show Document Layouts and click on the plus sign in the low 
right corner of the Document Layout window. 

To remove a layout 
 
Windows 

1. Go to the layout which needs to be removed. To do this, from the View toolbar select the layout. 
2. From the Layout menu, select Remove.  

Alternatively, in the Layouts panel, right click on the layout you want to remove and from the submenu select 
Remove. 

Mac OS 
1. Go to the layout which needs to be removed. 
2. From the Layout menu, select Duplicate.  

Alternatively, from the Window menu, select Show Document Layouts and click on the minus sign in the 
low left corner of the Document Layout window. 

To change the layout size and orientation for the currently selected page 
1. From the Layout menu, select Size. 
2. Make the appropriate changes.  

Under Windows, you can apply the changes to: 
• Selected Layout 
• Current Layout 
• This point forward 
• Whole document 

Note: Under Mac OS, PrintShop Mail does not support multiple layout sizes within one document. 
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Guide Lines 
  
Document Fundamentals 

 
About guide lines 
 
Guide lines are non printing grid lines to help you to arrange and position objects. Moving or resizing objects to within a 
certain distance of a guide line causes the selection to snap to the line.  
 
To add a guide line 
 

 
1. (Windows): From the Insert menu, select Guide line or left click on a ruler. Use the horizontal 

ruler to add a vertical guide, and the vertical ruler for a horizontal guide. Left clicking on a ruler 
adds either a guide line or a folding line, depending on the icon displayed in the top left corner of 
your work area. Click the icon to change it to the Guide line icon.  
(Mac OS): From the View menu, select Layout Ruler. 

2. Select either a horizontal or vertical guide line. 

 
   
Note: When you drag a guide line, its default behavior is to snap to any existing objects. You can change this behavior 
by selecting or clearing the Guides Snap to Objects option in the View menu . 
 
To set the "snap to" distance 
 
Set the distance required for objects to snap to guide lines in Program settings, under Magnetic strength. The indicated 
number of points is the distance from the guide, within which an object will be drawn to the guide position. 
 
To remove a guide line 
 
Remove a guide line by dragging it to an invalid location, outside of the layout.  
The drag cursor is updated to reflect whether releasing the mouse button will move or remove the line. 
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Folding Lines 
  
Document Fundamentals 

 
About folding lines 
 
You can use folding lines to determine where to fold documents. Folding lines are printed on the visible part of the 
document (the part that will remain when the document is cut to the right size, for example they are also printed when 
there is no bleed margin). Unlike guide lines, folding lines are part of the print output, they are printed on either side of 
the document. 
 
To add a folding line 
 

 
1. (Windows): From the Insert menu, select Folding line, or left click on a ruler. Use the 

horizontal ruler to add a vertical folding line, and the vertical ruler for a horizontal folding line. Left 
clicking on a ruler will add either a folding line or a guide line, depending on the icon displayed in 
the top left corner of your work area. 
(Mac OS): From the View menu, select Layout Rulers. 

2. Select either a horizontal or vertical folding line. 

 
 
To change the folding line: 

• Length - Use the Imposition settings dialog box to change the length of the folding line. The overlay length of 
a folding line specifies the length on the visible part of your document (for example, excluding any bleed 
margin). 

• Color - Use the Program settings dialog box to change the color of the folding line.  
To remove a folding line 
 
It is possible to remove a folding line by dragging it to an invalid location outside the layout. The drag cursor is updated 
to reflect whether releasing the mouse button will move or remove the folding line. Alternatively right click on the folding 
line and from the menu select " Remove" . 
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Bleed Margin 
  
Document Fundamentals 

 
About bleed margins 
 
A bleed margin is a part of your layout that is printed to the edge of a finished page. 
 
Once a page is reproduced on press, the bleed margin is removed. 
 
In PrintShop Mail, your total layout size (as seen in Size in the Layout menu) includes the bleed margin. 
 
To add a bleed margin for each layout 

1. (Windows): From the Edit menu, select Preferences or press (CTRL+K). 
(Mac OS): From the PrintShop Mail menu, select Preferences or press (Command,). 
  

 
 

2. In the left pane, click the Imposition Settings icon. 
3. Select one of the following: 
• None: No bleed margin will be used. 
• Add to Job: To add the bleed margin to your layout, the bleed will be positioned around each layout, thus 

increasing your layout size. 
• Include in Job: To subtract the bleed margin from your layout, thus keeping your layout size the same as 

before. 
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• Page Level: To add bleed margin to the page, the bleed will be positioned around a set of layouts, not 
between the layouts, thus keeping the layout size the same as before. 

 

 
 When applying  a Custom size to a layout and the bleed margin selected is at Page Level, the 
bleed is not displayed at the edge of the paper, but around the set of layouts. 

 
Once you specified the Bleed Margin, check the "Crop marks" option and specify the Gap size, which is the distance 
between the crop marks and the edge of the document. 
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Crop Marks 
  
Document Fundamentals 

 
About crop marks 
 
Crop marks are printed lines that make it easier to trim the document to its finished size after the bleed margin is 
removed. 
 
Crop marks are only printed if the layout includes a bleed margin.  
 
To add or remove crop marks 

1. (Windows): From the Edit menu, select Preferences, or press (CTRL+K). 
(Mac OS): From the PrintShop Mail menu, select Preferences, or press (Command,). 

2. In the left pane, click the Imposition Settings icon. 
You can select three types of Crop Marks: 

• None: No crop marks will be drawn. 
• Standard: One line will be indicated for each trim position. 
• Japanese: Two lines will be indicated for each trim position. 

 
 
Note: Gap size is the distance between the actual crop mark and the edge of the layout. 
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Manipulating Objects 

 

Selecting Objects 
  
Document Fundamentals 

 
To select objects 
 
There are several ways to select objects. You can: 
 
Windows 

• Left click a single object to clear any active selection and select the new object. 
• Press SHIFT or CTRL and left click to select multiple objects on the layout or drag a selection box (lasso) 

around them. 
• From the Edit menu, choose Select All or press CTRL+A. 

Mac OS 
• Press SHIFT and click the objects on the layout.   
• Drag a selection box (lasso) around them. 
• From the Edit menu, choose Select All or press Command+A. 

To select underlying objects 
 
If you cannot select an object with a mouse click because it is covered by another object, repeatedly press the TAB key to 
cycle through the objects on the visible layout.  
 
Press SHIFT+TAB to select the previous object. 
 
To extend a selection 
 
There are several ways to extend a selection. You can: 
  
Windows 

• Press and hold SHIFT or CTRL to ensure that any active selection is not cleared.  
• To extend the current selection, press and hold SHIFT while left clicking on additional objects.  
• To toggle an object selection state, press and hold CTRL while left clicking on the object. 

Mac OS 
• Press SHIFT and click the objects on the layout. 
• Drag a selection box around them. 
• From the Edit menu, choose Select All or press Command + A. 
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Moving and Resizing Objects 
  
Document Fundamentals 

 
To move objects using the mouse 
  
Windows 

1. Select one or more objects. 
2. Left click on the selection and drag it to the new location. 

Note: While dragging, the objects will be snapped to any nearby guide line. 
 
Mac OS 

1. Select one or more objects.  
2. Click on the selection, hold down the mouse and drag it to the new location.  

 
To move objects using the keyboard  
 
Windows 

1. Select one or more objects.  
2. Use the arrow keys on your keyboard to nudge the selection to a new location on the layout. (Each nudge 

offsets the objects by one pixel.) 
 
To move objects by entering the new coordinates (to place an object at a specific 
location) 
  
Windows 

1. Select the object. 
2. In the Properties panel/ Bounding box, enter the desired Left and Top position.  

Mac OS 
1. Select the object. 
2. From the Item menu, select Show Object Properties, or press Shift and double click. 
3. In Position, enter the X and Y coordinates. 
4. Click OK. 

 
To resize an object using the mouse 

1. Select the object. 
2. (Windows): Left click on one of the sizing handles.  

(Mac OS): Click on the sizing handles and hold down the mouse button. 
3. Drag the handle to resize the object. 

Note: For static images, resizing always maintains the original aspect ratio of the image. For any other object, resize 
proportionally by holding down the CTRL key while dragging. While dragging, the sides of the objects that you are 
resizing will be snapped to any nearby guide line. 
 
To resize an object by entering the new dimensions 
  
Windows 

1. Select the object. 
2. In the Properties panel/ Bounding box, enter the new Width and Height. 

Mac OS 
1. Select the object. 
2. From the Item menu, select Show Object Properties, or press Shift and double click.  
3. In Position, enter the new Width and Height. 
4. Click OK. 
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Copying Objects 
  
Document Fundamentals 

 
Windows 
 
To copy objects using the mouse 

1. Right click and drag one or more selected objects to another location.  
2. Release the mouse button. 
3. On the menu, choose Copy Here to create duplicates of the selected objects. 

 
To copy objects using the clipboard 

1. Select one or more objects. 
2. From the Edit menu, select Copy or press CTRL+C. 

Note: You can paste the contents of the clipboard to any layout, even in a separate instance of PrintShop Mail . To do 
this, from the Edit menu, select Paste or press CTRL+V. 
 
To paste objects to multiple layouts 
 
If your document consists of more than one layout, you can create multiple copies throughout your document. Choose 
either: 

• Paste To and then Entire Document to paste the contents of the clipboard to every layout in your document. 
• Paste To and then Remainder of Document to paste to the remainder of your document (for example, to 

every layout, starting with the next layout).  
Note: If the current layout happens to be the last layout in your document, the option "Paste to Remainder of 
Document" is not available. 
 
Mac OS 

1. Select the object. To select multiple objects, hold down the Shift key while you click on each of them, or draw a 
box that encloses the objects. To select all objects in the current page, choose Select All from the Edit menu. 

2. From the Edit menu, select Copy. 
3. From the Edit menu select Paste, to paste the objects to the current layout or to any other layout in your 

document. 
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Aligning Objects 
  
Document Fundamentals 

 
To align objects 
  
Windows 
 
Note: You align the edges of the objects in the selection to the object LAST selected. You can align to the left, right, top 
or bottom edges of the object.  

1. Select the objects which are to be aligned. 
2. Select one of the alignment buttons on the Objects toolbar. You can also right click on the selection and select 

an option from the submenu under Align Edges, or from the Object menu, select Align Edges. 
Example: Before aligning the left edges 
 

 
 
Example: After aligning the left edges 
 

 
 
Note that the top left image was selected LAST. 
 

 
If you don't know which object you selected last, for example if you selected everything with 
Select All or pressing CTRL+A, reselect the object to align to, while holding down the SHIFT key. 

 
Mac OS 

1. Hold down the Shift key while you select the objects you wish to align, or draw a box (lasso) that encloses all 
objects that need to be aligned. 
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2. From the Item menu, select Align. 
3. Select one of the available options from the submenu. 

 
Alignment 
Option 

Description 

Left Edges To align the selected objects along their left edges. 
Right Edges To align the selected objects along their right edges. 
Top Edges To align the selected objects along their top edges. 
Bottom Edges To align the selected objects along their bottom edges. 
Horizontal Centers To align the selected objects along their horizontal edges. 
Vertical Centers To align the selected objects along their vertical edges. 
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Arranging Objects 
  
Document Fundamentals 

 
To rearrange objects  
 
You can move objects in front or behind each other. 

1. Select the object. 
2. From the Object menu, select Arrange. You can also right click on the selection and select an option from the 

submenu under Arrange. 
3. Select the appropriate option:   
• Bring to Front: To move the object in front of all other objects. 
• Bring Forward: To move the object one position forward. 
• Send Backward: To move the object one position backward. 
• Send to Back: To move the object behind all other objects. 
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Locking Objects 
  
Document Fundamentals 

 
About locking objects 
 
Locking an object, protects it from accidental changes in size or position. The text in a text box remains editable, 
however. 
 
Windows  
 
To lock an object 

1. Select the object. 
2. From the Object menu, select Lock Position. Alternately, right click the object and choose Lock, or from the 

Properties panel change Lock Position to Yes.  
To unlock an object 

1. Select the locked object. 
2. From the Object menu, select Unlock Position. Alternately, right click the object and choose Unlock, or 

from the Properties panel change Lock Position to No. 
 
Mac OS 
  
To lock an object 

1. Select the object. 
2. From the Item menu, select Show Object Properties, click on Unlocked. Alternately, from the Item menu 

select Lock Position. 
To unlock an object 

1. Select the object. 
2. From the Item menu, select Show Object Properties, click on Locked. Alternately, from the Item menu 

select Unlock Position. 
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Linking Text Objects 
  
Document Fundamentals 

 
About linking text objects 
 
Multiple text object can be linked together in order to have text overflow between them. 
 
Text objects can be linked within a page, but they can also be linked between pages (Page Overflow). 
 
To link text objects 

1. Make sure the destination text object(s) to which you want your text to flow towards already exists. 
2. Select the first text object.  
3. From the Text menu, select Create Forward Link, or on the Text Link toolbar, click the Create Text Link 

button. 
4. Point with the mouse cursor to the text object where you want your text to overflow towards (the destination 

object). 
 
Note: When you move the mouse over a text object which can be linked to, the border of this object will become green if 
it is possible to link to this object, and red if this is not possible. 
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Anchored Objects 
  
Document Fundamentals 

 
Anchoring 
  
Defines the dynamic relationship between the position and size of two objects. Anchored objects are items, such as 
images or text boxes that are connected to each other in such a way that a change in position or size of an anchor Master 
will affect the position and size of any number of anchor Child's. It is possible to add more objects (Child's) and make 
their position relative to the first object (Master) by using the corresponding Top, Left, Width, and Height properties. 
 If the first added object (Master) is empty or contains less data, the object defined as (Child) moves to the free space.  
 
The effects will be visible when printing or browsing through records and when moving or resizing objects at design time. 
 
Note: The object resizes only if the “Snap frame to content” option is set to “Yes” and the anchoring coordinates for the 
child is set to Width and Height. 
 
Example 
 
Suppose that your layout consists of a text object containing a letter to a customer and an image object containing a 
signature. The text box has the property Snap Frame to Content set to “Yes” (anchor Master) and the image object 
(anchor Child) is anchored to the text object. When the height of the text object changes, the image box containing a 
signature will automatically move up or down in order to retain the same distance to the bottom side of the text box. 
 

 
 

1. Anchor Master 
2. Distance between the Master and the Child 
3. Anchored child 

The distance between the Master object and Child object will remain the same. For example, if the Master text object is 
rotated 180 degrees, the Child object will not move when adding more text to the text box, this is because the Master 
object will grow at the “top edge” (the top edge is the bottom edge of the text box in an unrotated state).  
 
To anchor objects 
 
This can be done in two ways: 

1. Through the Objects toolbar 
-Select the object to be anchored (anchor Child). 
-In the Object toolbar, click on the “Add or Remove Anchor” button. 
-Move the mouse over another object (anchor Master). 
-Left click on this object that serves as anchor Master to link the two objects together. 
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2. Through the Properties panel 
-Select the object to be anchored (anchor Child). 
-In the Properties panel, click on the Anchor property, to expand the Master Object property. 
-Select the name of the anchor Master object. 

Note: It is possible to select an anchor Master for one object at the time. When anchoring objects, the object will be 
highlighted in green if it is a valid anchor Master or in red if it is not. 
 
To remove anchoring 
 
This can be done in two ways: 
 

1. Through the Objects toolbar 
-Select the anchored object (anchor Child). 
-In the Objects toolbar, click on the “Add or Remove Anchor” button, to remove the anchor. 
  

2. Through the Properties panel 
-Select the anchored object (anchor Child). 
-In the Properties panel, click on the Anchor property, to expand the Master Object property. 
-From the drop down menu, select the “empty” option. 

 
Anchoring to another object 
 
It is possible to specify only one anchor Master for each anchor Child, but an anchor Master can have multiple anchor 
Child's. If you wish to connect an anchor Child to a different anchor Master, you will first have to remove the existing link 
or change the anchor Master name in the Properties panel. 
 
Modifying anchors 
 
Each side of a Master object can be anchored to another object by using the Left Top coordinates of the Child and the 
Left Bottom coordinates of the Master object (in un-rotated stated). 
 
Anchor coordinates can be changed in the Properties panel.  
 
Horizontal anchors include:  
 
Left: The anchor Child position will be relative to the left side of the anchor Master. 
Right: The anchor Child position will be relative to the right side of the anchor Master. 
Width: The anchor Child width will be relative to the width of the anchor Master. 
 
Vertical anchors include:  
 
Top: The anchor Child position will be relative to the top side of the anchor Master. 
Bottom: The anchor Child position will be relative to the bottom side of the anchor Master. 
Height: The anchor Child height will be relative to the height of the anchor Master.  
 
For example: 

• If the anchored Child is positioned to the left of the anchor Master, the Horizontal position will be set to Left. 
• If the anchor Master is positioned at the left side of the anchored Child, the Horizontal position will be set to 

the Right. 
• If the anchor Master is positioned under the Child, the Vertical position will be set to Top. 
• If the anchor Master is positioned above the Child, the Vertical position will be set to Bottom. 

When resizing or moving an anchored Child, it is possible to modify the distance between two anchored objects. 
When resizing or moving an anchor Master, the anchored Child is resized and moved to the new positions as indicated by 
their anchor coordinates. 
 
Deleting Master objects 
 
When an anchor Master object is deleted, the link between the Master and Child objects is broken. In the Properties 
panel, the property (of the Child object) called Master Object, will get the suffix “Unresolved”. The anchor Child will 
remember the name of the anchor Master and will remain in this state until a new object is added that has the same 
name as the original anchor Master. 
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Toolbar Reference 

 

Toolbars Overview 
  
Toolbar Reference 

 
Database Toolbar 
 
Objects Toolbar 
 
Standard Toolbar 
 
Text Formatting Toolbar 
 
Text Link Toolbar 
 
Tools Toolbar 
 
View Toolbar 
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Database Toolbar 
(Windows only) 

Document Fundamentals 
 
 
About the Database toolbar 
 

 
 
Click this button... To do this... 

 
Go to the first record. 

 
Go to the previous record. 

 
Go to the next record. 

 
Go to the last record. 

 
Go to the current record. 

 
Display the total number of records in the 
database.  

 
The Total number of records edit box is read-only when a database is open.  
 

 
When no database is open, you can change the total number of records, in the Database toolbar. 
To do this, enter the desired number of records and press Enter. 
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Objects Toolbar 
(Windows only) 

Document Fundamentals 
 
About the Objects toolbar 
 

 
 
Click this 
button... 

To do this... 

 
Add or Remove anchor. 

 
Align left edges to the left edge of the last selected object. 

 
Align right edges to the right edge of the last selected 
object. 

 
Align top edges to the top edge of the last selected 
object. 

 
Align bottom edges to the bottom edge of the last 
selected object. 

 
Rotate the object 90 degrees counter-clockwise. 

 
Rotate the object 90 degrees clockwise. 

 
Select the fill color. 

 
Specify the border width (or no border). 

 
Specify the border style 

 
Select the border color. 
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Standard Toolbar 
(Windows only) 

Document Fundamentals 
 
About the Standard toolbar 
 

 
 
Click this button... To do this... 

 
Create a new document, based on a blank layout. 

 
Open an existing document. 

 
Save your current document. 

 
Preview the current document. 

 
Print the current document. 

 
Publish templates to PrintShop Web. 

 
Cut the selected object(s). 

 
Copy the selected object(s). 

 
Paste the selected object(s). 

 
Undo the last action. 

 
Redo the last action. 

 
Note: To undo or redo multiple actions at one time, click the drop-down button next to the arrow. 



 

137 

  

 

Text Formatting Toolbar 
  
Document Fundamentals 

 
About the Text formatting toolbar 
 

 
 
Click this button... To do this... 

 
Select the font name. 

 
Select the font size. 

 
Make the selection bold. 

 
Make the selection italic. 

 
Underline the selection. 

 
Select the font color. 

 
Left align text. 

 
Center text. 

 
Right align text. 

 
Justify text. 

 
Switch the text direction from Left to Right 
(default) to Right to Left. 
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Text Link Toolbar 
(Windows only) 

Document Fundamentals 
 
About the Text Link Toolbar 
 

 
 
Click this 
button... 

To do this... 

 
Create Forward Text Link. 

 
Break Forward Text Link. 

 
Select Previous Text Box. 

 
Select Next Text Box. 

 
Note: Multiple text boxes can be linked together, with text flowing between them. Text boxes can be linked within a 
page, but they can also be linked between pages.  
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Tools Toolbar 
  
Document Fundamentals 

 
About the Tools toolbar 
  
Windows 
 

 
 
Click this button... To do this... 

 
Select the tool. 

 
Select the edit text tool. 

 
Select the zoom tool left click to zoom in, right click or hold down CTRL to 
zoom out. 

 
Pick a Fill, Text, or Border color based on the RGB values of any pixel on 
the screen. 

 
Place a PDF file. 

 
Place a static image. 

 
Select the place text tool. 

 
Select the place variable image tool. 

 
Rotate the selected object to any angle by dragging the mouse cursor. 

 
Place OLA object. 

 
Mac OS 
 

 
 
 
Click this 
button... 

To do this... 

 

Select the tool. 

 

Select the edit text tool. 

 

Select the place variable image tool. 

 

Place a static image. 

 

 Select the zoom tool. 
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View Toolbar 
(Windows only) 

Document Fundamentals 
 
 
About the View toolbar 
 

 
 
Click this button... To do this... 

 
Go to the first layout. 

 
Go to the previous layout. 

 
Go to the next layout. 

 
Go to the last layout. 

 
Specify the zoom level. 

 
Show or hide Formatting Marks. 

 
Toggle Preview mode. 

 
Show or hide the rulers. 

 
Show or hide a specific toolbar. 
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Supported File Formats 

 

Supported Database Formats 
  

Supported Files Formats 
 
These are the supported database formats and associated file name extensions: 
 
Database Format File Name Extension  
dBase DBF  
Extensible Markup 
Language 

XML  

Microsoft FoxPro DBF  
Microsoft Access MDB (Windows Only) 
Microsoft Excel XLS  
Paradox DB (Windows Only) 
Text TXT or CSV  
Oracle/SQL Through ODBC connection (Windows Only) 
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Supported Image Formats 
  

Supported Files Formats 
 
Windows  
 
These are the supported graphical formats and associated file name extensions: 
 
Graphics Format File name extension 
Encapsulated PostScript EPS 
Icon ICO 
GIF GIF 
JPEG File Interchange Format JPG, JPE or JPEG 
Tagged Image File Format TIF or TIFF 
Windows Bitmap BMP 
Portable Document Format PDF 
 
Note: PrintShop Mail supports LZW-compressed images, including LZW-compressed TIFF previews in EPS files. 
 
Mac OS 
 
PrintShop Mail uses QuickTime to handle image files. The supported image file formats therefore depend on the version 
of QuickTime you have installed on your Macintosh. For a list of image file formats you can visit www.apple.com. 
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Preferences Settings 

 

Program Settings 
 

Preferences 
 
To specify program preference settings 
 

 

1. (Windows): From the Edit menu (CTRL+K), select Preferences. 
(Mac OS): From the PrintShop Mail menu (Command,), select Preferences . 

2. In the left pane, click the Program Settings icon. 
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About general preferences 
 
Set this option... To do this... 
Variable Markers Specify the characters that delimit (enclose) the variables 

in your text objects. 
Measurement in Select the unit of measurement for PrintShop Mail. 
Items without database Specify the total number of records when no database is 

open. 
Interface language  (Windows 
Only) 

Specify which language you want to use. 

Interface theme (Windows Only) Specify the appearance of the application user interface. It 
is possible to choose from: 
Classic, Blue, Aqua. 

Panels fade out (Mac OS Only) When inactive, panels from the Window menu fade out, 
moving the mouse over a panel fades it back in. 

 
About layout appearance preferences 
  
Set this option... To do this... 
Bleed Specify color. 
Folding lines Specify color. 
Crop marks (Mac OS Only) Specify color. 
Printable area Specify the order in which the printable areas are drawn, 

relative to the objects. Top specifies that the areas are 
always visible, Bottom that they are obscured by objects. 

Guide lines Specify the order in which the guide lines are drawn, 
relative to the objects. Top specifies that the lines are 
always visible, Bottom that they are obscured by objects. 

Magnetic strength Define guide line sensitivity when moving or resizing 
objects. When the cursor comes within the specified pixel 
range on either side of a guide line the object snaps to it. 

Generate EPS for vertical text 
objects (Mac OS Only) 

During printing, PostScript for vertical text object is 
generated in an alternative way. 
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Color Management 
(Windows only) 

Preferences 
 
 
PrintShop Mail Color Management 
 
Color Management compares the color space in which a color was created to the color space in which the same color 
will be outputted, and makes the necessary adjustments to represent the color as consistently as possible. 
 
PrintShop Mail Color Management is designed to accurately display the same on-screen color as the color on the 
printed output. When you install PrintShop Mail, the color space profiles (Adobe ICC Profiles) will be installed in 
"Windows\System32\spool\drivers\color\" . When staring PrintShop Mail, the application will load the profiles allowing you 
to define colors for the different objects placed in your document.  
 
Note: Text in the text object can have different RGB colors, but only one CMYK color per object. 
 
PrintShop Mail handles the Color Management at two levels: 

1. PrintShop Mail originated colors. The colors defined in PrintShop Mail for objects, like border color, fill color and 
text color. 

2. PrintShop Mail Embedded Color Management. The colors defined for certain image file types, like TIFF, EPS, 
JPG 

Note: PrintShop Mail does not change the Color Management of your image, if your image files have embedded color 
profiles, these colors will not be overruled by PrintShop Mail’s Color Management. 
 
You can enable Color Management in the PrintShop Mail Preferences, by default this option is off. Once the Color 
Management is enabled it is possible to change the working spaces profiles, which allows for colors to be adjusted. 
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The default working space color profiles settings are: 
RGB: sRGB 
CMYK: U.S Web Coated (SWOP) v2 
Gray: Gamma 1.8 
Rendering: Absolute colorimetric 
 
For example 
 
Suppose you have a colored text box with the following CMYK values: 

• Cyan: 100 % 
• Magenta: 0% 
• Yellow: 0% 
• Black: 0% 

These values are an indication of the color intended to be printed, but because of the different monitors, printers, inks, 
types of paper these values may yield a different color on the printed output. 
 
To avoid this, Color Management translates colors with the help of color profiles. 
 
To enable Color Management: 
 
From the Edit menu, select Preferences or press Ctrl+K and click on the Colors icon. 

1. Check the option “Enable colormanagement”. 
2. In the working space section select your desired color profile. 
3. Click Apply. 
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The colored object will change slightly depending on the chosen color profile, but in the Properties panel the CMYK 
values for that color will stay the same. 
 
Rendering 
 
Rendering is the process of converting one color space to another color space. The result of choosing a rendering intent 
depends on the content of documents and on the profiles used to specify color spaces. Some profiles produce identical 
results for different rendering intents. Differences between rendering intents are apparent only when you print a 
document or convert it to a different color space. 
 
The following rendering intent options are available: 

• Absolute colorimetric 
• Perceptual 
• Relative colorimetric 
• Saturation 

In a Color Management workflow, you can use the precision of color profiles to soft proof your document directly on the 
monitor. You can display an on-screen preview of how your document’s colors will look when reproduced on a particular 
output device. The reliability of the soft proof depends upon the quality of your monitor, the profiles of your monitor and 
output devices. To preview how the color will look when printed, select Print Preview and click Color Soft proof. 
 
Soft proof colors show the color profile defined in the Color Management. 
 
Note: This feature is enabled when Color Management is activated. 
 
Color Management for on-screen preview is different from Color Management reproduced in a particular output device. 
You have more control over the appearance of the document on a particular output device than with on-screen preview, 
because your document may appear on a wide range of possible uncalibrated monitors and video display systems which 
limits control over the color consistency. 
 
To control the color consistency it is possible to assign a color profile to the monitor. In a workflow such a profile would 
be provided by the monitor manufacturer or the profile would be created using specialized equipment that measures the 
monitor's color space. 
 
To provide a practical means for color consistence you can change the monitor color profile to match your output device. 
To do this: 
 
Windows 2000 and Windows XP 

1. In the Control Panel, select Display. 
2. Click on the Setting tab. 
3. Click on Advanced 
4. Select the “Color Management” tab. 
5. Click on Add, to add the desired monitor color profile for your documents 

Note: You need to restart PrintShop Mail for the changes to take effect. 
 
Windows Vista 

1. In the Control Panel, select Personalization. 
2. Select Display Settings from the list. 
3. Click on the Advanced Setting tab. 
4. Select the “Color Management” tab. 

Here you can add color profiles for each device on your system (monitor and printers). 
5. Click on the Advanced tab and from the drop down menus select the desired color profiles. 
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Print Job Settings 
 

Preferences 
 
To specify print job preference settings 
 

 

1. (Windows): From the Edit menu (CTRL+K), select Preferences. 
(Mac OS): From the PrintShop Mail menu (Command,), select Preferences . 

2. In the left pane, click the Print Job Settings icon. 
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About print job preferences 
 
Set this option... To do this... 
Print Margins Print Margins are empty spaces all around the page. The margin 

(top, bottom, left, right) is usually the empty space between where 
the page is cut and the layout area of the page.  
PrintShop Mail allows you to make changes to the print margin for all 
layouts in the document. It is possible to: 
Center (Windows only): Where the layout(s) will be centered on 
the paper. 
Offset: Where you can specify different values for each print 
margin: Top-Bottom (Y offset) and Left-Right (X offset).  
Note: PrintShop Mail supports different paper sizes within one 
document. Print Margins settings will be applied to the whole 
document. 

Technology Select which print technology is used to optimize your PostScript 
output. See Supported Printing Technologies for more information 
on these options. 

Print report page Specify that a report page is printed at the end of the job. 
Send custom error handler (Windows 
only) 

Specifies whether a Postscript error will generate a custom error 
page containing tips on how to solve the problem. Leave this box 
unchecked if you want your printer to handle any errors. 
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Repetition Settings 
 

Preferences 
 
Note: Use these settings bellow for Multi-up printing. See How to Use Layout Repetition for more information. 
 
To specify repetition preference settings 
 

 

1. (Windows): From the Edit menu (CTRL+K), select Preferences . 
(Mac OS): From the PrintShop Mail menu, select Preferences . 

2. In the left pane, click the Repetition Settings icon. 
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About repetition preferences 
 
Set this option... To do this... 

Layout Repetition Specify how the actual multi-up is done. The number between brackets indicates 
the maximum number of repetitions possible with the current layout and print 
settings.  
Horizontal repetition: Specify the amount of layouts positioned in the horizontal 
direction (number of columns). 
Vertical repetition: Specify the amount of layouts positioned in the vertical 
direction (number of rows).    

Spacing between layouts Specify the horizontal and vertical distance between each layouts when using 
layout repetition. 

Repetition Preview Shows the repetition order on the page. When the defined Horizontal and Vertical 
repetition does not fit on the page, the layouts on the left and bottom are 
represented with a dash line. 

Priorities Specify the priorities (1,2,3) and direction (Left to Right, Right to Left , Top to 
Bottom, Bottom to Top, Front to Back, Back to Front) in which the records in your 
document are going to be printed. You can specify: 
Left to Right, Right to Left: Influences the horizontal repetition. 
Top to Bottom, Bottom to Top: Influences the vertical repetition. 
Front to Back, Back to Front: Allows printing Through-the-stack 
To print Through-the-stack, set top priority (1) to Front to back, priority (2) to 
Top to bottom and priority (3) to Left to right. This way the first record is 
printed on the top left corner of the first page, the second record is printed on 
the top left corner of the second page, etc. This eliminates the need for collating 
after the job is printed. 
Reverse sheets (Windows only): Checking this option will shuffle the printed 
output so that the top page will be the last page to be printed and the bottom 
page will be the first page to be printed. 

Mirroring Used when printing duplex: Specify that the positions of the layouts on the 
back of each page should match de positions of the layouts on the front of each 
page. In effect, the layout positions on the back will mirror the layouts in front of 
the page .  
You can specify: 
Based on driver settings: The document will be printed duplex according to 
the settings in the printer driver, provided the driver supports this. 
 
Note: Some printer drivers do not correctly report duplex settings. You can force 
PrintShop Mail to mirror the layout positions on the back of the page, by 
specifying "Flip on long edge" or “Flip on short edge”. 
 
Flip on long edge: Layouts in the back side of the page will be mirrored through 
the long edge of the page. 
Flip on short edge (Windows only): Layouts in the back side of the page will 
be mirrored through the short edge of the page. 
Simplex: The document does not require mirroring of the layouts. 
 
Note: When using duplex settings in combination with layout conditions (Skip is 
activated) or when number of copies is applied, the next layout will move to the 
position where the previous would have been positioned. This can result in 
printing an odd number of layouts per record. This can be avoided by adding a 
Blank page to the layouts for that record. 

 

 
PrintShop Mail supports mixed layout sizes, except when layout repetition is used. When using 
layout repetition, the first layout size will be the layout size for the complete document. 

 

 
When you use layout condition SKIP for your PrintShop Mail documents with multiple layouts, or 
when you have applied variable Number of Copies, this may cause that the size of the record 
sets (the number of actual printed layouts per record) will be different per record set. This in 
turn may cause that some record sets will be split across  different stacks. 
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Imposition Settings 
 

Preferences 
 
To specify imposition preference settings 
 

 

1. (Windows): From the Edit menu (CTRL+K), select Preferences. 
(Mac OS): From the PrintShop Mail menu (Command,), select Preferences . 

2. In the left pane, click the Imposition Settings icon. 
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About imposition preferences 
 
Set this option... To do this... 
Bleed Margin Specify bleed margin information as follows:  

None: No bleed margin will be used. 
Add to Job: To add the bleed margin to your layout, the bleed is 
positioned around each layout, thus increasing your layout size. 
Include in Job: To subtract the bleed margin from your layout, the 
bleed is positioned around each layout, thus keeping your layout size the 
same as before. 
Page Level (Windows Only): To add bleed to the page, the bleed is 
positioned around a set of layouts, thus keeping the layout size the same 
as before. 
Note: When applying  a Custom size to a layout and the bleed selected 
is at Page Level, the bleed is not displayed at the edge of the paper, 
but around the set of layouts. 
Width: To set the width of the bleed margin. 

Crop Marks Crop Marks are lines that indicate the edges of the layouts or pages. 
They will be printed making it easier to trim the document to its finished 
size after the bleed margin has ben removed. 
Note: You can only specify crop marks if you have specified a bleed 
margin.  
Crop Marks style options:  
None: No crop marks will be drawn.  
Standard: One line will be indicated for each trim position.  
Japanese: Two lines will be indicated for each trim position. 
Double Sided: When using duplex and you select this option the crop 
marks will be printed in both sides of the paper.  
Gap size: Specify gap size as the distance between the actual crop mark 
and the edge of the layout. 
Color (Windows Only): It is possible to select a color for the Crop 
marks. 

Folding Lines  Specify the length of folding lines. 
Center layouts on paper 
(Mac OS) 

Select this option to center layouts on the physical paper. 

 
     



 

154 

 

 

PrintShop Web Settings 
(Windows only) 

Preferences 
 
Note: Use the settings bellow to fill in the URL and the login account for your company Web Server. See Publishing 
Documents, for more information about creating and publishing PrintShop Mail documents to PrintShop Web. 
 
To specify PrintShop Web Preference settings 
 

 

1.  From the Edit menu (CTRL+K), select Preferences. 
  

2. In the left pane, click the Publish to Web icon. 
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About PrintShop Web preferences 
 
Set this option... To do this... 
Server address (URL) Specify the company Web Server. 
Login (Username and 
Password) 

Specify the username and password assigned by the 
administrator to log in the company Web Server. If you do 
not have an account, please contact your Web server's 
administrator. 

Test Connection... To establish a connection with the publication server. 
Also publish database To add the opened database to the published document. 
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PlanetPress Suite 
(Windows only) 

Preferences 
 
PlanetPress Watch is a powerful printing software for transforming and distributing print jobs from virtually any host. 
Transforming and distributing print jobs allows for automated local and remote printing, integrated PDF generation for 
archiving, emailing and faxing. 
 
Options for the PlanetPress Suite can be added to a PrintShop Mail output job through the Preferences panel, which 
enables you to send PrintShop Mail output to a location or queue that is being watched by PlanetPress Watch. This makes 
that PrintShop Mail output can be further processed to be archived or emailed or sent by fax. 
 
For example, PDF files can be automatically generated and mailed to addresses defined by the customer.  
 
Defining fields in PrintShop Mail 

1. Create a PrintShop Mail document.  
2. From the File menu, select Preferences and click on the PlanetPress Suite icon. 
3. Define the output type for your document.  
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Set this option... To do this... 
Fax  Number: Specify the fax number from the data fields of the currently 

opened database or the variable you created. 
Description: Specify the description from the data fields of the currently 
opened database or the variable you created. 

Email Number: Specify the email address from the data fields of the currently 
opened database or the variable you created. 
Subject: Specify the email subject from the data fields of the currently 
opened database or the variable you created. 
Body text: Specify the email content from the data fields of the currently 
opened database or the variable you created. 

PDF Bookmark Create a standard PDF bookmark.  
Archive Name: Defines a descriptive name for the archive or for the item to be 

archived. 
Variable: Specify a data field of the currently opened database or the 
variable you created. 

 
4. PlanetPress Watch captures the PostScript file and routes it to the appropriate device to output the document. 

For more information about PlanetPress Watch, please visit http://www.objectiflune.com 
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Using Expressions 

 

Expressions Overview 
  
PrintShop Mail Expressions Guide 

 
About expressions in PrintShop Mail 
 
Expressions allow you to manipulate text and data from the database. They also allow you to add conditions to database 
fields for example, to create a salutation based on a "Gender" field.  
 
Here is a valid example of an expression, made up of functions: 
 
IF(UPPER([GENDER]) = "M", "Dear Mr" & PROPER([LAST_NM]), "Dear Mrs" & PROPER([LAST_NM] ))  
 
The functions used in the example are: 

1. IF(logical_test, value_if_true, value_if_false) 
2. PROPER(string_value) 
3. UPPER(string_value) 

The expression is the combination of functions that make up the calculation.  
 
There are various function types available, depending on the expression you want to create. 

• Barcode Functions 
• Layout Functions 
• Logical Functions 
• Number Functions 
• String Functions 

You can also select from the list with all functions, see: 
• Functions Overview 

PrintShop Mail Expression Editor 
 
Before start using expressions is good to get familiar with the Expression Editor interface. 
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1- Expression Edit field:  Allows adding, deleting and modifying the expressions. 
2- Expression result: Checks the expression and shows the result if the expression is valid. 
3- Favorites: Allows saving the favorites expressions. 
4- Components: Shows the functions type by group (string, number, barcode, logical) and the functions that belongs to 
the group. 
5- Functions: Shows the functions list. 
6- Open Assistant button: Opens a new Expression Assistant window for that function. 
7- Data Fields: Shows the content of the opened database. 
8- Operators: Allows combining, comparing or modifying the value of an expression. 
9- Help text: Shows the description of the selected function. 
10-Example: Shows an example of the selected function and the result of the function when applied. 
  
Using Expressions 
 
You can add or modify expressions dynamically through the Expression Editor or you can add an expression manually 
using keywords. 
 
The Expression Editor automatically verifies the expression while you are editing it.  
 
Note: When the cursor is moved to a position where the expression may be faulty, a tool tip will appear indicating what 
is expected or what may be the issue. 
 
Expression texts are displayed as follows:  

• Blue text:       Functions 
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• Green text:    String  
• Purple text:    Database fields  
• Red text:        Logical 
• Dark red text: Variables 

When the syntax of an expression is represented in italic+bold, this suggests that you need to review the expression. This 
happens for example when a database field is not recognized. 
 
Creating Expressions 
 
Once the Expression Editor is open, you can add expressions: 
 
Manually: When you create expressions manually, you can start typing keywords which will cause a pop up menu to 
appear. For example, if you type “P” in the Expression Edit field, a list will automatically jump to the available keyword 
options starting with “P”. You can continue typing or you can use the mouse pointer or the UP/DOWN arrow keys to 
select a function from the function list. Another way to call the pop up menu is by pressing Ctrl + Space on your 
keyboard. 
 

 
 
Dynamically: To create expressions dynamically, double click a function in the function list, the expression will be 
pasted into the Expression Edit field straightaway. 
 
Example: 
 
Suppose you have a database with fields named "First Name" and "Last Name". If those fields are improperly filled with a 
combination of lowercase and uppercase characters, you need to convert the first letter of each word to an uppercase 
character, and the rest to lowercase. To do this, we need to use the following function: PROPER. 
 
If you double click on "PROPER" in the functions list, the expression will be pasted into the Expression Edit field. 
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In the Expression Edit field you can enter the expression yourself without the help of the Expression Assistant, but if 

you are not sure about which functions arguments you need to enter, click on the icon  next to the function (in this 
example the PROPER function) to open the Expression Assistant. Another way to open the Expression Assistant is 
to select the function in the Expression Edit field and double click on it. 
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To help you to add the correct names of database fields, variables or functions, you can select those items from the pop 
up menu on the right hand side of the edit box. 
 

 
 
The result of the function you created here, will be  pasted into the Expression Edit field. For example: PROPER ([First 
name]). 
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You can see the result of this expression directly on the screen. 
 
You can use a function within a function. Selecting a function in the Expression Assistant will open a new Expression 
Assistant for that function. Finishing the second function will paste the resulting expression into the edit box of the 
function. 
 

 
For more information about some frequently used functions, go to Favorite Expressions 
Overview. 

 
Variable dependencies 
PrintShop Mail introduces a concept called "variable dependencies". The result of an expression can now depend on the 
result of another expression. This makes expressions more flexible, and allows users to: 

1. Reuse expressions. 
2. Break complex expressions into smaller and more manageable parts. 
3. Create global variables, for example: variables that are not linked to specific objects. 

You can recycle or reuse an expression by including a reference to its variable in another expression. 
 
Just like variable references in text objects, variable references in expressions consist of a "@" character, followed by a 
variable name (case sensitive), followed by another "@’" character. For example: @Variable 1@. 
 
Variable references are treated as strings, and can be passed to functions that expect string arguments. 
 
Examples of variable references used in calculations: 
 
1. @Title@ & " " & @First name@ &  " " & 
@Surname@ 
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2. TRIM(LEFT(@Address@, 5)) 
 
Note that the first expression in these two examples looks compact and easy to understand, even though the expression 
of variable "Title" can be quite complex, perhaps containing nested IF statements. Using variable references in 
expressions may improve readability. 
 
If a referenced variable does not exist, PrintShop Mail will automatically create a new variable with the appropriate name 
and an empty expression. This new variable is not yet linked to an object. 
 
In some cases, PrintShop Mail will not be able to calculate the result of an expression. Circular references (for example, a 
variable referring back to itself), result in a deadlock situation. The expression of a variable in a deadlock situation will 
evaluate to "[deadlock]". 
 
Example of a "deadlock" situation: 
 
Name  Expression  Result 
A @A@ [deadlock] 
B @B@ [deadlock] 
 
Please note that variables in the Expression Editor are considered to be strings, even if the variable is a number type. 
You can use the VAL function to convert a string into a number if necessary. 
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Favorite Expressions 

 

Favorite Expressions Overview 
  
PrintShop Mail Expressions Guide 

 
Here are the most frequently used expressions: 

• Capitalizing Names 
• Inserting a Salutation 
• Creating a Custom Serial Number 
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Favorite Expressions- Capitalizing names 
  
PrintShop Mail Expressions Guide 

 
If you encounter a database with incorrectly entered data, the fields may appear like this: 
 
First Name Last Name 
john abrahams 
theREsa Johnson 
William fremont 
 
You want the names to print with the first letter capitalized in every document. Use the PROPER function to achieve this 
result. For every word, this function capitalizes the first letter and changes the rest of the word to lowercase. 
 
The expression looks like this: 
 
PROPER ([First name]) & " " & PROPER ([Last name]) 
 
This will be  the "cleaned-up" result: 

• John Abrahams 
• Theresa Johnson 
• William Fremont 
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Favorite Expressions- Salutations 
  
PrintShop Mail Expressions Guide 

 
You can generate salutations with a conditional IF statement. If you have a field in your database that specifies the 
gender of the person, you can use it to add 'Mr.' or 'Mrs.' to the name. 
 
Example 
 
First 
Name 

Last Name Gender 

John Abrahams M 
Theresa Johnson F 
William Fremont M 
 
This example uses the IF function in combination with the "&" operator, which allows you to combine text strings. 
 
IF([Gender]="M", "Dear Mr. " & [First name] & " " & [Last name], "Dear Mrs. " & [First name] & " " & [Last 
name]) 
 
IF( Start of the IF function. 
[Gender]="M", Checks if "M" appears in the [Gender] field. 
"Dear Mr. " & [First name] & " "& [Last 
name] 

 If it does, it combines "Dear Mr. ", the first name, 
a space and the last name. 

"Dear Mrs. " & [First name] & " " & [Last 
name] 

If it does not equal "M", it assumes the letter is 
addressed to a female, and creates a combination 
of "Dear Mrs. ", the first name, a space and the 
last name. 

) End of the IF function. 
 
These are the results using the above database as an example: 
 
First 
Name 

Last Name Gender Result 

John Abrahams M Dear Mr. John Abrahams 
Theresa Johnson F Dear Mrs. Theresa 

Johnson 
William Fremont M Dear Mr. William Fremont 
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Favorite Expressions- Custom Serial Numbers 
  
PrintShop Mail Expressions Guide 

 
About customized serial numbers 
 
PrintShop Mail allows you to create customized serial numbers. You can use these numbers to serialize such items as 
raffle tickets, coupons or self-mailers. In combination with the barcode functions, you can create serially numbered 
barcodes. 
 
You do not need to have a database to create serial numbers. You can change the number of Items without a database 
in the Preferences dialog box, from the Edit menu, select Preferences,  or in the Database toolbar, enter the desired 
number of records and press Enter . From the PrintShop Mail menu, select Preferences (Mac OS). 
 
For example 
 
This example creates a Code 39 barcode. The custom serial number starts with "SWA", and ends with a counter, counting 
from 1 to 1000. The functions used are: 

• CODE39 
• COUNTER 

After a text box with a variable for the barcode is created, the barcode function is attached to the variable. 
 
CODE39("SWA" & COUNTER(1, 1000, 1, 4, True)) 
 
The result in PrintShop Mail: 
 
*SWA0001*, *SWA0002*, *SWA0003*, etc. 
 
After the correct barcode font is selected, the result is: 
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Functions and Operators 

 

Functions Overview 
  
PrintShop Mail Expressions Guide 

 
You can use the following functions in PrintShop Mail: 
 
Operator Function 
ABS Converts the leading character in <Text> to its numeric ASCII value. 
AND Returns True if both <Logical value 1> and <Logical value 2> are 

True. 
ASC Converts the leading character in <Text> to its numeric ASCII value. 
BLANK Layout action constant. If your layout condition evaluates to BLANK, 

then the layout will be left blank when the document is printed. 
CHR Returns the character represented by ASCII index <Number>. 
CODABAR Computes a CODABAR barcode. 
CODE128 Computes a CODE128 barcode. 
CODE39 Computes a CODE39 barcode. 
CONTAINS Returns True if <Text> contains <Text to find>,  returns FALSE 

otherwise. 
COUNTER A counter which by default counts from the first to the last record. 

Arguments are optional. 
DATE Returns the current date, formatted according to <Date string format> 

(optional) or the system regional settings. 
DIV Returns the integral quotient from dividing <Number> by <Number>. 
EAN13 Computes an EAN13 barcode. 
EAN8 Computes an EAN8 barcode. 
FALSE Logical constant False. 
FILE_EXIST Returns True if the file <Filename> exist on disk. 
IF Gives one of two results depending on a condition you specify. 
INT Returns the integral part of a floating point number. 
ITF Computes an ITF barcode. 
JAN13 Computes a JAN13 barcode. 
JAN8 Computes a JAN8 barcode. 
KIX Computes a KIX barcode. 
LAYOUT_COUNT Returns the total number of layouts of the current record of the 

database. 
LAYOUT_NR Returns the current layout number. 
LEFT Returns the specified number of characters in the supplied text, 

counting from the left. 
LEN Returns the number of characters in <Text>. 
LOWER Returns all letters in the given text as lowercase. 
LTRIM Returns the supplied text, stripped of all leading spaces, tabs and 

newline characters. 
MID Extracts characters from the supplied text, starting at the character 

position specified by start position and containing the number of 
characters specified by size. 

MOD Returns the remainder after the specified number is divided by a 
divisor. 

MSI Computes a MSI Plessey barcode. 
NOT Returns True if <Logical value> is False, and False otherwise. 
NW7 Any expression which results in a logical value, example True or False. 
OBJECT_EMPTY Determines whether a object with the specified name is empty. 

Returns True or False. 
ONECODE Computes a ONECODE  barcode. 
OR Returns True if either <Logical value 1> or <Logical value 2> is True. 
PAGE_COUNT Returns the total number of pages at printing for this document. 
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PAGE_NR Returns the page number at printing.  
POS Returns the character position of a searched string in text. Returns 0 if 

not found. 
POSTNET Converts a 5 digit (zip code), 9 digit (zip+4 code), or an 11 digit 

(delivery point barcode) to a valid POSTNET barcode. 
PRINT Layout action constant. 
PROPER Convert the first letter of each word to an uppercase character, and 

the rest to lowercase. 
RECORD_COUNT Returns the total number of records of the database. 
RECORD_NR Returns the current record number of the database. 
REPLACE Looks for<Text to find> in <Text> and replaces every occurrence with 

<Replace with text>. 
RIGHT Returns the specified number of characters in the supplied text, 

counting from the right. 
ROUND Returns the supplied number rounded off to the specified number of 

decimal places. 
RTRIM Returns the supplied text, stripped of all trailing spaces, tabs and 

newline characters. 
SGN Returns one of three possible values (-1,0 or 1), depending whether 

the number is negative, zero, or positive. 
SKIP Layout action constant. 
STR Returns the supplied number as data type Text, for use with formulas 

involving text or text functions. 
TEXT_FILE Returns the contents of the TXT or RTF file<Filename>. 
TODAY Returns the current date, according to the computers internal calender, 

formatted according to the system regional settings. 
TRIM Returns the supplied text, stripped of all leading and training spaces, 

tabs and newline characters. 
TRUE Logical constant True. 
UPCA Computes a UPCA barcode. 
UPCE Computes a UPCE barcode. 
UPPER Returns all letters in the given text as uppercase. Use the UPPER 

function to ensure consistent data entry of such things as state 
abbreviations or postal codes. 

VAL Returns number in text as data type Number, for use with formulas 
involving numbers or numeric functions. 

YuBar Computes a YuBar barcode. 
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Expressions Operators 
  
PrintShop Mail Expressions Guide 

 
You can use the following expression operators in PrintShop Mail: 
 

 
 
 
Operators Definition 
+ Add 
- Subtract 
* Multiply 
/ Divide 
( Left parentheses 
) Right parentheses 
< Less than 
<= Less than or equal 
<> Not equal 
> Greater than 
>= Greater than or equal 
= Equal 
" " Denotes a text string 
, Separates parameters in an 

expression 
. Decimal point 
& Ampersand; combines text string 
¶ Line feed; carriage return 
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Barcode Functions 

 

Barcode Functions Overview 
  
PrintShop Mail Expressions Guide 

 
Barcode Basics 
 
A barcode can best be described as an "optical Morse code". Series of black bars and white spaces of varying widths are 
printed on labels to uniquely identify items. The barcode labels are read with a scanner, which measures reflected light 
and interprets the code into numbers and letters that are passed on to a computer. 
 
You must have a reader to read the barcode into the computer. The reader includes: 

• An input device to scan the barcode 
• A decoder to convert the symbology to ASCII text 
• A cable to connect the device to your computer 

Density 
 
Each symbology can encode a different number of characters in a given space with all other factors being the same. 
Numeric only barcodes such as Interleaved 2 of 5 can encode many more numbers in a given space than a more flexible 
symbology, such as Code 128. In many cases this is critical. Even if one symbology is capable of making a barcode of the 
required size, you may get a better first read rate using a different symbology. 
 
Checksums 
 
Checksums are additional characters appended to barcodes to guarantee good reads. Checksums are necessary for some 
barcodes that are prone to errors. For example, Interleaved 2 of 5 is a very dense, numeric only barcode, but it is prone 
to substitution errors. You should always use a checksum on this code. Other codes, such as Code 128 and Code 39, are 
self checking and seldom require a checksum. 
 
Barcode data collection systems provide enormous benefits for just about any business. With a barcode data collection 
solution, capturing data is faster and more accurate, costs are lower, mistakes are minimized, and managing inventory is 
much easier.  
 
You can use the following barcode functions in PrintShop Mail: 

• CODABAR 
• CODE128 
• CODE39 
• EAN13 
• EAN8  
• ITF 
• JAN13 
• JAN8 
• KIX 
• MSI 
• NW7 
• ONECODE 
• POSTNET 
• UPCA 
• UPCE 

 
This is what  barcodes are used for: 
 
Codabar 
Codabar (also known as NW7) is generally used in health care, chemical processing, express delivery and government. 
 
Code 128 
The most common use of Code 128 is for shipping labels. 
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Code 39 
Code 39 is a widely used industrial barcode and is mandated for some automotive industry and Department of Defense 
labels, because of its ability to represent alphanumeric data. Code 39 is a bidirectional, self-checking, discrete and 
variable length code. 
 
EAN/UPC 
The EAN (European Article Numbering) and UPC (Universal Product Code) is used through the world to mark physical 
goods in retail shops. 
 
ITF (Interleaved 2 of 5) 
ITF is one of the most popular barcode used by shipping and warehouse industries for identification. It is also used in the 
medical and automotive fields. 
 
JAN  
The JAN (Japanese Article Numbering) is similar to EAN, used in Japan. 
 
KIX 
KIX barcode is used by the Dutch post office for mail addressing. 
 
MSI/Plessey 
MSI/Plessey (Modify Plessey Code) barcode, are mostly used for marking retail shelves for inventory control. MSI is a 
variable length symbology, however various applications use fixed length codes. 
 
NW7 
Is used at library, parcel delivery service and various other purposes. 
 
ONECODE 
ONECODE barcode used to sort and track packages from their origins to their destination. 
 
POSTNET 
The POSTNET (Postal Numeric Encoding Technique) symbology was developed in the United States for the automatic 
sorting of mail. POSTNET is only used for mailing address marking. 
 
Barcode Fonts 
 
The table below  reflects an example of which font name can be used with each barcode. 
 
Barcode PrintShop Mail Font 

Name 
Example 

CODABAR PSMCbar PSMCbarHrP24DhTt 
CODE 128 PSMC128 PSMC128Bwr3P36DhTt 
CODE 39 PSMC39 PSMC39HrP24DhTt 
EAN 13/ EAN 8 PSMEan PSMEanBwrP36Tt 
ITF PSMInt PSMIntHrP72DmTt 
JAN 13/JAN 8 PSMJan PSMJanBwrP36Tt 
MSI PSMMsi PSMMsiHr72DhTt 
NW7 PSMNW7 PSMNW7HrP48DmTt 
ONECODE OneCode Barcode OneCode Barcode 
POSTNET PSMPostNet PSMPostNetHrTt 
UPCA/UPCE PSMUpc PSMUpcP72Tt 
 
PrintShop Mail font name description 
 
 P = Point size. The Point size refers only to the height of the font. For example if you see C39HrP24DmTt, the P used 
here refers to the point size of 24. 
Dh, Dm and Dl = Density (high, medium and low).The density of a barcode is the number of characters per inch (cpi) of 
the printed  barcode. It is of great practical importance since it determines the minimum barcode length required to print 
the desired information. The higher the density, the shorter the barcode.  
Hr  = Human Readable characters. These characters are printed below the barcode.  
Bwr = Bar Width Reduction. The font includes technology to reduce the width of the individual bars uniformly across the 
barcode without changing the center line of the barcodes.  
 

 
You can install the barcode fonts library from the PrintShop Mail Installers folder on the CD. 
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The PSMFimCodesTt font, used to generate POSTNET barcode, is a special font used by the US Post Office to separate 
business reply mail from other mail. The FIM font consist of four unique barcodes, each barcode represents a unique 
reply mail classification. 
 
Font Information 

• Each font name starts with the letters “PSM”. 
• Some fonts come in human readable versions. 
• Each font has different densities (thicknesses) depending on printer capability. It is recommended that samples 

of each density be printed to verify quality and readability. 
• Font Style: must always be Regular. 

 
Barcode Setup 
 
Below are the steps for setting up a barcode. A Postnet barcode is used for this example. 

1. Click on the text tool on the Tools toolbar to draw a text box, or from the Insert menu, select Variable Text. 
2. Type a variable name, example @Barcode@.  
3. Double click on the Barcode field in the Variables panel, to open the Expression Editor. 
4. Click the radio button titled "Barcode" to display all barcode generators and select the required function from 

the list. A barcode function translate a numerical code to a text string, which yields the desired barcode when 
printed with a special barcode font. Select POSTNET by double clicking on it. 

5. As the argument to the barcode function, enter the database field that contains the code that should be 
translated into a barcode. Some barcode functions require another argument. 

6. Click OK.  
 
Note: PrintShop Mail Postnet function and font, only works with 5, 9 and 11 digit number strings. No hyphens 
can be in the string. 
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7. Select the variable @Barcode@, and pick the barcode font, that is specified for use with the chosen barcode 
generator. 

8. From the Text Formatting toolbar or from the Text menu, select the desired PrintShop Mail font. Adjust the 
font size to show the barcode at the specified or desired size. 
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CODABAR 
 
Syntax CODABAR(Text, Start character, Stop character, 

Check digit) 
Description Computes a CODABAR barcode. 
Example CODABAR("123456", "A", "B", True) 
Result 

 
 
Parameter description 
 
Text The value represented by the barcode.Codabar 

barcodes can include numeric characters, special 
characters (-$:/.+) and spaces. 

Start character One of four special start/stop characters A,B,C and 
D. 

Stop chararcter One of four special start/stop characters A,B,C and 
D. 

Check digit True or False. Default value is False. 
    
Codabar is useful for encoding dollar figures and mathematical figures. These barcodes are slightly larger than 
Interleaved 2 of 5 barcodes. 
 
Codabar requires start and stop characters. The check digit is optional. 
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CODE128 
 
Syntax CODE128(Text) 
Description Computes a Code128 barcode 
Example CODE128("123456") 
Result 

 
 
Parameter description 
 
Text The string to be represented as barcode. The full 

(128-character)ASCII character set can be encoded. 
    
This symbology is a very compact barcode for all alphanumeric applications.  
 
The full (128-character) ASCII character set can be encoded in this symbology without the double characters found in 
extended Code 39.  
 
If the barcode has four or more consecutive numbers (0-9), the numbers are encoded in double density mode (where 
two characters are encoded into one character position). 
 
Code 128 actually has three different character code subsets. It has two forms of error checking, making it a very stable 
barcode.  
 
Checksums are not required. 
 
If you have a choice, Code128 is generally the best all round one. 
 



 

179 

CODE39 
 
Syntax CODE39 (Text[,Check digit]) 
Description Computes a Code39 barcode.  
Example CODE39("Example", True) 
Result 

 
 
Parameter description 
 
Text The string to be represented as barcode. The full 

(128-character)ASCII character set can be encoded. 
 [,Check digit] Optional,True or False. Default value is False. 
    
Code 39 (or Code 3 of 9) is the most common barcode in use for custom applications. It is popular because it: 

• Supports both text and numbers (A-Z, 0-9, +, -, ., and <space>). 
• Can be read by almost any barcode reader in its default configuration. 
• Is one of the oldest of the modern barcodes. 

Code 39 is a variable width barcode, and it can support any number of characters that the reader can scan.  
 
It is used in many military and government specifications.  
 
Code 39 barcodes are self checking and are not prone to substitution errors.  
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EAN13 
 
Syntax EAN13(Text) 
Description Computes an EAN13 barcode 
Example EAN13("978123456789") 
Result 

 
 
Parameter description 
 
Text Any text expression or data field containing a text 

to be represented by the barcode. 
 
EAN (European Article Number) 
 
This function prints the variable barcode for the string using the EAN13 standard, which consists of an 12 digit numeric 
code. To print the barcodes, a special barcode font is needed. 
 
The EAN13 code is used for overseas applications where a country code is required. The UPCA symbology is actually a 
subset of the EAN13 symbology.  
 
This barcode is composed of 2 numbers for the country code, 10 numbers for the data characters, and a checksum. The 
checksum is generated automatically.  
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EAN8 
 
Syntax EAN8(Text) 
Description Computes an EAN8 barcode. 
Example EAN8("9712345") 
Result 

 
 
Parameter description 
 
Text Any text expression or data field containing a text 

to be represented by the barcode. 
 
EAN (European Article Number) 
 
This function prints the variable barcode for the string using the EAN8 standard, which consists of an 7 digit numeric 
code. To print the barcodes, a special barcode font is needed. 
 
The EAN8 code is similar to the EAN13 barcode. Is used for overseas applications where a country code is required, only 
five numbers are used. 
 
This barcode is composed of 2 numbers for the country code, 5 numbers for the data characters, and a checksum. The 
checksum is generated automatically.  
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ITF (Interleaved 2 of 5) 
 
Syntax ITF(Text [,Check digit) 
Description Computes an ITF barcode .ITF has the flexibility to 

encode any even number of digits. If you have an 
odd number of digits, a leading zero will be added. 

Example ITF("1234567890") 
Result 

 
 
Parameter description 
 
Text Any text expression or data field containing a text 

to be represented by the barcode. 
Check digit Interleaved 2 of 5 is prone to substitution errors, it 

is advised to use a check digit. 
 
Also known as I2of5, this is a numeric only barcode that prints out a little larger than the UPCA barcode when 10 digits 
are encoded.  
 
This symbology has the flexibility to encode any even number of digits. 
 
This barcode is an excellent candidate for numeric only applications, and it is the best symbology to use for fixed mount 
readers.  
 
Because Interleaved 2 of 5 is prone to substitution errors, you should always use a checksum. 
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JAN13 
 
Syntax JAN13(Text) 
Description Computes JAN13 barcode 
Example JAN13 ("123456789012") 
Result 

 
 
Parameter description 
 
Text Any text expression or data field containing a text 

to be represented by the barcode. 
 
JAN (Japanese Article Number) 
 
JAN code is most popular barcode for products in the shop.  JAN13 is called as standard code. 
 
JAN13  represents fixed length 13 digits number. It requires fixed length 12 digits of numeric characters for input.  
 
MOD10 check digit is automatically calculated and added. 
 
This barcode is composed of 2 numbers for the country code, 10 numbers for the data characters, and a checksum. The 
checksum is generated automatically.  
 
For JAN barcodes the first two numbers must be 45 or 49 which identifies Japan. 
 
JAN code is equal to EAN code. 
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JAN8 
 
Syntax JAN8(Text) 
Description Computes JAN8 barcode. 
Example JAN8 ("1234567") 
Result 

 
 
Parameter description 
 
Text Any text expression or data field containing a text 

to be represented by the barcode. 
 
JAN (Japanese Article Number) 
 
JAN code is most popular barcode. JAN8 is called simplified code. 
 
JAN8 represents fixed length 8 digits number. It requires fixed length 7 digits of numeric characters for input.  
 
MOD10 check digit is automatically calculated and added. 
 
This barcode is composed of 2 numbers for the country code, 5 numbers for the data characters, and a checksum. The 
checksum is generated automatically.  
 
For JAN barcodes the first two numbers must be 45 or 49 which identifies Japan. 
 
JAN code is equal to EAN code. 
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KIX 
 
Syntax KIX(Postcode, Street address number,Country code) 
Description Computes a KIX  barcode. KIX barcode are used by 

the Dutch post office for bulk mail addressing. 
Example KIX("3842BX", "Daltonstraat 42-44", "NL")  
Result NL3842BX 
 
Parameter description 
 
Postcode Any text expression or data field containing a text. 
Street address 
number 

Any text expression or data field containing a text. 

Country code Any text expression or data field containing a text. 
 
KIX barcode are used by the Dutch post office for bulk mail addressing. 
 
It is imperative that the point size of the KIX code font is 10 point. 
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MSI Plessey 
 
Syntax MSI(Text) 
Description Computes a MSI Plessey barcode. 
Example MSI("1234567890") 
Result 

 
 
Parameter description 
 
Text Any text expression or data field containing a text. 

Numbers must be provided as text. 
   
The MSI Plessey barcode was designed in the 1970s by the Plessey Company in England and is used primarily in libraries 
and retail applications.  
 
This is a numeric only code that stands up well to frequent use.  
 
This code is not self checking, a checksum is highly recommended. 
 
The symbology of the MSI Plessey character set consists of barcode symbols representing the numbers 0-9, the start 
character and the stop character. 
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NW7 
 
Syntax NW7 (Text, Start character, Stop character, Check 

digit) 
Description Any expression which results in a logical value, 

example: True or False. 
Example NW7 ("123456", "A", "B", True) 
Result 

 
 
Parameter description 
 
Text Any text expression or data field containing a text 

 to be represented by the barcode. 
Start character Start character. 
Stop Character Stop character. 
Check digit Optional, True or False. Default value is False. 
 
NW7 is used at library, parcel delivery service and various other purposes. 
 
NW7 supports variable length number up to 100 digits. 
 
When use DR7 / DSR7 / DR9 / DSR9 and if original text includes more than 16 digits of numeric strings, error will be 
returned.    
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ONECODE 
 
Syntax ONECODE(Barcode ID, Special services, Customer ID, Sequence 

no.[,Zipcode]) 
Description Computes a ONECODE solution barcode.  
Example ONECODE("10","042","123456","123456789",[""]) 
Result 

 
 
Parameter description 
 
Barcode ID ID String of exactly 2 characters containing only numeric digits. 
Special services String of exactly 3 characters containing only numeric digits. 
Customer ID String of either 5 or 6 characters containing only numeric digits. 
Sequence no. String with a length of 0 to 9 digits. 
Zipcode Optional string with a length of 0 to 11 digits. 
 
For more information about the ONECODE barcode, please visit www.ribbs.usps.gov/onecodesolution. 
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POSTNET 
 
Syntax POSTNET(Text[,Street address number]) 
Description Converts a 5 digit (zip code), 9 digit (zip+4 code), 

or an 11 digit (delivery point barcode) to a valid 
POSTNET barcode. 

Example POSTNET("12345-6534","152 Oxford Street") 
Result 

 
 
Parameter description 
 
Text Any text expression or data field containing a text 

to be represented by the barcode. 
Street address 
number 

Any text expression or data field containing a text 
to be represented by the barcode. The delivery 
point number is calculated from this text. 

    
POSTNET (Postal Numeric Encoding Technique) 
 
This barcode is the special code that is placed on the lower right portion of an envelope.  
 
It is used to speed mail through the postal service (by automated sorting) and get reduced rates. 
 
Start and stop characters are automatically added by PrintShop Mail. 
 
It is recommended that you have an U.S Postal Service Mailpiece Design Analyst review and approve all POSTNET 
barcodes generated from PrintShop Mail. The Mailpiece Design Analyst is trained to analyze POSTNET barcodes and 
determine whether or not they meet the U.S Postal Service's technical requirements. Output can be send to them via 
email (digital file) fax or mail. Point your Web browser to: http://pe.usps.gov/mpdesign/mpdfr_mda_lookup.asp to find 
the name and contact information for the Mailpiece Design Analyst that is assigned to your geographical area. 
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UPCA 
 
Syntax UPCA(Text, System number) 
Description Computes a UPCA barcode 
Example UPCA("123456789", 0) 
Result 

 
 
Parameter description 
 
Text Any text expression or data field containing a text 

to be represented by the barcode. 
System number Numeric expression or data field containing a 

number which results in a one digit system number 
(0-9). 

 
UPC is the standard barcode for items for sale to the public. It is the code seen on items at the local supermarket. UPCA 
is a fixed length, numeric only barcode. 
 
It contains:  

• 1 digit for a system number 
• 5 digits for the manufacturer number 
• 5 digits for the product number 
• One checksum digit 

The position and value of the digits is standardized by a grocery industry committee. UPCA and UPCE also allow two or 
five digit supplemental numbers. 
 
UPCA and UPCE codes have an automatic checksum.  
 
Only tags with the system character of 0 can be encoded with this symbology.  
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UPCE 
 
Syntax UPCE(Text) 
Description Calculates an UPCE barcode 
Example UPCE("123456") 
Result 

 
 
Parameter description 
 
Text Any text expression or data field containing a text 

to be represented by the barcode. 
 
UPCE is ideal for small packages, because it is the smallest barcode available. This symbology contains the same 
information as UPCA, except that at least four zeros are suppressed. 
 
The position and value of the digits is standardized by a grocery industry committee. UPCA and UPCE also allow two or 
five digit supplemental numbers. 
 
UPCA and UPCE codes have an automatic checksum.  
 
Only tags with the system character of 0 can be encoded with this symbology.  
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Rolan Barcode Function 
YUBAR 
 
Rolan barcode consists of YUBAR. 
 
YUBAR is for Japanese postage barcode defined by Postal Services Agency. 
 
 
Syntax YUBAR(Address code, Postal code) 
Description Computes a YUBAR barcode 
Example YUBAR("1-1-11", "1030013") 
Result 

 
 
Parameter description 
 
Address code Any expression or text field to represent the address code. 
Postal code Any expression or text field to represent the address code. 
    
YUBAR is Japanese postal barcode named Yusei Customer Barcode.  
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Layout Functions 

 

Layout Functions Overview 
  
PrintShop Mail Expressions Guide 

 
 
About layout functions 
 
You can use the following layout functions in PrintShop Mail: 

• Blank 
• Print 
• Skip 

Use these functions to specify which layout should be printed, left blank, or skipped. 
 
PRINT and BLANK commands won't influence the amount of printed pages. 
 
To edit layout conditions 

1. Go to the layout for which you want to change the expression.  
2. From the Layout menu, select Edit Condition or select the layout in the Layout panel, in the properties 

click on Action.  
3. Select one of the layout functions. 

Example 
 
A specific page must go to clients of a specific sales representative ("John"). This field is called 'SALES REP' in the 
database. 
 
The expression used is: 
 
IF([SALES_REP] = "John", Print, Skip) 
 
When PrintShop Mail encounters the name "John" in the "SALES REP" field, it prints the page. In all other cases, the page 
will be skipped. 
 

 
Fiery FreeForm does not support the SKIP function. BLANK is used instead.  
Fiery FreeForm 2 uses BLANK instead of SKIP when Layout Conditioning is used in combination 
with Layout Repetition. 
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BLANK 
 
Syntax BLANK 
Description Layout action constant. If your layout condition 

evaluates to Blank, then the layout will be left blank 
when the document is printed. 

Example IF(VAL([AGE])<55,Print,Blank) 
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PRINT 
 
Syntax PRINT 
Description Layout action constant. If your layout condition 

evaluates to Print, then the layout will be printed. 
Example IF([SALES_REP] = "John", Print, Blank) 
 
In this example, the layout is printed when PrintShop Mail finds the name "John" in the "SALES_REP" field of the 
database. 
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SKIP 
 
Syntax SKIP 
Description Layout action constant.  If your layout condition 

evaluates to Skip, then the layout will be skipped. 
Example IF([SALES_REP] = "John", Print, Skip) 
 
In this example, the layout is skipped when PrintShop Mail finds anything else but the name "John" in the "SALES_REP" 
field of the database. 
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Logical Functions 

 

Logical Functions Overview 
  
PrinShop Mail Expressions Guide 

 
You can use the following logical operators to define conditions in PrintShop Mail: 

• AND 
• FALSE 
• FILE_EXIST 
• IF 
• NOT 
• OBJECT_EMPTY 
• OR 
• TRUE 
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AND  
 
Syntax (Logical value 1) AND (Logical value 2) 
Description Returns True if both <Logical value 1> and <Logical 

value 2> are True. 
Example False AND True => False 
 
Parameter description 
 
Logical value 1 Logical expression. 
Logical value 2 Logical expression. 
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FALSE  
 
Syntax False 
Description Logical constant False 
Example (1<10) = False => False 
 
The result of the example is "False", "1<10", which is True, does not equal "False". 
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FILE_EXIST 
 
Syntax FILE_EXIST (Filename) 
Description Returns True if the <filename> exist on disk. 
Example FILE_EXIST([Image]) 
 
Checks whether a resource, for example an image file exists on your computer. This function returns "True", if the image 
exist on disk.  
 
Parameter description 
 
Filename Filename of file to check the existence of. Any text 

expression or data field containing a text. 
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IF  
 
This function manipulates the database output without changing the content. Its purpose is to make a conditional 
selection from the database. 
 
Syntax IF(Logical test, Value if True, Value if False) 
Description Gives one of two results depending on a condition 

you specify. Returns <Value if True> when 
<Logical test> is True, and <Value if False> 
otherwise. 

Example IF([GENDER]="M", "Mr.", "Mrs.") 
 
In this example, the IF function checks the database field [GENDER], if it contains "M", it returns the string "Mr.". If the 
database field contains anything else, it returns "Mrs". 
 
Parameter description 
 
Logical test Logical expression that determines which of the 2 

parameters values will be returned. 
Value if True Any expression of fieldname. Will be returned if test 

condition evaluates to True. 
Value if False Any expression of fieldname. Will be returned if test 

condition evaluates to False. 
 
You can use the IF function, for example, to create a salutation. See "Inserting a Salutation". 
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NOT  
 
Syntax NOT(Logical value) 
Description Returns True if <Logical value> is False, and False 

otherwise. 
Example NOT(True)=>False 
 
Parameter description 
 
Logical value Any expression which results in a logical value, 

example: True or False. 
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OBJECT_EMPTY 
(Windows only) 
 
Syntax OBJECT_EMPTY(Object name) 
Description Determines whether an object with the specified 

name is empty. Returns True or False. 
Example OBJECT_EMPTY("Text1") 
 
Parameter description 
 
Object name Name of the object to check. 
 
Checks whether the name of an object exist, even when moving objects backward or forward on the same layout or to 
another layout.  
   
This function can also be called upon via the menu Layout>Skip if Object is Empty.  
 
 



 

204 

OR  
 
Syntax Logical value 1 OR Logical value 2 
Description Returns True if either <Logical value 1> or <Logical 

value 2> is True. 
Example True OR False => True  

False OR True => True 
True OR True => True 
False OR False => False 

 
Parameter description 
 
Logical value 1 Logical expression. 
Logical value 2 Logical expression. 
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TRUE  
 
Syntax True 
Description Logical constant True 
Example (1<10) = True =>True 
 
This example returns "True", because the logical test (1<10) is true. 
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Number Functions 

 

Number Functions Overview 
  
PrintShop Mail Expressions Guide 

 
You can use the following functions to manipulate numbers and values in PrintShop Mail: 

• ABS 
• CHR 
• COUNTER 
• DIV 
• INT 
• LAYOUT_COUNT 
• LAYOUT_NR 
• MOD 
• PAGE_COUNT 
• PAGE_NR 
• RECORD_COUNT 
• RECORD_NR 
• ROUND 
• SGN 
• VAL 
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ABS  
 
Syntax ABS(Number) 
Description Returns the absolute value of <Number>.  
Example ABS(-2.3) => 2.3 
 
Parameter description 
 
Number Numeric expression or data field containing a 

Number. 
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CHR 
 
Syntax CHR(Number) 
Description Returns the character represented by ASCII index 

<Number>. 
Example CHR (97) => "a" 
 
Parameter description 
 
Number ASCII index of character to represent. 
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COUNTER 
 
Syntax COUNTER([Start value][,End value] [,Step size] [,Number of positions] 

[,Leading zeroes]) 
Description A counter which by default counts from the first to the last record. 

Arguments are optional. 
Example COUNTER (1,100) 

COUNTER (1,100, 5, 3, True) 
COUNTER (1, 100, 0.5, 3, False) 
COUNTER() 

 
Parameter description 
 
Start value The start value of the counter. Default 1 . 
End value The end value of the counter. Default 10000000000. 
Step size The step size to the next number. Default 1. 
Number of 
positions 

The number of characters the counter will create. By default no extra 
characters will be added.  Default 0. 

Leading zeroes True for leading zeroes, False for no leading zeroes (default). 
 
You can use a counter when printing tickets or numbering your mailing. You do not need to open a database within 
PrintShop Mail when using a COUNTER, if this is the only variable. 
 
The first example creates numbers, starting with 1 and ending with 100. As you browse through the fields of the 
database, the series is as follows: 
1, 2, 3, 4, ..., 99, 100, 1, 2, 3, ... 
The counter restarts once it has reached 100. 
 
The series generated by the second example looks like this: 
001, 005, 010, ..., 090, 100, 005, 010, ... 
The parameters step size, number of positions and leading zeroes have been added. 
 
The third example has a fraction for the step size. This means that the counter increases by 0.5. 
1, 1.5, 2, 2.5, 3, ..., 99.5, 100, 100.5, ... 
 
The last example, COUNTER() starts with 1 and ends at whatever number is set in Items without database (Program 
settings in the Preferences). 
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DIV 
 
Syntax DIV(Number,Divider) 
Description Returns the integer quotient from dividing <Number> 

by<Divider>.  
Example DIV (25, 3) => 8 
 
Both may be a floating point number, and an integer result is returned. 
 
Parameter description 
 
Number Numeric expression or data field containing a number. 
Divider Numeric expression or data field containing a number. 
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INT  
 
Syntax INT(Number) 
Description Returns the integral part of floating point number 

<Number>. 
Example INT(2.78) => 2 
 
Parameter description 
 
Number Numeric expression or data field containing a number. 
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LAYOUT_COUNT 
 
Syntax LAYOUT_COUNT() 
Description Returns the total numbers of layouts for the current record of the 

database. 
Example LAYOUT_COUNT()=>10 
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LAYOUT_NR 
 
Syntax LAYOUT_NR() 
Description Returns the current layout number. 
Example LAYOUT_NR()=>3 
 

 
When using layout conditions, the function LAYOUT_NR will respect the SKIP argument. When 
using PRINT and BLANK, the LAYOUT_NR function will return the number for those layouts. 
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MOD 
      
Syntax MOD(Input number value, Modulus numeric value) 
Description Returns the remainder after the specified number is 

divided by a divisor. 
Example MOD (20, 9) => 2 
 
Parameter description 
 
Input number 
value 

Numeric expression or data field containing a 
number. 

Modulus 
numeric value 

Numeric expression or data field containing a 
number. 
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PAGE_COUNT 
 
Syntax PAGE_COUNT() 
Description Returns the total numbers of pages at printing for this document. 
Example PAGE_COUNT()=>10 
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PAGE_NR 
 
Syntax PAGE_NR ([Reset after each record]) 
Description Returns the page number at printing. If <Reset after each record> 

equals TRUE, the page number will be reset to "1" after each 
record. 

Example PAGE_NR()=>10 
 
Parameter description 
 
Input number 
value 

True to reset to 1 after each record. Leave empty to increment 
the page number continuously throughout all printed records. 

 
This function can also be called upon via the menu: 
 
Insert>Page Numbers  
 
Entire Job: Prints the page number for the entire job. 
Reset After Each Record: Prints the layout number within a record set. 
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RECORD_COUNT 
 
Syntax RECORD_COUNT() 
Description Returns the total number of records of the database. 
Example RECORD_COUNT()=>10 
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RECORD_NR 
 
 
Syntax RECORD_NR() 
Description Returns the current record number of the database. 
Example RECORD_NR()=>10 
 
The function RECORD_NR() yields the current record number. It has no arguments and it does not perform any 
calculations. 
When no records are filtered out and no BLANK is used as a layout expression, it simply increases 1 at a time. 
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ROUND 
         
Syntax ROUND(Number, Precision) 
Description Returns the supplied number rounded off to the 

specified number of decimal places. 
Example ROUND (1.678,2) => 1.68 
 
Parameter description 
 
Number Numeric expression or data field containing a 

number. 
Precision Number of decimal places. Numeric expression or 

field containing a numeric expression. 
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SGN    
         
Syntax SGN(Number) 
Description Returns one of three possible values (-1,0 or 1), 

depending whether the number is negative, zero, or 
positive. 

Example SGN (-345) => -1 
 
Parameter description 
 
Number Numeric expression or data field containing a number. 
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VAL   
 
Syntax VAL(Text) 
Description Returns number in text as data type Number, for use with 

formulas involving numbers or numeric functions. 
Example VAL ("123") => 123 
 
Parameter description 
 
Text Any text expression or data field containing a text to be 

converted to a numeric value. 
 
You can use this function to convert text fields to fields that hold a value.  
If you have a text field that holds number characters, you can convert that field so you can do calculations with it. 
 
Example:  
 
The field [COUPON] holds a text, (for example, "7") 
 
VAL([COUPON])/365 => 0.02 
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String Functions 

 

String Functions Overview 
  
PrintShop Mail Expressions Guide 

 
You can use the following functions to manipulate strings in PrintShop Mail: 

• ASC 
• CONTAINS 
• DATE 
• LEFT 
• LEN 
• LOWER 
• LTRIM 
• MID 
• POS 
• PROPER 
• REPLACE 
• RIGHT 
• RTRIM 
• STR 
• TEXT_FILE 
• TODAY 
• TRIM 
• UPPER 
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ASC 
 
Syntax ASC(Text) 
Description Converts the leading character in <Text> to its 

numeric ASCII value. 
Example ASC ("abc") => 97 
 
Parameter description 
 
Text String from which to get ASCII code from first 

character. 
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CONTAINS 
 
Syntax CONTAINS(text,Text to find) 
Description Returns True if<Text> contains<Text to find>, 

returns False otherwise. 
Example CONTAINS("PrintShop", "Mail")=>False 
 
Parameter description 
 
text Any text expression or data field containing a text. 
Text to find Any text expression or data field containing a set of 

characters you want to verify the existence of. 
 
Searches for a given text in another given text. This example returns "False", because the text ("PrintShop"), does not 
contain the text to find ("Mail").  
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DATE 
 
Windows 
 
Syntax DATE(Input date string[,Date string format]) 
Description Returns the current date, formatted according to 

<Date string format> (optional) or the system 
regional settings. 

Example DATE(database field, "DD MMMM YYYY") or 
DATE("19740227", ""). 

 
Parameter description 
 
Input date 
string 

Date in "YYYYMMDD" format (Example: 20070206). 

Date string 
format 

Enter the output date format. Use the D, M and Y 
symbols to represent the date. 

 
You can use the following parameters for "date string format": 
 
d Number of the day, no leading zero 1 
dd Number of the day, with leading 

zero 
01 

ddd Short weekday name Mon 
dddd Long weekday name Monday 
   
m Number of the month, no leading 

zero 
6 

mm Number of the month, with leading 
zero 

06 

mmm Short month name Jun 
mmmm Long month name June 
   
yy Short year notation 01 
yyy Long year notation 2001 
 
Mac OS 
 
It is possible to specify the format of the expression with format specifiers as shown below. These can be used with the 
DATE and the TODAY function. 
 
Format Specifier Result 
%% A"%" character 
%a Abbreviated weekday name 
%A Full weekday name 
%b Abbreviated month name 
%B Full month name 
%c Shorthand for "%X %x", the locale format for date 

and time 
%d Day of the month as a decimal number (01-31) 
%e Same as %d but does not print the leading 0 for 

days 1 through 9 (unlike strftime(), does not print a 
leading space) 

%F Milliseconds as a decimal number (000-999) 
%H Hour based on a 24-hour clock as a decimal number 

(00-23) 
%I Hour based on a 12-hour clock as a decimal number 

(01-12) 
%j Day of the year as a decimal number (001-366) 
%m Month as a decimal number (01-12) 
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%M Minute as a decimal number (00-59) 
%p AM/PM designation for the locale 
%S Second as a decimal number (00-59) 
%w Weekday as a decimal number (0-6), where Sunday 

is 0 
%x Date using the date representation for the locale, 

including the time zone (produces different results 
from strftime()) 

%X Time using the time representation for the locale 
(produces different results from strftime()) 

%y Year without century (00-99) 
%Y Year with century (such as 1990) 
%Z Time zone name  (such as Pacific Daylight Time; 

produces different results from strftime()) 
%z Time zone offset in hours and minutes from GMT 

(HHMM) 
 
Examples: 
You can use the format specifier to generate different results. 
 
DATE() - Yields a date according to the specified format or according to the date preferences (specify format:"") 
DATE("20020701", "") => 2002-07-01 00:00:00 +0000 
DATE("20020701","%m-%d-%y") => 07-01-02 
DATE("20020701","%m-%d-%y") will give 07-01-02 
DATE("20020701","%b-%A-%Y") will give Jul-Monday-2002 
DATE("20020701","%B-%w-%Y") will give july-1-2002 
 
TODAY() - Yields today's date according to the specified format or according to the date preferences (if format="") 
TODAY("") => "2002-11-07 12:40:10 +0100" 
TODAY("%A %d-%m-%Y %H:%M:%S") => Thursday 07-11-2002  12:40:10 
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LEFT 
 
Syntax LEFT(Text, Number of characters) 
Description Returns the specified number of characters in the 

supplied text, counting from the left. 
Example LEFT ("Personalized Printing", 6) => Person 
 
Parameter description 
 
Text Any text expression or data field containing a text. 
Number of 
characters 

Numeric expression or data field containing the 
number of characters to get. 

 
This function allows you to print a number of characters, counting from the left side of the value in the defined database 
field.  
You can use this function to separate field content or to create a unique code with parts of someone's name. 
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LEN 
 
Syntax LEN(Text) 
Description Returns the number of characters in <Text>. 
Example LEN ("Personalized Printing") => 21 
 
Parameter description 
 
Text Any text expression or data field containing a text. 
 
You can use this function to calculate the length (the number of characters) of the database field. For example, certain 
ZIP codes or barcodes might need to have a specific number of characters to print correctly. 
 
LEN is often used in combination with other functions, such as LEFT, RIGHT, MID and IF, where it can be used to 
determine  exactly how many characters are printed of a selected database field.  
 
In the following example, IF and LEN are combined to calculate the length of the "gender" database field. It also ensures 
that fields without text, but with spacing, are recognized and eventually the correct output is generated. 
 
First 
Name 

Last Name Gender 

John Abrahams M 
Theresa Johnson F 
William Fremont M 
Tom Cooper  
 
IF(LEN([GENDER]) = 0, "Dear Sir, Madam", IF([GENDER] = "m", "Dear Mr." & [Name], "Dear Ms" & 
[Name] ) ) 
 
The result is: 
 
Dear Mr John Abrahams 
Dear Ms Theresa Johnson 
Dear Mr William Fremont 
Dear Sir, Madam 
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LOWER 
 
Syntax LOWER(Text) 
Description Returns all letters in the given text as lowercase. 
Example LOWER ("Personalized Printing") => personalized 

printing 
 
Parameter description 
 
Text Any text expression or data field containing a text. 
 
This function allows you to print the selected database fields in lowercase. 
 
For example, if your database is filled out with information in capitals, you could use this expression to amend this.  
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LTRIM 
 
Syntax LTRIM(Text) 
Description Returns the supplied text, stripped of all leading 

spaces, tabs and newline characters.   
Example LTRIM ("  12") => "12" 
 
Parameter description 
 
Text Any text expression or data field containing a text. 
 
This function removes extra spacing (at the left side of the word) in a combination of variables (for example, when the 
database has set a defined number of characters for each particular database field or when a database field is left 
empty). 
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MID 
 
Syntax MID(Text, Start position,Size) 
Description Extracts characters from the supplied text, starting 

at the character position specified by start position 
and containing the number of characters specified 
by size. 

Example MID ("Personalized Printing", 5, 4) => onal 
 
Parameter description 
 
Text Any text expression or data field containing a text. 
Start position Any numeric expression or data field containing a 

number (start position to get characters from).  
Size Any numeric expression or data field containing the 

number of characters to get. 
 
This function allows you to print a number of characters of the value in the defined database field.  
With MID, you can decide which character you want to start with and how many characters from that point onwards you 
want to print. 
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POS 
 
Syntax POS(Text, String to find, Start position) 
Description Returns the character position of a searched string 

in text. Returns 0 if not found. 
Example  POS("Personalized Printing", " ", 1) => 13 
 
Parameter description 
 
Text Any text expression or data field containing a text. 
String to find String to search for. 
Start position Position to start search from. 
 
This function allows you to search for certain character in the value of a database field. The result will be the position of 
the character you are searching for. 
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PROPER 
 
Syntax PROPER(Text) 
Description Converts the first letter of each word to an 

uppercase character, and the rest to lowercase. 
Example PROPER ("PERSONALIZED printing") => 

Personalized Printing 
 
Parameter description 
 
Text Any text expression or data field containing a text. 
 
This function allows you to clean up improperly filled out databases or to amend all lowercase or all uppercase 
information. 
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REPLACE 
 
Syntax REPLACE(Text, Text to find, Replace with text) 
Description Looks for<Text to find> in <Text> and replaces every 

occurrence with <Replace with text>. 
Example REPLACE("PrintShop Mail", " ", "") => PrintShopMail 
 
Parameter description 
 
Text Any text expression or data field containing a text. 
Text to find Any text expression or data field containing a text. 
Replace with 
text 

String to replace occurrences of <Find string>. Any 
text expression or data field containing a text. 
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RIGHT 
 
Syntax RIGHT(Text, Number of characters) 
Description Returns the specified number of characters in the 

supplied text, counting from the right. 
Example RIGHT ("Personalized Printing", 8) => Printing 
 
Parameter description 
 
Text Any text expression or data field containing a text. 
Number of 
characters 

Numeric expression or data field containing the 
number of characters to get. 

 
Use this function to separate field content or create a unique code with parts of someone's name. 
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RTRIM 
 
Syntax RTRIM(Text) 
Description Returns the supplied text, stripped of all trailing spaces, 

tabs and newline characters. 
Example RTRIM ("12   ") => 12 
 
Parameter description 
 
Text Any text expression or data field containing a text. 
 
This function removes extra spacing (at the right side of the word) in a combination of variables. For example, you can 
use this function when the database sets a defined number of characters for each particular database field or when a 
database field is left empty. 
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STR 
 
Syntax STR(Number) 
Description Returns the supplied number as data type Text, for 

use with formulas involving text or text functions. 
Example STR (123.55) => 123.55 
 
Parameter description 
 
Number Numeric expression or data field containing a 

number. 
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TEXT_FILE 
(Windows only) 
 
Creating variable text blocks, such as paragraphs and bodies of letters is easier with the TEXT_FILE function. The ability 
to read .RTF (Rich Text Format) and .TXT files eliminates the need to copy and paste text strings into Expression logic 
formulas. 
 
Syntax TEXT_FILE(Filename) 
Description Returns the contents of the TXT or RTF 

file<Filename> 
Example TEXT_FILE("TEST.TXT") 
 
Parameter description 
 
Filename Any text expression or data field containing a text 

which holds the Filename of TXT or RTF file. 
 
Allows you to link variable (external) text files in .RTF or .TXT text format to your PrintShop Mail document.  
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TODAY 
 
Syntax TODAY([Number]) 
Description Returns the current date, according to the computers 

internal calender, formatted according to the system 
regional settings. 

Example TODAY() => 20070208 
 
Parameter description 
 
Number The amount of days added to the current date. Numeric 

expression or field containing a number. 
 
This function takes no arguments. It returns the current system date (at the time the current record is printed).  
The date format depends on the preferences defined in regional settings.  
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TRIM 
 
Syntax TRIM(Text) 
Description Returns the supplied text, stripped of all leading and 

training spaces, tabs and newline characters. 
Example TRIM ("   12    ") => 12 
 
Parameter description 
 
Text String to remove leading and trailing spaces, tabs and 

newline characters from. 
 
This function removes extra spacing in a combination of variables (for example, when the database has set a defined 
number of characters for each particular database field or when a database field is left empty).  
 
TRIM removes any extra spacing at the left and at the right side of the word in the database field that has been selected. 



 

241 

UPPER 
 
Syntax UPPER(Text) 
Description Returns all letters in the given text as uppercase. Use the 

UPPER function to ensure consistent data entry of such 
things as state abbreviations or postal codes. 

Example UPPER ("Personalized Printing") => PERSONALIZED 
PRINTING 

 
Parameter description 
 
Text Any text expression or data field containing a text. 
 
You can use this function to print the selected database field in capital letters.  
 
If you are creating a mailing for which you need to print the names in capitals, although the names in the database are in 
lowercase, perform the conversion with UPPER. 
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Plugins 
 

PrintShop Mail plugins 
 
 
Plugins provide a way to define new types of objects that can be used in PrintShop Mail documents. 
 
When PrintShop Mail startup, it will load the plugins. Plugins are located in a folder called "Plugins" in the PrintShop Mail 
installation folder. When PrintShop Mail is started up, it will check for existing plugins in that folder and if present load 
them. If the plugins folder is not found, PrintShop Mail will startup without the plugins. 
 
When you place a plugin object on the layout such as, a text object or an image object it is possible to change its 
properties in the Properties Panel, just like you do with any other object. 
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Windows Shortcuts 
  

Shortcuts Overview 
 
 
Windows Shortcuts Overview 

• File Menu 

Menu Action 
New Blank Document Ctrl + N 
New PDF Based Document Ctrl + Shift + N 
Open Ctrl + O 
Close Ctrl + W 
Save Ctrl + S 
Save As... Ctrl + Shift + S 
Page Setup Ctrl + Shift + P 
Print Preview Ctrl + F2 
Print  Ctrl + P 
Exit Ctrl + Q 
 

• Edit Menu 

Menu Action 
Undo Ctrl + Z 
Redo Ctrl + Y 
Cut Ctrl + X 
Copy Ctrl + C 
Paste Ctrl + V 
Select All Ctrl + A 
Preferences Ctrl + K 
 

• View Menu 

Menu Action 
Preview F2 
Zoom In Ctrl + + 
Zoom Out Ctrl + - 
Actual Size Ctrl + Alt + 0 
Whole Layout Ctrl + 0 
Rulers Ctrl + R 
Object Borders Ctrl + H 
 

• Insert Menu 

Menu Action 
PDF Ctrl + Alt + W 
Image File Ctrl + Alt + E 
Variable Text Ctrl + Alt + T 
Image Box Ctrl + Alt + G 
 

• Text Menu 

Menu Action 
Italic Ctrl + I 
Bold Ctrl + B 
Underline Ctrl + U 
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• Database Menu 

Menu Action 
Open Ctrl + D 
Close Ctrl + Shift + D 
First Record Alt + Up 
Previous Record Alt + Left 
Next Record Alt + Right 
Last Record Alt + Down 
 

• Windows Menu 

Menu Action 
Layouts Ctrl + 1 
Variables Ctrl + 2 
Database Ctrl + 3 
Warnings Ctrl + 4 
Verification Results Ctrl + 5 
Properties Ctrl + Enter 
 

• Help Menu 

Menu Action 
Help Topics F1 
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Macintosh Shortcuts 
  

Shortcuts Overview 
 
 
Macintosh Shortcuts Overview 
 

• PrintShop Mail Menu 

Menu Action 
Preferences Command, 
Hide PrintShop Mail Command + H 
Hide Others Alt + Command + H 
Quit PrintShop Mail Command + Q 
 

• File Menu 

Menu Action 
New Command + N 
New PDF based Document.. Shift + Command + N 
Open Command + O 
Close Command + W 
Save Command + S 
Save As... Shift + Command + S 
Page Setup Shift + Command + P 
Print... Command + P 
Print Record Alt + Shift + Command + P 
Print Report Page Alt + Command + P 
 

• Edit Menu 

Menu Action 
Undo Command + Z 
Redo Shift + Command + Z 
Cut Command + X 
Copy Command + C 
Paste Command + V 
Delete Backspace 
Select All Command + A 
Spelling Command: 
Check Spelling Command; 
 

• View Menu 

Menu Action 
Toolbar Alt + Command + T 
Preview Command + Y 
Layout Rulers Alt + Command + R 
Zoom in Command + + 
Zoom out Command + - 
Actual size Command + = 
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• Insert Menu 

Menu Action 
Image File Shift + Command + E 
Variable Text Shift + Command + T 
Variable Image Shift + Command + G 
 

• Item Menu 

Menu Action 
Lock Position Command + L 
Unlock Position Shift + Command + L 
Show Object Properties Command + Return 
 

• Text Menu 

Menu Action 
Show Fonts Command + T 
Copy Font Alt + Command + C 
Paste Font Alt + Command + V 
Style Bold Command + B 
Style Italic Command + I 
Style Underline Command + U 
Copy Tabruler Command + 8 
Paste Tabruler Command + 9 
Show Colors Shift + Command + C 
 

• Layout Menu 

Menu Action 
First Alt + Shift + Command + Left 
Next Shift + Command + Right 
Previous Shift + Command + Left 
Last Alt + Shift + Command + Right 
Go To... Command + J 
 

• Database Menu 

Menu Action 
Open Alt + Command + O 
Close Alt + Command + W 
First Record Alt + Left 
Next Record Command + Right 
Previous Record Command + Left 
Last Record Alt + Right 
 

• Window Menu 

Menu Action 
Minimize Command + M 
Show Database Command + 1 
Show Variables Command + 2 
Show Layout Conditions Command + 3 
Show Fonts Command + 4 
Show Document Layouts Command + 5 
Show Warnings Command + 6 
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• Help Menu 

Menu Action 
PrintShop Mail Help Command + ? 
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License Agreement 
 

PrintShop Mail User Guide 
 
ELECTRONIC END USER LICENSE AGREEMENT FOR PRINTSHOP MAIL  
 
NOTICE TO USER: THIS IS A CONTRACT. BY INSTALLING THIS SOFTWARE YOU ACCEPT ALL THE TERMS AND 
CONDITIONS OF THIS AGREEMENT. 
 
This Objectif Lune End User License Agreement accompanies the PrintShop Mail product and related explanatory 
materials ("Software"). The term "Software" also shall include any upgrades, modified versions or updates of the 
Software licensed to you by Objectif Lune. Please read this Agreement carefully. Upon your acceptance of this 
Agreement, Objectif Lune grants to you a nonexclusive license to use the Software, provided that you agree to the 
following: 

1. Use of the Software. 
You may install the Software on a hard disk or other storage device; install and use the Software on a file 
server for use on a network for the purposes of: 
(i) permanent installation onto hard disks or other storage devices or 
(ii) use of the Software over such network; and make backup copies of the Software. 
 
You may make and distribute unlimited copies of the Software, including copies for commercial distribution, as 
long as each copy that you make and distribute contains this Agreement, the PrintShop Mail installer, and the 
same copyright and other proprietary notices pertaining to this Software that appear in the Software. If you 
download the Software from the Internet or similar on-line source, you must include the Objectif Lune 
copyright notice for the Software with any on-line distribution and on any media you distribute that includes the 
Software. 
  

2. Copyright.  
The Software is owned by Objectif Lune and its suppliers, and its structure, organization and code are the 
valuable trade secrets of Objectif Lune and its suppliers. The Software also is protected by Dutch Copyright 
Law. 
  

3. Restrictions. 
You agree not to modify, adapt, translate, reverse engineer, decompile, disassemble or otherwise attempt to 
discover the source code of the Software. You may not alter or modify in any way the installer program or 
create a new installer for the Software. The Software is licensed and distributed by Atlas for creating optimized 
print jobs. 
  

4. No Warranty. 
The Software is being delivered to you AS IS and Objectif Lune makes no warranty as to its use or 
performance.  
 
OBJECTIF LUNE AND ITS SUPPLIERS DO NOT AND CANNOT WARRANT THE PERFORMANCE OR RESULTS YOU 
MAY OBTAIN BY USING THE SOFTWARE OR DOCUMENTATION. OBJECTIF LUNE AND ITS SUPPLIERS MAKE 
NO WARRANTIES, EXPRESS OR IMPLIED, AS TO NONINFRINGEMENT OF THIRD PARTY RIGHTS, 
MERCHANTABILITY, OR FITNESS FOR ANY PARTICULAR PURPOSE. IN NO EVENT WILL OBJECTIF LUNE OR 
ITS SUPPLIERS BE LIABLE TO YOU FOR ANY CONSEQUENTIAL, INCIDENTAL OR SPECIAL DAMAGES, 
INCLUDING ANY LOST PROFITS OR LOST SAVINGS, EVEN IF AN OBJECTIF LUNE REPRESENTATIVE HAS BEEN 
ADVISED OF THE POSSIBILITY OF SUCH DAMAGES, OR FOR ANY CLAIM BY ANY THIRD PARTY.  
 
Some states or jurisdictions do not allow the exclusion or limitation of incidental, consequential or special 
damages, or the exclusion of implied warranties or limitations on how long an implied warranty may last, so the 
above limitations may not apply to you. 
  

5. Governing Law and General Provisions. 
This Agreement will be governed by the laws of the Netherlands, excluding the application of its conflicts of law 
rules. This Agreement will not be governed by the United Nations Convention on Contracts for the International 
Sale of Goods, the application of which is expressly excluded. If any part of this Agreement is found void and 
unenforceable, it will not affect the validity of the balance of the Agreement, which shall remain valid and 
enforceable according to its terms. You agree that the Software will not be shipped, transferred or exported 
into any country or used in any manner prohibited by any export laws, restrictions or regulations. This 
Agreement shall automatically terminate upon failure by you to comply with its terms. This Agreement may only 
be modified in writing signed by an authorized officer of Objectif Lune. 
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Objectif Lune Inc. 
2030 Pie IX, Suite 500 
Montréal, QC 
Canada H1V 2C8 
www.objectiflune.com 
 
YOUR ACCEPTANCE OF THE FOREGOING AGREEMENT WAS INDICATED DURING INSTALLATION. 
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Trademarks 
PrintShop Mail 
 

  
 
All trademarks referenced in this user's guide and the PrintShop Mail application, are the trademarks or registered 
trademarks of their respective holder. 

• Adobe,Acrobat, PostScript and all related products are registered trademark of Adobe System Incorporated. 
• The included Adobe ICC Profiles are copyright of Adobe System Incorporated. 
• LibTIFF : Copyright (c) 1988-1997 Sam Leffler; Copyright (c) 1991-1997 Silicon Graphics, Inc. 
• Apple and Macintosh are registered trademarks of Apple Computer, Inc. 
• Creo VPS is a registered trademark of Creo Corporation Ltd. 
• PPML is a registered trademark of PODi. 
• VIPP is a registered trademark of Xerox Corporation. 
• PrintStreamer is a registered trademark of Barco 
• Windows, Word and Excel are registered trademarks of Microsoft in the U.S. and other countries. 
• PlanetPress Suite is a registered trademark of Objectif Lune Inc. 
• PrintShop Web is a registered trademark of Objectif Lune Inc. 
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Glossary 

A 
Anchoring: Defines the dynamic relationship between the position and size of two objects. Anchored objects are items, 

such as images or text boxes that are connected to each other in such a way that a change in position or size 
of an anchor Master will affect the position and size of any number of anchor Childs. It is possible to add more 
objects (Childs) and make their position relative to the first object (Master) by using the corresponding Top, 
Left, Width, and Height properties. If the first added object (Master) is empty or contains less data, the object 
defined as (Child) moves to the free space. 

APR: Automatic Picture Replacement. A mechanism that automatically replaces low resolution images with high 
resolution images. 

C 
CMS: Color Management System. Software that allows applications and printer drivers to access information about the 

color characteristics of monitors, printers, and scanners. The CMS uses the color information to provide 
accurate and consistent color to the output device. 

Crop Marks: Printed or drawn lines indicating where the paper should be cut to produce the correct page size. Crop 
marks are necessary for offset printing because the original paper that goes through the printing press is 
usually larger than the final page size. 

D 
Database: A file containing information grouped in records. The records consist of fields that hold the actual information. 

DDE: DDE (Dynamic Data Exchange) allows two applications to interact with each other. PrintShop Mail acts as a DDE 
server, accepting commands from a client application. 

Direct Digital Printing: Commercial-quality printing in which electronic source files are processed directly on the 
printing press or printing system, rather than through analog steps such as film imagesetting and platemaking. 
Direct digital printing systems may be based on lithographic offset technology or laser/toner technology. Front-
end RIPs and servers are integrated components of these printing systems. 

Distributed Printing: Printing directly to printers (imagesetters or direct digital presses) that are located far from the 
operator's workstation. May include multiple destinations for a single job. Often associated with on-demand and 
short-run printing. 

DPI: Dots Per Inch. A measure of the resolution of a device. The higher the number, the sharper the type and images. 

E 
EPS: Encapsulated PostScript. A standard file format for importing and exporting PostScript® language files among 

applications in a variety of heterogeneous environments. 

I 
Imposition: The process of arranging individual pages on a form in preparation for the printing press so that the pages 

will be in proper sequence after printing, folding, and binding. 

Interpreter: The Adobe PostScript Raster Image Processor (RIP) that translates the instructions in a PostScript language 
file sent from the printer driver. 

Items: The objects that make up the layout, such as image boxes and textboxes. 

K 
Kerning: Refers to adjusting the space between characters, especially by placing two characters closer together than 

normal. 
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L 
Layout conditioning: Specifying which page should be printed, according to database information. 

Leading: Leading is the measurement of space occupied by a line of text measured from one baseline to the next 
baseline. A leading value includes the font size plus the space between lines. 

O 
Offset Printing: The most common commercial printing technology in use today. Offset printing applies layers of ink on 

the page. For each layer, a reverse image of the page is placed on a roller in the printing press. Ink is applied 
to the non-image areas on the roller, so that as the roller presses against paper moving through the press, the 
proper image is left on the paper. 

On-Demand Printing: Commercial-quality printing produced as needed with turnarounds of a few hours or less. Often 
associated with very short runs of a hundred or fewer pieces. A newer class of device - the direct digital 
printing system - is usually associated with on-demand printing. 

OPI: Open Prepress Interface. A set of PostScript language comments for defining and specifying the placement of 
images on an electronic page layout. 

P 
Papertrays: A physical tray in the printer that holds media of different sizes or colors. 

PDF: Portable Document Format. 

Pixel: The smallest dot that can be produced on a computer screen. 

Point: A basic unit for typographic measurement. A point is equal to 1/72th of an inch. 

PostScript: Adobe PostScript is a worldwide standard for printing and imaging. This technology is licensed to OEM 
partners for integration and customization with their output devices and workflows. 

Prepress: The steps required to turn a design into final form, ready for final printing on a printing press. May include 
preflight, color correction, color trapping, imposition, color separation, proofing, and imagesetting. 

Print technology: The 'language' used to send data to the printer or the RIP. 

Printable Area: The area on the media that your printer can print on. 

Printer Driver: Software that serves as the communication link between applications and the page-description language 
used by printers. 

R 
RIP: Raster Image Processor. The hardware and/or software that translates data from PostScript and other high-level 

languages into dots or pixels in a printer. 

S 
Static text: Text that contains no variable information, it will not change when browsing through the database. 

Subset finishing: The process of applying a finishing option (such as stapling or binding) to all pages of the same 
record. 

T 
TrueType Fonts: Scalable typefaces for Windows and Macintosh software. 

Type 1 (PostScript) Fonts: Adobe's industry-standard outline font technology that enables type to be scaled to any 
size while staying sharp and clear. More than 20,000 Type 1 typefaces are available from vendors worldwide. 
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B 
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BLANK..................................................... 44, 172, 195 
Bleed Margin.......................................... 121, 123, 154 
Bounding................................................................ 96 
C 
Capitalizing ........................................................... 168 
Child's .................................................................. 133 
CHR ..............................................................172, 208 
CMYK ...................................................... 96, 102, 147 
CODABAR ......................................................172, 175 
CODE128.......................................................172, 175 
CODE39 ........................................................172, 175 
Color ........................................................................8 
Color Management ................................................ 147 
Color profiles ........................................................ 147 
Colorimetric .......................................................... 147 
Commandline.......................................................... 83 
Company Web Server............................................ 156 
Configuration .......................................................... 26 
Contain .................................................................. 40 
CONTAINS.....................................................172, 224 
Convert .................................................................. 96 
Copies .................................................................... 51 
Copy fitting.............................................. 96, 106, 112 
Copying Objects.................................................... 127 
COUNTER.............................................. 171, 172, 208 
Create ZIP .............................................................. 75 
Creating ................................................................. 12 
Credit Information................................................... 14 
Creo............................................................. 1, 66, 72 
Creo VPS ................................................................ 66 
Crop Marks ....................................................123, 154 
Custom Serial Number....................................168, 171 
D 
Data....................................................................... 26 
Data Field Properties ............................................... 22 
Data Fields ............................................................. 32 
Data Triggers.......................................................... 40 
Database.........................................................57, 158 
Database Toolbar...........................................135, 136 
DATE.............................................................172, 224 

DBF ........................................................................22 
DDE..................................................................82, 88 
Default Tab Stops..................................................112 
Design .................................................. 20, 22, 32, 57 
Designer ...........................................................14, 57 
Dictionary .............................................................110 
DIV............................................................... 172, 208 
Document ................................................... 12, 17, 54 
Document’s colors .................................................147 
Documents..............................................................57 
Dongle....................................................................14 
DPI.........................................................................40 
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