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1 About PrintShop Mail

Leverage the real potential of your data by printing variable images and text based upon
unique information on each individual recipient!

Overview

PrintShop Mail is a fast, efficient and very easy to use professional software tool that makes personalized
printing quick and easy. It allows you to optimize the process of merging variable database information with a
design. For advertisements, direct mailing, flyers or any other type of promotional documents, you can rely on
PrintShop Mail. PrintShop Mail enables users to perform simple and complex Variable Data Printing jobs for
medium to high volume output quantities.

By simply dragging and dropping database fields onto the document layout, PrintShop Mail creates a link
between the database field and your document. PrintShop Mail gives you an instant preview and provides you
with a powerful resource checking option to ensure proper printing. Utilize the comprehensive set of
conditional rules for database driven composition.

¥ Verify Document before printing.
¥ Preview repetition settings.
¥ Support for vertical text and double byte characters.

During the printing process, the variable information from the database is sent to the printer on the fly. The
static portion of the job does not need to be re-ripped. This greatly shortens the printing process and prevents
network congestion.

PrintShop Mail then allows your PostScript¨ printer to print at or near rated speed, depending on RIP
capability. This makes variable information printing an efficient process.

Benefits
¥ Easy to use: no programming experience needed
¥ No need to change your design application, database, PostScript RIP or printer
¥ Variable Information Printing at rated speed of the printer!
¥ Reduced print cost and print wastage
¥ Efficient production process saves time and money
¥ Open architecture - plugs in easily into your existing workflow
¥ Instant preview to see results before printing to facilitate accuracy
¥ Layout and database can be created separate from each other
¥ Resource check on print stream reliability
¥ Finishing options per record or per set
¥ Nine free bar code fonts included!

Business applications
¥ Targeted Advertisements
¥ High Speed Mail Merges
¥ Direct Mailings
¥ Discount Coupons
¥ Postcards
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¥ Flyers
¥ Tickets
¥ Certificates
¥ Letters and moreÉ

About PrintShop Mail
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2 Contact Information

To find an Objectif Lune office near you and for more information on our products and services, visit
www.objectiflune.com .
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3 Using PrintShop Mail Help

Here are some tips on how to use this PrintShop Mail on-line Help.

About the Help Display

You can use several navigation tools in this Help system. The Help is divided into a left-hand and right-hand
frame. The right-hand frame shows the actual texts and some navigational aids, the left-hand frame is the
mainstay for the navigational aids. You can select four options above the left-hand frame:

¥ Hide / Show : To display or hide the Contents.
¥ Back :To display the previous topic you selected.
¥ Forward :To display the next topic you selected.
¥ Print :To print one or more topics.

Contents, Index and Search Tabs

The left-hand frame contains the following tabs, which access these navigation aids:

¥ Contents
¥ Index
¥ Search

Hyperlinks and Related Topics

The right-hand frame contains the following navigation aids:

¥ Hyperlinks
¥ Related topics

To use the Help navigation tools

Contents

Note : The Contents are displayed by default. Click the other tabs to access the corresponding
navigational aids.

1. If not selected, click the Contents tab.
The table of contents appears in the left-hand frame. It is represented in the form of a tree structure
with book icons. These books are structured hierarchically.

2. Click a book icon.
3. Click a page icon.

The corresponding Help text appears in the right-hand frame.

Index
1. Click the Index tab.
2. In the text box, begin to type the first letters of the keyword you want information on or the entire

keyword. The list below will jump to the first word beginning with the letters you typed.
The selected keyword is highlighted.

3. Continue to type more letters to narrow down the choice, or click the correct keyword if you can identify
it.

4. Click Display .
The corresponding Help text is shown in the right-hand frame.
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Search
1. Click the Search tab.

At the top of the Search tab sheet, there is a box in which you can type the keyword.
2. Click List Topics .

A list with topics containing the keyword is displayed.
3. Click the topic you want.
4. Click Display .

The Help text is displayed in the right-hand frame. The selected keyword is highlighted.

Hyperlinks

The Help text contain hyperlinks. These are underlined texts. Click the underlined text to view the Help topic.

Related topics

The Related Topics provide access to topics that deal with similar subjects.

Using PrintShop Mail Help
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4 Getting Started

4.1 Installing PrintShop Mail

Before you start

If you are installing PrintShop Mail on a computer with Windows 2000, XP, 2003 or Vista, make sure you are
logged in with full administrative rights before running the installation program.

To install PrintShop Mail

Windows

1. Locate the setup.exe file on the CD-ROM.
2. Double click this file to start the installation wizard.
3. Select the language you want to use for the installation.
4. Click OK .
5. Click Next .
6. Read the license agreement and select I accept the terms in the license agreement. (If you select I do

not accept the terms in the license agreement, the installation stops).
7. Click Next .
8. Specify whether you want PrintShop Mail to be available for all users on the computer, or just for the

current user.
9. Click Next .

10. Choose between a Complete or Custom setup.
¥ If you select Complete , all necessary program features will be installed. This option automatically

installs all available languages.
¥ If you select Custom , use the next screen to select or clear program features.

To create a custom installation
1. Click the hard disk icon to view four choices for the selected feature:

This feature will be installed on local hard drive.
This feature, and all subfeatures, will be installed on local hard drive.
This feature will be installed when required.
This feature will not be available.

2. Select the options you want.
3. To change the default installation directory, click the Change button and select the directory for the

PrintShop Mail installation.

With either selection you have the option to verify your installation settings.

1. After you have set the option you want, click Next .
2. Press Install to continue the installation wizard.
3. Click Finish .

Mac OS

Note : PrintShop Mail 5.4 is supported on Macintosh Operating System 10.4.11 and later (including Operating
System 10.5).

1. Locate the PrintShop Mail 5.4.x.dmg file on the CD-ROM.
2. Double click on this file.
3. Select the language you want to use for the installation.
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4. Read the license agreement and select " Agree ". (If you select " Disagree " , the installation will be
canceled).

5. A window will be displayed " Opening PrintShop Mail 5.4.x.dmg".
6. You can drag the PrintShop Mail icon to the Applications folder or to any other location on your

computer.

Getting Started - Installing PrintShop Mail
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4.2 What's New in PrintShop Mail

Printing
¥ PrintShop Mail can print to any output engine, also non PostScript printers. When selecting the printer

driver for your printer, PrintShop Mail detects if it is a PostScript printer or not. If it is not a PostScript
driver, the output is handled differently to be able to print to that printer, which allows you to print un-
optimized to a non PostScript printer, like PCL.

¥ Adobe PDF Print Technology has been added, which allows you to save optimized PDF files directly from
PrintShop Mail. The PDF output files can be used for printing to PostScript level 3 printers and soft
proofing when uploading PrintShop Mail documents to PrintShop Web.

¥ Print to Web option has been added to the File menu, which allows you to print directly from within
PrintShop Mail to PrintShop Web. The output will be generated on the PrintShop Web server, not on the
computer where the PrintShop Mail document is created.

Database
¥ A new operator CONTAINS has been added to the database filter options, which allow filtering strings

from the database.
¥ Opening flat database files (csv,txt) has become easier. When opening those database formats, a dialog

is shown where you can set the separator and the character encoding correctly.
¥ Support for Officer 2007 databases has been added.

Variables
¥ A logical function CHANGED has been added, which determines if the value of a variable or field from

the database has changed compared with the previous record. By defining actions on a previous record
you influence the output result.

Documents
¥ Automatic synchronization of Word document placed on PrintShop Mail has been added, allowing you to

update the content of your PrintShop Mail document.
¥ Fonts used in Printshop Mail documents will be checked on availability, if a font is not available,

PrintShop Mail will generate a warning for each missing font and the font will be replaced.
¥ PrintShop Mail is able to use fonts that are not installed on the system. Fonts files available in the

document folder are detected by PrintShop Mail and used in the document.
¥ Support for Office 2007 Word documents has been added.
¥ Zoom buttons have been added to the View toolbar, making it easier to get a quick overview of the

layout and quick toggle between the view options.
¥ Word Wrap has been extended. When Copy Fitting is enable, the words can be kept together or can be

broken to the next line when the text does not fit completely on the line.
¥ PrintShop Mail Warnings and Verification Results messages can be copied.
¥ Save for Output option has been added to the File menu, making it easier to move and open PrintShop

Mail documents to another computer. The PrintShop Mail document and its files will be archived in a zip
file.

User Interface
¥ Resetting Windows position, Toolbar position and Preferences has been added. Holding the Ctrl+Shift

keys when starting the application allows you to reset the Windows Position, Toolbar position and the
Preferences setting to the default PrintShop Mail settings.
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4.3 Upgrading PrintShop Mail

The hardware key contains the license information of the PrintShop Mail application.

To view the license information, select Help / Credit Information .

To use certain features in PrintShop Mail, your license must be upgraded before you are allowed to use this
feature. This count for the amount of credits, CARE, automated printing and multi user licenses.

Credits

Unlimited or Production version, allows unlimited records to be printed.

Limited or Standard version, allows 200,000 records to be printed.

CARE

The care date determines which PrintShop Mail version is licensed. Each PrintShop Mail version has an own
release date, which is compared with your care date. If your care date is equal or newer than the
release date, the application will run as licensed, otherwise the application will run in demo mode.

Automated printing

Enabling this option allows scripting of PrintShop Mail with API, Scripting or DDE.

Multi-User Licenses (Windows only)

A Multi-user license is a license that will allow multiple users to print a PrintShop Mail job simultaneously to a
printer that is found within the Local Area Network (LAN).

All Multi-user license versions allow for an unlimited number of database records to be merged.

Cross Platform

A cross platform license hardware key allows to run PrintShop Mail on Windows and Macintosh systems.

PrintShop Mail upgrade options

The Upgrade options are only enabled when the PrintShop Mail hardware key is attached to the computer
where the upgrade procedure is performed.

To upgrade your hardware key

From the Help menu, you can select from three different upgrade menu items:

¥ Voucher
¥ Upgrade request
¥ Activate dongle
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Voucher

If you have a PrintShop Mail voucher number, click on the "Voucher" option. A PrintShop Mail voucher web
page will open. Here you need to enter the voucher number and some additional information to confirm the
request.

Upgrade

If you want to add credits, upgrade the version, add OL CARE or another option, click on the "Upgrade"
option. The PrintShop Mail Upgrade page will open. Here you select the options you want and some additional
information to confirm the request.

Activate dongle

If you have received an Authorization code back from your voucher or upgrade request (by email), you have
to copy that code into the Activate dongle screen. Then click " Activate ".

Getting Started - Upgrading PrintShop Mail
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4.4 Help Overview

These are the basic steps to install PrintShop Mail and create PrintShop Mail documents.

Click each topic to follow this step by step guide.

Installing PrintShop Mail
¥ Installation Procedure (Page 6)

Step by Step Guide
¥ Starting a New Document (Page 14)
¥ Opening the Database (Page 22)
¥ Inserting Static and Variable Images (Page 38)
¥ Creating Variable Text (Page 31)
¥ Layout Conditioning (also known as "page picking" ) (Page 42)
¥ Selecting Paper Trays (Page 47)
¥ Layout Repetitions (Page 45)
¥ Print Preview (Page 69)
¥ Verifying the Layout (Page 53)
¥ Saving Your Document (Page 56)

After you create and verify the PrintShop Mail document, it is ready to print or publish to PrintShop Web.

¥ Printing Basics (Page 69)
¥ Publishing Documents (Page 58)
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4.5 Installing a Printer Driver

PrintShop Mail is capable of generating PostScript and non PostScript output.

PostScript output

To generate PostScript output, PrintShop Mail must communicate with a PostScript printer driver. The
PrintShop Mail installer installs a PostScript printer which will be used by the application to generate PostScript
output.

We recommended that you use either the Adobe or Microsoft printer driver in order to install your own printer.

Adobe PostScript Driver

Printer installation using the Adobe PostScript driver requires the AdobePS installer and a PPD (PostScript
Printer Description) file.

For more information about Adobe PostScript Driver, please visit www.adobe.com .

Microsoft PostScript Driver (Windows only)

You can install a printer using the Microsoft PostScript driver with the Add Printer wizard in the Windows
Control Panel . The wizard prompts for an INF file containing printer specific information.

Non PostScript output

When you want to print to a non PostScript printer, you just have to select the printer driver for that printer.
PrintShop Mail will print through that printer driver non optimized output. Printing and spooling time will be
significantly slower compared to other print technologies like Optimized PostScript.

Objectif Lune Inc. © 2010 12
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4.6 Installing the Hardware Key

About the hardware key

Without a hardware key, also known as "Dongle", PrintShop Mail runs in Designer mode. In this mode, all
PrintShop Mail functions are available, but you can only print up to 25 records per session and PrintShop Mail
is printed over each layout.

If you have a hardware key from older versions of PrintShop Mail, it will need to be upgraded. Otherwise,
PrintShop Mail will run in Designer mode. For more information, see Upgrading PrintShop Mail (Page 9) .

This is a picture of the USB hardware key (though your key may differ slightly in appearance).

You can use each credit on your hardware key to print one record.

To install the hardware key

Windows

Attach the hardware key to the USB port on your computer.

To view the amount of credits available on the hardware key:

1. Start PrintShop Mail.
2. From the Help menu, select Credit Information .

Mac OS

Attach the hardware key to the USB port on your computer.

1. Start PrintShop Mail
2. From the Help menu, select Install Dongle Software...
3. Follow the instructions on the screen

To view the amount of credits available on the hardware key:

1. Start PrintShop Mail.
2. From the Help menu, select Credit Information .

Objectif Lune Inc. © 2010 13



5 How to

5.1 Create a New Document

Windows

You can create a new PrintShop Mail document in two ways:

¥ Start with a blank layout
¥ Base the contents and size of your layouts on a PDF or an image file.

To start with a blank document

On startup, PrintShop Mail always starts out with a blank layout. You can also instruct PrintShop Mail to create
a new blank document by selecting New Blank Document from the File menu, or press CTRL+N.

The size of this blank layout is set to Fit to Page . For more information on layout sizes, see How to Specify
the Layout Size (Page 18) .

Now you can use the design tools in PrintShop Mail to add static and variable objects to your layouts. For
more information, see How to open a database (Page 22) , How to add images (Page 38) and How to add
variable text. (Page 31)

To base the layout contents on a PDF or image file

From the File menu, select New PDF based Document or press CTRL+SHIFT+N, to select a PDF document
or a Word document. The Word document will automatically be converted to a PDF file, using the current
selected printer driver. This will create layouts that match the pages in the PDF file.

If Microsoft Word documents are used, PrintShop Mail documents will be updated when the original Word
document has been changed. If the Word document is missing or has been moved to another location but the
PDF file is available, PrintShop Mail will issue a warning.

Note : After you create a new PDF based document, the PDF pages are treated as separate objects. It is
possible to scale the PDF pages around on the layout. You can also place a PDF by choosing PDF from the
Insert menu or click the Place PDF button in the Tools toolbar.

PrintShop Mail Templates

PrintShop Mail allows you to create PrintShop Mail templates. Templates are PrintShop Mail documents that
you can design for later use, for example for Publishing to PrintShop Web. These templates contain the
(background) layout and the document settings.

Creating a template

You can create a PrintShop Mail template in two ways:

¥ From a PrintShop Mail document:

1. Start PrintShop Mail.
2. Create the desired PrintShop Mail document.
3. From the File menu, select Save as Template .
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¥ New Template document:

1. Start PrintShop Mail.
2. From the File menu, select New Template-based Document .
3. Browse for a template file.
4. Click Open .
5. Make the desired changes.
6. From the File menu, select Save As Template .

PrintShop Mail templates are saved with the extension ".PSMT". By default PrintShop Mail templates will be
saved in the Template folder which is located in the PrintShop Mail application folder.

Modifying the template

It is possible to modify PrintShop Mail templates to change the document settings or content.

1. From the File menu, select Open Template .
2. Make the desired changes.
3. From the File menu select Save As Template .

Note : A template does not save the link to the database you may have used in the designed stage of
the PrintShop Mail document.

Mac OS

On startup, PrintShop Mail always starts out with a blank layout. The size of the blank layout is set to
Automatic . To change the layout size, see How to Specify the Layout Size (Page 18) .

Related Topics

¥Add Static and Variable Images (Page 38)

¥Add Variable Text (Page 31)

¥Open a Database (Page 22)

¥Specify the Layout Size (Page 18)

How to - Create a New Document
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5.2 Default Settings

Default settings in PrintShop Mail are time savers. If the default settings don't fit the way you work, you may
find yourself repeatedly customizing each document individually before you can get started.

In PrintShop Mail it is possible to reset the default settings in the Preferences, to do that:

1. Start PrintShop Mail.
2. From the File menu, select Close . On startup, PrintShop Mail always starts out with a blank layout.

(Windows ): From the Edit menu (Ctrl+K), select Preferences .
(Mac OS ): From the PrintShop Mail menu (Command,), select Preferences .

3. Make the appropriate changes.

Note : Adjust the settings while no documents are open and those settings become the default for all
new documents. Changes made while a document is open affect that document only.

The default settings that can be fine tuned for all documents are:

¥ Program (Page 148)
¥ Colors (Page 150) (Page 148)
¥ Print Job (Page 154)
¥ Repetition (Page 156)
¥ Imposition (Page 159)
¥ PrintShop Web (Page 161)
¥ PlanetPress Suite (Page 163)

Reseting PrintShop Mail to it's Default settings

PrintShop Mail allows you to reset the Window Positions, Toolbar Configuration and the Preferences settings to
its Default settings.

To Reset one of those settings or all of them, do the following:

1-Hold the Ctrl+Shif keys when starting PrintShop Mail.

The following dialog will be displayed:

2-Select all the settings you want to reset.

Objectif Lune Inc. © 2010 16



Window positions : Set the location of the floating window back to its original location. It will also show or
hide windows if they are in that state by default.

Toolbar configuration : Set the location of the toolbars back to its original location. It will also show or hide
toolbars if they are in that state by default.

Preferences : Set the Preferences settings back to its default, except for the Language Interface.

Related Topics

¥Bleed Margin (Page 126)

¥Crop Marks (Page 127)

¥Folding Lines (Page 124)

¥Guide Lines (Page 123)

¥Printing Basics (Page 69)

¥Use Layout Repetition (Page 45)

How to - Default Settings
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5.3 Specify the Layout Size

Windows

A PrintShop Mail document may consist of one or more layouts, which can be of different sizes. PrintShop Mail
supports multiple layout sizes within one document.

On startup, PrintShop Mail always starts out with a blank layout. The size of this blank layout is set to Fit to
Page . The layout size and shape (tall or wide) can be specified per each layout by selecting Size in the
Layout menu or by selecting the layout in the Layouts Panel (Page 91) .

Locating this dialog box

The table below shows more information on the options in the Layout Size dialog.

Setting Description

Size Select a standard size for the PrintShop Mail document, A3, A4, A5, B5, US Letter, US Legal.
Select Custom Size to enter customized settings.

Width Enter custom width. This setting is editable if you select "Custom Size".

Height Enter custom height. This setting is editable if you select "Custom Size".

Shape Select either Tall or Wide.

Apply
to

Current Layout
This point forward
Whole document

Note : PrintShop Mail supports mixed layout sizes, except when layout repetition is used. When using
layout repetition, the first layout size will be the layout size for the complete document.

Mac OS

A PrintShop Mail document may consist of one or more layouts, all having the same size. There are two ways
to specify the layout size and orientation.

Objectif Lune Inc. © 2010 18



Automatic Layout Size

You can choose to base your layout size on the currently selected paper size in the Print Setup dialog, by
selecting Layout Size Automatic in the Layout menu. This will cause PrintShop Mail to dynamically resize
your layouts to fit on the paper, even when you are using layout repetition.

Fixed Layout Size

You can specify a fixed layout size in the Layout Size dialog. This will force your layout size to stay the same,
independent of the currently selected printer and paper size.

The table below shows more information on the options in the Layout Setup dialog.

Setting Description

Size Select a standard size for the PrintShop Mail document, A4, A5, B5, US Letter, US Legal.
Select Custom Size to enter customized settings.

Width Enter custom width. This setting is editable if you select "Custom Size".

Height Enter custom height. This setting is editable if you select "Custom Size".

Orientation Select either Tall or Wide.

Related Topics

¥Layout Repetition (Page 45)

¥Repetition (Page 156)

How to - Specify the Layout Size
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5.4 Specify Spot Colors

Spot Colors are special premixed inks used instead of, or in addition to CMYK inks. Spot Colors are used in
offset printing to reduce printing cost or to provide solid colors that can not be exactly reproduced using
process colors (such as CMYK). For example to be able to print colors like gold and silver, some printers can
accommodate an extra toner or cartridge filled with that dedicated ink.

PrintShop Mail allows you to enable Spot colors in order to print the document with the desired colors.

To define Spot Colors

From the Edit menu, select Spot Colors.
The Spot Color window is shown

Spot Color " Name": A descriptive name is defined here.

Separation "Name": The name of the ink/cartridge as known on the device (printer/RIP).

Note : This must be identical to the name configured on the device.

Alternate color : The Alternate color will be used at printing if the Spot Color is not available on the device
and it will be used as the displayed color on the screen preview at design time. This color may be complete
different from the actual Spot Color

1. Add a new Spot Color , click the New button.
2. Type the Separation name. The actual name of the Spot Color as it is defined on your device.
3. Select the desired Alternate color from the drop down list or create a Custom color.
4. Click Save .

Spot Colors can be deleted via the Remove button. When a predefined color is used in the document it won't
be possible to delete it from the color window list, it can only be modified.
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Note : Your specified Spot Colors will be saved with the document you defined the Spot Color for. The
Spot Color will not be saved as an application setting.

Spot Colors in EPS files

Spot Colors defined in EPS files are recognized and loaded in the Spot Color dialog as though it is defined in
the document itself. If a Spot Color defined in an EPS file has the same name as an already existing Spot
Color definition but is in fact a different Separation, a warning will be shown. As a result the used Spot Color
will be sent to the printer (unmodified) and depending on the availability of the Spot Color on the printer, the
Spot Color or the Alternate color will be printed.

Limitations

There are some limitations based on the printer and PrintShop Mail capabilities.

¥ Spot Color functionality in PrintShop Mail has as a limitation that only one Spot Color can be used per
text object.

¥ The number of Spot colors used in a document is limited to the printer capabilities. PrintShop Mail
cannot determine if a Spot Color is available on the device.

¥ Support for EPS with DCS (Desktop Color Separation) is limited to one separation in the DCS. If the EPS
exceeds this limitation, PrintShop Mail will return a warning: "ÇfilenameÈ.eps is a color separated file
and might not print correctly.

¥ When verifying a document, the verification results show all used Spot Colors in the document.

How to - Specify Spot Colors
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5.5 Link a Database to a Document

5.5.1 Open a Database

Note : For a list of supported database formats, see Support Database Formats .

Traditional databases are organized by fields, records and files. A field is a single piece of information, a
record is one complete set of fields and a file is a collection of records.

Database example

ZIP CAR CAR TYPE

91335 Mustang A

75038 Explorer B

60173 Windstar C

33351 Explorer B

Where ZIP, CAR, and CAR TYPE are fields and the rest are the records.

To open a database

Windows

1. From the Database menu, select Open or press Ctrl+D. .
2. Browse for a database file.
3. Alternatively to connect to a server based data source, in the left pane click the ODBC Data Sources

icon.
4. Select the database and click on Open .

Note : You can define new data sources or modify existing data sources in the Data Sources (ODBC)
dialog box. This dialog box is located in the Control Panel/Administrative Tools .

Limitations:

¥ PrintShop Mail only supports one active table at a time. If a database contains multiple tables, you will
be presented with another dialog box prompting you to select one of the tables.

¥ PrintShop Mail does not support relational databases.

To open delimited text files

Databases that are separated by tab, comma, semicolon, space etc can be opened in PrintShop Mail.

The window below shows the database separator as well as the encoding table:
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1. Encoding : Select the encoding that is used in the text file. PrintShop Mail detects the encoding
automatically. In most cases, you can leave this setting as its default. If you know that the text file was
created using a different encoding that the encoding that you are using on your computer, you should
change this setting to match it. For example, if your computer is set to use encoding 1251(Cyrillic ,
Windows), but you know that the file was created by using encoding 1252(Western European,
Windows), you should change it to 1252.

2. Separator : Select the character that separates values in your text file. If the character is not listed,
select the Other check box, and then type the character in the box that contains the cursor.

3. Create field names : If no field names are part of the database, PrintShop Mail can add the field names
for you. The field names have the following structure Field <<number>>, where the number is
formatted as three digits with leading zeros starting at 1.

String Encoding

Select the text encoding of the database. The encoding will use the correct ASCII table of the database
allowing special characters to be treated correctly.

A Preview of the database will be shown in the same window. If a setting changes, the preview of the
database will be updated according to the setting.

To browse the contents of your database

After you open the database, the contents are displayed in the Data Fields panel. You can view the complete
path of the database location, by placing the mouse pointer on the database name in the Data Fields panel.
You can browse the records in the database by clicking the browse buttons in the Database (Page 138)
toolbar, or by making the following selections from the Database menu:

¥ First Record (ALT+Up)
¥ Previous Record (ALT+Left)
¥ Next Record (ALT+Right)
¥ Last Record (ALT+Down)
¥ Record (Allows you to select an specific record)

To sort the database
1. Select from the menu Database : Sort > Edit .
2. Specify your sort conditions by selecting a database field from the drop down menu and specifying the

sort order.
3. Click OK .

How to - Link a Database to a Document
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To filter the database

You can set up a filter in the Database by selecting Filter > Edit from the Databas e menu, for example if you
only need to print a certain range of ZIP codes (10000 up to 19999).

You can choose from:

Contains

Equals

Does not equal

Is less than

Is less than or equal to

Is greater than

Is greater than or equal to

Is empty

Is not empty

Starts with

If you have more than one filter rule and you want ALL to be applicable, select AND to combine them.

If you want either one or the other, select OR.

How to - Link a Database to a Document
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Another way to filter the database is using Extended Scripting. See Extended Scripting (Page 83) for more
information.

Note : Data Fields: For the purpose of publishing PrintShop Mail documents to PrintShop Web, you can
design a PrintShopMail document with or without linking it to a database. The entries you will
find in the Data Fields panel in PrintShop Mail, represent data fields that occur in the document.
These fields are either referred to in expressions (for variables or layout conditions, without the
need to be directly linked to a database), or they refer to actual database fields (when the
document is already linked to a specific database). Data Field Properties are relevant for
Publishing to PrintShop Web. For more information about Data Fields, see Publishing Documents
(Page 58) .

Mac OS

To open delimited text files
1. From the Database menu, select Open .
2. Browse for the database file.
3. Select the database file and click Open .

Using a Text File as Database

The following rules apply when using a text file as database:

¥ The first line in your text file should contain the field names.
¥ Field names should only contain alphanumeric characters and underscores.
¥ The records should be listed on the following lines.
¥ The field separator is either a tab, a comma, a space, a semicolon or a user-defined character (not

alphanumeric or underscore) and these separators cannot be used in field contents.
¥ If a field contains a field separator character, it should be enclosed in double quotes in order to be

treated as one string.
¥ Two adjacent field separators imply that an empty field is placed between them.
¥ The record separator is a newline character.
¥ Any missing fields at the end of a line are left empty.

Opening a Text File as Database
1. From the Database menu select Open .
2. Browse to the folder where the database file is located.
3. Select the text database file and click Open .
4. Select the Separation mark you wish to use in the dialog box.

How to - Link a Database to a Document
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To Sort the database

You can define a large number of sort keys, which are applied to the opened database. Defining the sort keys
and their precedence is done independently of switching on or off, as explained below.

1. Open the Database floater and click the Edit button next to Sort checkbox.

2. Select a database field in the list to the left and press Add button to copy it to the Sort Order list to the
right. Double clicking the field name has the same effect. Repeat the steps with all the fields that you
want to use as further sort keys.

3. It is possible to specify the Sort Order per selected field, which is either Ascending or Descending by
selecting a sort key in the list to the right and dragging it up or down, or remove a sort key by selecting
it and clicking Clear , or double click the sort key.

4. Press Sort to sort the database and Ready to close the dialog.

How to - Link a Database to a Document
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To Filter the database

PrintShop Mail allows you to filter the database to which you wish to link a document. This implies that only a
selection of the database is going to be used.

1. Open the Database window and click Edit button next to the Filter checkbox.

2. Enter an expression of which the result can only be true or false.
3. Select Filter from the Database menu or click the Filter checkbox in the database window to apply

your filter settings. Selecting or deselecting the filter option, toggles between using the entire database
or using only the filtered records. The filter option is enabled only when the database is currently open.

Realted Topics
¥ Add Variable Text (Page 31)
¥ Add Images (Page 38)

How to - Link a Database to a Document
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5.5.2 Connect to SQL Server

Before you can connect to an SQL Server, you need to setup an SQL Server ODBC Data Source, as follows.

1. In the Windows Control Panel , select ODBC Data Source Administrator . (In Windows 2000, XP and
2003 this panel is located under Administrative Tools ).
The ODBC Data Source Administrator window appears.

2. On the User DSN tab, click Add .
The Create New Data Source window appears.

You are prompted to specify which driver to use for the data source.

How to - Link a Database to a Document
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3. Double click SQL Server .

4. Type the data source name and description.
5. Specify the SQL server name or IP address.
6. Click Next .

7. Select With SQL Server authentication using a login ID and password entered by the user .
8. Specify the logon ID and the password.
9. Click Client Configuration .

10. On the Add Network Library Configuration window, under Network Libraries , select TCP/IP .
Note : Do not change the server name or port number unless otherwise specified by your system

administrator.

How to - Link a Database to a Document
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11. Click OK .

12. Select Change the default database to : and choose SQL Test (or the name you gave the data
source).

13. Click Next .

14. Click Finish .

15. On the Microsoft SQL Server Setup window, review the options and click Test Data Source ... to test
the connection.

16. To begin to use the data source in PrintShop Mail, click OK .

How to - Link a Database to a Document
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5.6 Add Text

5.6.1 Add Variable Text

Text objects in PrintShop Mail can contain both static and variable text, separated by delimiters. By default,
the @ character delimits variables. Each variable is associated with an expression. An expression is a
calculation that is usually based on the contents of your database.

To add variable text

Note : As an alternative to the steps outlined below, you can also drag and drop directly fields from
your database onto your layout. This automatically creates a text box and a variable name.

1. In the Tools (Page 143) toolbar click the Place Variable Text button, or from the Insert
menu select Variable Text .
(Windows ): From the Window menu, select Data Fields (Ctrl+3), or select Data Fields
panel in the Properties Window .
(Mac OS ): From the Window menu, select Show Variables .

2. Begin typing. Whenever you want to include variable information, type a meaningful name
between two delimiting characters. By default, the @ character delimits variables. It is possible
to change the delimiting characters in the Preferences (Page 148)

3. When you are finish click outside the text box.

Variables you have defined, automatically appear in the Variables panel (Windows) , or in the Variables
floater (Mac OS) .

To assign database fields to the variables

The next step is to connect the variables to fields in the database. To do this,

1. (Windows ): Double click on a variable in the Variables Panel to display the Expression Editor , or
right click on the text object and select the variable in the Edit Expression submenu.
(Mac OS ): Double click on a variable in the Variables floater.
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Use the Expression Editor to assign an expression to the variable.

2. Double click on the database field to which to associate the variable.
3. Click OK to close the window.

Note : You can check the result of the expression in the Variables panel, or in the Variables floater
(Mac OS).

To preview the variables

In Preview mode, you can view the result in the text box itself.

To toggle between Preview and Design modes, click this button in the View (Page 145) toolbar.
Alternatively from the View menu, select Preview or press F2 (Windows) .
From the View menu, select Preview or press Command + Y (Mac OS) .

How to - Add Text
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You can change the text style (for example, font name, size, color and style properties) of any part of the text
object from the Text Formatting (Page 141) toolbar, or from the Text menu.

Mac OS

Note : The "Remove Empty Lines" feature can be switched on using a checkbox in the Expression
Editor Window.

Related Topics

¥Expressions Overview (Page 166)

¥Paragraph Style (Page 115)

¥Text Properties (Page 105)

¥Text Style (Page 112)

5.6.2 Formatting Variables

Formatting variables allows you to set how numbers, currencies and dates are displayed and printed. You can
set this for each variable text object in the document, according to regional preferences.

To format variables

Choose the Variables panel and select a variable to specify its format settings. You can select the following
format categories:

¥ Number
¥ Currency
¥ Date
¥ Text
¥ E-mail

Number

The Number category has all number formatting options available on the system.

How to - Add Text
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Set this
option...

To de this...

Decimal Symbol Specifies the symbol that indicates decimal values.

Decimals Places Specifies how many digits appear to the right of the decimal symbol.

Digit Grouping
Symbol

Specifies the symbol that groups the digits in large values (for example:
1,000,000).

Digit Grouping Specifies how digits are grouped.

Negative Symbol Specifies the symbol that indicates a number is negative.

Negative Format Specifies how negative values are formatted.

Leading Zeroes Specifies whether a zero appears before the decimal symbol in decimal values (for
example, 0.7 or .7)

Currency

The Currency category allows you to format a numeric value to be represented in currency format.

How to - Add Text
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Set this option... To do this...

Locale This affects how number, currencies and dates are formatted.

Currency Symbol Specifies the symbol that identifies the currency of a particular region.

Positive Format Specifies how positive currency values are formatted.

Negative Format Specifies how negative currency values are formatted.

Decimal Symbol Specifies the symbol that indicates decimal values.

Decimal Places Specifies how many digits appear to the right of the decimal symbol.

Digit Grouping Symbol Specifies the symbol that groups the digits in large values.

Digit Grouping Specifies how digits are grouped.

Date

The Date category lets you format a date when it is in the expected input format. The expected input format
is "YYYYMMDD"

Set this option... To do this...

Locale This affects how number, currencies and dates are formatted.

Date Format Specifies how dates will be formatted.

Sample dd/MM/yyyy

How to - Add Text
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Text

The Text category is the default option a variable is set to. Setting the format to this category will have
PrintShop Mail treat variable numeric content as a text string.

E-mail

Setting the format to this category will have PrintShop Mail to check if there is something missing in the
format like "@" and "."

5.6.3 Creating Serial Numbers

Serial numbers are linked to the COUNTER (Page 199) function.

To create a serial number
1. In the Tools (Page 143) toolbar click the Place Variable Text button, or from the Insert menu select

Variable Text .
2. Insert a variable in the text box, for example @COUNTER@.

(Windows ): In the Variables panel, double click the variable you just created, or right click on the
variable text box and select Edit Expression to open the Expression Editor .
(Mac OS ): From the Window menu, select Show Variables .
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3. Double click on the COUNTER function in the function list. The expression will be pasted into the
Expression Edit field.

4. Fill in the values you want the counter to generate.
5. Click OK.

For example :

COUNTER(1, 100) creates a counter that starts with 1 and ends with 100.

Note : To create an indefinite COUNTER, simply double click the COUNTER function, after the expression is
pasted into the Expression Edit field, click OK ; the operator COUNTER() creates a counter that starts with 1
and ends with whatever is set as the maximum number of " Items without Database " as set in the Programs
Settings (Page 148) .

To view the results, browse the records using the buttons of the Database (Page 138) toolbar. The
counter displays 1, 2, 3, and so on as you scroll through the records.

Note : You do not need to open a database to use this function.

Note : When no database is open, you can change the total number of records, in the Database (Page
138) toolbar. To do this, enter the desired number of records and press Enter.

To view an example that uses customized serial numbers, see Custom Serial Numbers (Page 174) .
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5.7 Add Images

5.7.1 Add Static and Variable Images

In PrintShop Mail, image objects can contain either static or variable images. Using variable images with
PrintShop Mail allows you to personalize your documents with pictures.

Note : For a list of supported image formats, see Support Image Formats (Page 146) .

About static images

Static images are not linked to a variable, which means that they are always associated with the same image
file. Print technologies use this fact to optimize print process time by only spooling static images once per job.

To insert a static image

1. In the Tools (Page 143) toolbar, click the Insert Image File button, or from the Insert
menu, select Image File .

2. In the dialog box, browse to the image to insert.
3. Click Open .

About bounding boxes

The bounding box of a static image reflects the image size. When you resize the object, it retains its original
aspect ratio. The initial size of an image depends on its resolution. PrintShop Mail assumes an image
resolution of 96 DPI (Dots Per Inch), except for EPS (72 DPI) and TIFF files. The resolution of a TIFF image is
stored in the file itself.

About variable images

Variable images are linked to variables in the same way as variable text. The result of the expression
associated with a variable image should be an image file name. Print technologies optimize print process time
by only spooling recurring variable images once per job.

To insert a variable image

1. In the Tools (Page 143) toolbar, click the Insert Image Box button, or from the Insert
menu, select Image Box .

2. Double click the name of your variable image in the Variables panel to display the
Expression Editor . Alternatively right click on the variable image and choose Edit
Expression .

3. In the Expression Editor , define an expression or select a database file that contains the
image filename.
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PrintShop Mail can use field information from the database to create variable images. This information is used
in two ways:

¥ "As is" handling, uses field data to tell the Image Box what the image file name is.
¥ "Trigger" handling, uses field data combined with a logic expression to create the image file name result.

Both are used regularly for generating variable data.

To insert variable images "As is"

Database Setup

ZIP CAR CAR PIC

91335 Mustang Mustang.jpg

75038 Explorer Explorer.jpg

60173 Windstar Windstar.jpg

33351 Explorer Explorer.jpg

Expression

The "CAR PIC" field is used to tell the image box what the file name is:

To insert variable images "Trigger"

Data Triggers can be alpha, numeric or symbol characters. The simplest way to setup a Trigger field is to use
short 1 to 3 digit character strings.

How to - Add Images

Objectif Lune Inc. © 2010 39



Database Setup

ZIP CAR CAR TYPE

91335 Mustang A

75038 Explorer B

60173 Windstar C

33351 Explorer B

Expression

IF([CAR TYPE] = "A", "Mustang.jpg",

IF([CAR TYPE] = "B", "Explorer.jpg",

IF([CAR TYPE] = "C", "Windstar.jpg","")))

The "CAR TYPE" field is used with a conditional logic formula to generate the image file name.

To check and preview the results

You can check the result in the Variables panel. The image is displayed in Preview mode.

To toggle between Preview and Design modes, click this button in the View (Page 145) toolbar.
Alternatively from the View menu, select Preview or press F2 (Windows) .
From the View menu, select Preview or press Command + Y (Mac OS) .

Note : To view the image objects properties, see Image Properties (Page 100) .

To insert a PDF image

You can insert a PDF file as a static PDF object or as a variable image object. As a variable image object allows
for using variable pages within a (single) PDF document.

To insert a PDF image as a static PDF object, you can:

1. Drag and drop a PDF file to your layout, or
2. From the File menu, select New PDF based document , or
3. In the Tools toolbar, click the Insert PDF button, or from the Insert menu, select PDF.. .

To insert a PDF file as a variable image object, you can:

1. In the Tools toolbar, click the Insert Image File button, or from the Insert menu, select Image File.
2. In the Tools toolbar, click the Insert Image Box button, or from the Insert menu, select Image Box.

Note : An image object can be linked to a single PDF file. As PDF files can contain multiple pages you
can specify the page(s) to be used in your document through an expression, in this way you can
use variable pages within that PDF file.
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Mac OS

1. In the Tools toolbar, click the Place Variable Image button and drag a rectangle to the desired size on
your layout, or from the Insert menu, select Variable Image .

2. Double click the name of your variable image in the Variables window, to display the Expression
Editor .

3. In the Expression Editor , define an expression or select a database field that contains the image
filename.

Note : PrintShop Mail for Macintosh converts the color space that is embedded in the image to the
color space of the printer driver. You can check the color space of the printer driver, selecting
from the File menu, Print/ColorSync.

Related Topics

¥Expressions Overview (Page 166)

¥Image Properties (Page 100)

¥Supported Image Formats (Page 146)
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5.8 Use Layout Conditioning

Use layout conditioning to conditionally skip certain pages of your document or to leave them blank during the
printing process. The PRINT and BLANK commands will not influence the amount of pages printed.

There are three options for applying a condition to a layout:

¥ PRINT : The layout will be printed (default).
¥ BLANK : A BLANK page will be printed instead of the layout.
¥ SKIP : The layout will be skipped.

To specify layout conditioning

Select the layout for which you want to set the condition:

¥ (Windows ): It is possible to specify layout condition in three ways:

1. From the Layout menu, select Edit Condition .
2. Right click on the layout and select Edit Layout Condition .
3. In the Layouts panel, select the layout and click on Action to Edit Condition .

¥ (Mac OS ):

1. From the Windows menu, select Show Layout Condition s.
2. From the Windows menu, select Show Variables and click on Layout Conditions .

For example :

Your document consists of two layouts:

¥ Male audience target
¥ Female audience target

You want to create a one page newsletter. PrintShop Mail can use information from your database to
determine whether to print a page, skip it, or leave it blank.
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The expression used is:

IF( [GENDER] = "M", Print, Skip)

In other words,

If the GENDER field equals "M", print the page, otherwise skip the page.

Conversely, the expression for the layout that targets the female audience is:

IF( [GENDER] = "F", Print, Skip)

Note : FreeForm does not fully support layout conditioning. In particular, it does not allow you to
conditionally Skip layouts. When SKIP is used, a BLANK page will be printed instead.
FreeForm 2 does not support SKIP in combination with layout repetition, the skipped layout will
be left BLANK.

When using layout condition in combination with layout repetition and SKIP is activated, the next layout will
move to the position where the previous would have been positioned.

To print Through-the-stack, set top priority (1) to Front to back , priority (2) to Top to bottom and priority
(3) to Left to right . This way the first record is printed on the top left corner of the first page, the second
record is printed on the top left corner of the second page, etc. This eliminates the need for collating after the
job is printed.

How to - Use Layout Conditioning
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Note : When you use layout condition SKIP for your PrintShop Mail documents with multiple layouts,
or when you have applied variable Number of Copies, this may cause that the size of the record
sets (the number of actual printed layouts per record) will be different per record set. This in
turn may cause that some record sets will be split across different stacks.

When Layout Conditions should be applied?

¥ Output of multiple versioned documents within one PrintShop Mail file.
¥ Layout Condition is an alternative for setting up text heavy variables (multiple variable paragraphs).

Creating an expression formula within the Variable text box using 1000s characters can be tedious. A
simpler way is to create multiple static pages in native Desktop Publishing or Word processing programs,
convert the documents into a usable PrintShop Mail file format (EPS or PDF) and from PrintShop Mail
setup the conditions for the output.

¥ Inserting blank pages

Note : For more information on expressions, see Expression Overview (Page 166) .

Related Topics

¥Layout Functions (Page 193)

¥Use Layout Repetition (Page 45)
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5.9 Use Layout Repetition

PrintShop Mail can print multiple layouts on media that has a larger format than the layout. For example, a
postcard that is 5.5" x 4.25" can be printed 2 by 2 on letter-size paper (11" x 8.5").

To achieve this result, you can create a layout that is the size of 1 personalized document in this case, a
postcard that is 5.5" x 4.25".

For a document with multiple layouts, you can print different layouts on the same page.

Note : PrintShop Mail supports mixed layout sizes, except when layout repetition is used. When using
layout repetition, the first layout size will be the layout size for the complete document.

To specify layout repetition
1. (Windows ): From the Edit menu (CTRL+K), select Preferences .

(Mac OS ): From the PrintShop Mail menu, select Preferences .
2. In the left pane, click on the icon Repetition .
3. Specify the number of repetitions for the layout, as well as the horizontal and vertical spacing between

each layout.
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Note : The maximum number of repetitions is displayed between brackets. This is dependent on the
size of the layout and the selected media in the Page Setup .

About priorities

Priorities affect the order in which your database is going to be printed. Specify the priorities (1,2,3) and
direction (Front to Back, Back to Front, Left to Right, Right to Left, Top to Bottom, Bottom to Top) to define
the database order.

You can change priorities for each of the three dimensions:

¥ Front to Back, Back to Fron t: To print Through-the-stack, set top priority (1) to Front to back ,
priority (2) to Top to bottom and priority (3) to Left to right . This way the first record is printed on
the top left corner of the first page, the second record is printed on the top left corner of the second
page, etc. This eliminates the need for collating after the job is printed.

¥ Left to Right, Right to Left : Influences the horizontal repetition.
¥ Top to Bottom, Bottom to Top : Influences the vertical repetition.

Note : When you use layout condition SKIP for your PrintShop Mail documents with multiple layouts,
or when you have applied variable Number of Copies, this may cause that the size of the record
sets (the number of actual printed layouts per record) will be different per record set. This in
turn may cause that some record sets will be split across different stacks.

When using layout repetition in combination with layout condition and SKIP is activated, the next layout will
move to the position where the previous would have been positioned.

Related Topics

¥Repetition (Page 156)

¥Specify the Layout Size (Page 18)

How to - Use Layout Repetition

Objectif Lune Inc. © 2010 46



5.10 Select Paper Trays

If your printer supports different paper trays and your document consists of multiple layouts, you can send
different layouts to different trays.

To associate a layout with a paper tray

Windows

1. From the File menu select Page Setup , or right click on the layout and choose Page Setup .
Alternatively in the Properties panel , select Page Size .

2. From the Tray box, select the desired paper tray.
3. In the Apply to box select:

Current layout : layout or layouts selected in the Properties Panel.
This point forward : current layout and all layouts below it.
Whole document : all layouts in the document.

4. Click OK .

If your printer supports more trays but they are not available in the Page Setup window, use the following
steps to select a tray in the Advanced properties of the printer driver:

1. From the File menu select Page Setup , or right click on the layout and choose Page Setup.
2. Click on the Advanced tab.
3. In the Printer Document Properties select Advanced .
4. In the Printer Advanced Options select Printer Features .

Note : The options outline above, must be repeated for each layout, if each layout need a different
tray.

Another way to associate a layout with a paper tray is by selecting the layout in the Layouts panel, then
select the Paper Tray property and choose the desired tray from the drop down menu.
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Mac OS

From the Layout menu, select Paper Tray . Depending on the selected PPD, a list with the available trays will
be displayed.

Related Topics

¥Page Setup (Page 77)

¥Printing Basics (Page 69)

¥Properties Panel (Page 96)

How to - Select Paper Trays
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5.11 Number of copies

PrintShop Mail allows you to print a number of copies per page. The Expression Editor can be used to
generated multiple copies of each page in your document.

To setup the number of copies
1. Select the Layouts panel.
2. Select the desired layout and click on Number of Copies , to open the Expression Editor .

Data fields can be used to specify the number of copies per page. Field data not containing number
strings can be used with logic functions such as the IF statement.

Number Text String

Once the Expression Editor is open:

1. Double click on the VAL function from the function list. The expression will be pasted into the
Expression Edit field.
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2. Select the string value of the database field containing the number of copies.

Non-numerical Text String

In this case, the data field does not contain a number string, but it does have a field to be used as "Trigger".

How to - Number of copies
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In the expression "IF([TRIGGER]="A",VAL("12"),IF([TRIGGER]="B",VAL("8"),VAL("1"))) ", the field name
"TRIGGER" has either an "A" or a "B" in it. The number of copies for "A" would be 12, and the number of
copies for "B" would be 8. At the end of the expression, you need to add VAL("1"), because the function must
result in a numeric value.

Note : When you use layout condition SKIP for your PrintShop Mail documents with multiple layouts,
or when you have applied variable Number of Copies, this may cause that the size of the record
sets (the number of actual printed layouts per record) will be different per record set. This in
turn may cause that some record sets will be split across different stacks.

You can also print multiple copies of your document by entering the desired number of copies in the Print
Dialog. To do this:

1. On the File menu, click Print .
2. In the Number of copies box, enter the number of copies you want to print.

To print a complete copy of the document before the first page of the next copy is printed, select the Collate
check box. If you prefer to print all copies of the first page and then print all copies of subsequent pages, clear
the check box.

Limitations

¥ The output result will be one copy if a single zero ("0") is used in any part of the Expression.
¥ For multi-page documents, you need to set the number of copies per each individual page.

How to - Number of copies
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¥ Number of copies can not be used in combination with Layout Repetition (Page 45) .
¥ Number of copies can not be used when FreeForm (Page 73) Print Technology is selected, use FreeForm

2 (Page 73) instead.

How to - Number of copies
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5.12 Verify a Document

Before printing, you can verify your document for possible problems.

Verify document checks the document at two levels:

¥ Layout level : Warnings at layout level will show the warning with the layout number in the Warnings
panel.

¥ Record level : Warnings at record level will show the warning with the layout number and record
number in the Warnings panel.

PrintShop Mail performs the following checks at Layout level:

¥ Are any images or PDF files missing?
¥ Are all items placed within the printable area?
¥ Does a text object contain more text than the text box can hold? For example, the following warning is

displayed: "Text does not fit in its bounding box". You can prevent this warning from appearing again by
resizing the text box or by linking the text box to another text box. For more information about linking
text boxes, see Linking text (Page 134) objects.

To perform document verification

Warnings

While you are working, PrintShop Mail will dynamically check for any possible errors on the layout and will
display any occurring error in the Warnings panel, like:

Verify Document

When you select Verify Document from the Layout menu, a progress bar will be displayed, showing the
amount of records being checked. The warnings for the whole document will be listed in the Verification
Results panel.
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Note : Verify document will be stopped when 1000 warnings are found or when you press the Cancel
button on the progress bar.

Here is a list of a few possible messages:

Object is placed beyond the printable area

Object is not entirely placed on the layout

Text file not found

Variable X is not linked to an expression

Text does not fit in its bounding box

Image X not found

Error loading image

Page number X is invalid; this PDF only contains Y pages

Variable X: argument Y is invalid

Variable X: barcode input string Y is invalid

Variable X: date format Y is invalid

X contains at least one TrueType font that is not embedded in the PDF

Variable X: database field Y not found

It is possible to save messages displayed in the Warning panel and the Verification Result panel by right
clicking on the message an Copy/ Paste the text to a text file, save it and e-mail it to support to get help on
errors.

How to - Verify a Document
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Related Topics

¥Properties Window (Page 0)

How to - Verify a Document
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5.13 Save a Document

When saving a document, it is recommended to use one folder for the document file and its supporting files
that is, the image files and the database. The reason for this is because the supporting files for a PrintShop
Mail document are not included in the document file. This file only contains references, stored as paths
relative to the document folder.

For example :

If you save your document in...

"C:\My Documents"

and it contains an image...

"C:\My Documents\Images\Car.tif",

the reference to this image is stored as...

"Images\Car.tif"

If you move the Documents folder and its subfolders to another drive, PrintShop Mail will still be able to
locate the image.

Windows Note : PrintShop Mail 6.1 documents can be opened in all PrintShop Mail 6.X versions
(downward/ upward compatibility). You can import PrintShop Mail 98, 4.x, 5.x and 6.x
documents into new versions of PrintShop Mail, but PrintShop Mail 98, 4.x and 5.x will not be
able to interpret documents saved by the new version of PrintShop Mail . If you try to overwrite
an existing PrintShop Mail 98/ 4.x/ 5.x/ 6.x document in the new PrintShop Mail format, PrintShop
Mail will issue a warning.

Mac OS Note : You can open PrintShop Mail documents created in PrintShop Mail 4.3.X or older, but
PrintShop Mail 4.3.x will not be able to interpret documents saved by the new version of
PrintShop Mail. If you open an existing PrintShop Mail 4.3.x document in the new PrintShop Mail
format, PrintShop Mail will issue a warning, asking you whether you really want to save this
document as soon as you close the document, even if you have not changed anything.
When opening PrintShop Mail documents from versions 4.3.6 or 4.2.9 (Japanese language) in
PrintShop Mail 5, the following settings might be lost:

-Format settings in DATE and TODAY expressions will not be converted automatically; this
settings can be rest manually.
-Variable images will be opened with an empty expression.
-Leading between lines setting can not be converted, this setting can be reset manually.
Variables embedded in an EPS (@variable@) is not supported.
-Transparency will be converted to white, this setting can be reset manually.
-The COUNTER function will be converted using an end value of 2.000.000.

If you wish to use documents made in earlier versions of PrintShop Mail than versions 4.3.6/
4.2.9 (Japanese language) before you open them in PrintShop Mail 5.x.

To save your documents

You can save a PrintShop Mail document in three ways:

1. As a PrintShop Mail document, with the extension ".PSMD".
From the File menu, select Save as .
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2. As a PrintShop Mail template, with the extension ".PSMT".
From the File menu, select Save as Template . For further guidance in saving PrintShop Mail
templates, see Create a New Document (Page 14) .

3. Save for Output archived in a "ZIP" file which contains all files used in the PrintShop Mail document.
From the File menu, select Save for Output .
When selecting Save for Output , PrintShop Mail collects and copies all the files needed into a
compressed folder. The collected data includes the PrintShop Mail document, static and variable images,
database, fonts and a summary file which shows a list of all the copied image file names.

To revert to the last saved version of the document, select Revert from the File menu.

How to - Save a Document
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5.14 Publish to PrintShop Web

5.14.1 Publishing Documents

PrintShop Web is an easy to use, powerful and open Web to print application that allows for printing over the
Web.

PrintShop Mail allows to prepare and add documents to PrintShop Web. PrintShop Mail documents are used as
the basis for print jobs, meaning that it is possible to reuse the documents by uploading new databases. The
designer can publish (upload) an existing or new document and customers will be able to use PrintShop Web
to order print jobs based on this document. Print jobs can be previewed and validated before they are
submitted to the printer.

How to create PrintShop Mail documents for publishing

You, " the designer " create documents and templates in PrintShop Mail.

When the document is ready for publishing, you can start the upload process by clicking on Publish to
PrintShop Web selecting the File menu or clicking the Publish to PrintShop Web button in the Standard
(Page 140) toolbar.

You can design a document with or without linking it to a database. The variable data in the document
preview in PrintShop Web will be based upon Data Fields that you assign in PrintShop Mail.

Note : Keep in mind that when you design a template, the template does not save the link to the
database.

Data Fields are representatives for the variable data that can be provided either directly through a database
that you link to a PrintShop Mail document, or through any other data source, for example a database which is
uploaded by a PrintShop Web client or a web form.

The entries you will find in the Data Fields panel in PrintShop Mail, represent data fields that occur in the
document. These fields are either referred to in expressions (for variables or layout conditions, without the
need to directly being linked to a database), or they refer to actual database fields (when the document is
already linked to a specific database).

When a data field is used in the PrintShop Mail document, it will have a check mark in the Data Fields panel.
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Example

The Type column displays the type of data in the data field. "Default" means that at the moment no data
source is available for this field. Once there is a data source available, the Type column will display the data
type for that field, as specified in the data source, like number, text, etc.

Example

By selecting a Data Field , you can view and edit its properties:

Name : A unique identifier. You can not modify this value here.

Default Value : You can set a Default Value here, this will be a string value that will be displayed in PrintShop
Web, once the document is published, as a placeholder when no data source is available (yet) for this Data
Field. You will find this string value back in PrintShop Web, after the document has been selected (before the
stage where a data source is provided).

How to - Publish to PrintShop Web
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Note : When no database is (yet) available, this Default Value will be displayed as the current value in
the Data Fields panel and in the text object in the layout, in case the data field is in use in the
document:

How to create a Data Field without opening a database?

1. Create a variable: @variable@ .
2. Enter the Expression Editor by double clicking on the @variable@ in the Variables panel.
3. Type: [My data field].
4. Click OK .

Now you will find the data field back in the Data Fields panel.

Remarks : You can define a Remark here, this will be a string value that will be displayed in PrintShop Web
once the document is published. You can use this, for example, to give clients a hint about this variable data
field.

Source : The data source can be either "Database", a database uploaded by the PrintShop Web client, or
"User input", data provided by for example a web form.

Note :These Data Fields properties are only relevant for PrintShop Web, they will not affect the
behavior of PrintShop Mail.

How to publish documents from PrintShop Mail

Publishing PrintShop Mail documents to PrintShop Web can be done from PrintShop Mail directly.

When publishing documents the first time, you will need to specify the URL and the login account for your
company Web Server.

1. Launch PrintShop Mail.
2. From the Edit menu, select Preferences and click the PrintShop Web icon. To tell PrintShop Mail how

to log on to your company Web Server, specify:
URL : The Web address of your company.
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Login : The user name and password assigned by the administrator.

Once you have specify all the necessary information to login to your company Web server, you can start
publishing documents to PrintShop Web. The connection can be tested clicking the Test Connection button.
It verifies only if all three options (URL, Username, Password) are valid. If no PrintShop Web Server address
has been defined in the PrintShop Mail Preferences , the document and its attributes (images and fonts) will
be saved in a zip archive (Publish to zip) for later publishing.

1. From the File menu, select Publish to PrintShop Web or click the Publish to PrintShop Web button
in the Standard toolbar.
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Before publishing PrintShop Mail documents, a document designer can add a note containing Operator
Instructions about for example, duplex settings, paper weight etc.

2. A dialog Publish to PrintShop Web opens.
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3. Select the Publication Type where you want to place the document.

In PrintShop Web documents are organized within Publications Types. Publication Types are a way to
mark a document as being in a particular category (such as envelop, business cards, invitation etc).
Each Company can have a range of Publication Types. Within the Company each Publication Type is
unique. Each Publication Type can contain one or multiple documents.

When a customer of a company logs on to the PrintShop Web web site all Publication Types available for
that Company will be shown.

4. Click Next .
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5. On the next dialog click the Show Browser button to display the folder containing the image files.

Note : Adding files is only necessary when variable images and txt/ rtf files are used. If the document
does not contain variable images or txt/rft files, the wizard will take you to step 7.
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6. Select the additional files for the document and click the Add button.

Note : In this dialog, you can choose to add variable image and .txt/ .rtf files that belong to the
document. The PrintShop Mail document, its used fonts and static images are added automatically.
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7. Click Next .

8. Click Finish to publish the document.
9. Once the message Successfully uploaded the new document appears, click OK .

Note : It is possible to upload documents made in older versions of PrintShop Mail WE to PrintShop
Web through PrintShop Mail 5.2 and higher.

PrintShop Mail shows a list of warnings prior uploading the PrintShop Mail document to PrintShop Web.

The following features are checked:

Fonts

Only freely distributable fonts will be added automatically. A warning message will be displayed about fonts
that need license before publishing. You need to verify if the necessary licenses are available to add the fonts
that need licenses. It is possible to choose to upload the licensed fonts directly to avoid a manual upload of
the fonts at the PrintShop Web server.

PrintShop Mail version

PrintShop Mail verifies if the version used at the PrintShop Web server is the same or if the document needs to
be converted.
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List of used plugins

When publishing a PrintShop Mail document which contains plugin objects, the availability and the version of
the plugin will be checked with the PrintShop Web server before publishing.

List of used MacroÕs

When publishing a PrintShop Mail document which contains external macros, the availability of the macro will
be checked with the PrintShop Web server before publishing. The check is based on the filename only.

When pressing OK , the uploading process will continue.

When pressing Cancel , the uploading process will stop and you will be back in the default PrintShop Mail
environment.

If you have enough access privileges you can create a "New Company " and "Publication Type " from the
Publish to PrintShop Web dialog in PrintShop Mail.

How to create a New Company

To create a New Company, do the following:

1. In the Publish to PrintShop Web dialog click the New Company button. The New Company dialog
appears.

2. Enter the name for the company and click OK .

How to create a New Publication Type

To create a New Publication Type, do the following:

1. In the Publish to PrintShop Web dialog, select the company.
2. Click the New Publication Type button. The New publication type dialog appears.
3. Enter the name for the Publication Type and click OK .
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More information about managing uploaded documents, Companies and Publication Types can be found in
PrintShop Web Help .

Related Topics

¥Create a New Document (Page 14)

¥Default Settings (Page 16)

¥Save a Document (Page 56)
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5.15 Print a Document

5.15.1 Printing Basics

Before you do the actual printing, PrintShop Mail offers different ways to optimize your output, allowing you to
select how many pages or records you want to print. Additionally, you may wish to print the currently selected
record, or proof your document in PDF format before printing. To do this, click on the File menu and select
Print to open the Print Dialog .

Print Preview

While you are working on your document, it is possible to view an on screen representation of the printed
output. In this Print Preview it is possible to browse through pages and view multiple layouts and records at
the same time.

You can enter the Print Preview mode in two ways:

1. From the File menu, select Print Preview .
2. Click the Print Preview toolbar button in the Standard (Page 140) toolbar.

In Print Preview mode, four menu items are shown:

¥ Page combo box : Allows you to select the view of a single page or multiple pages at the same time. By
default you will see two pages horizontally and one vertically.

¥ Print button : When you click this button, PrintShop Mail returns to the design view and the Print
Dialog will be opened.

¥ Close button : When you click this button, PrintShop Mail returns to the design view. Alternatively, you
can close the Print Preview by pressing Esc, or by pressing Alt+F4.

¥ Color softproof: Allows you to display an on-screen preview of how your documents colors will look
when reproduced on a particular output device. This feature is enabled when Color Management is
activated.

Print Dialog Options
1. Operating System Default Print Options

Printer : The printer you wish to print to.
Printer Properties : Controls printer options, for example layouts options and paper quality.
Print to File : Instruct the printer driver to print to a file on the disk, instead of the printer.
Number of copies : Indicates the number of copies you wish to print of each page. If the value is set to
one, only the original page will be printed.
Collate : Determines how the layouts are ordered within a record, the layouts within the record set will
keep the order intact. By default this option is On .

2. PrintShop Mail Print Options

Print: From the drop down menu you can select the following options:

All Records : By default "All Records" is selected. This option allows you to print the complete job.
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Behind this selection the amount of available records is displayed.
Record Range : This option allows you to print a certain range of records.
Note : If the range of records you wish to print exceeds the number of records available, a message will
be displayed until the amount of records is equal or less than the total amount of records available.
Page Range : This option allow you to print a certain range of pages.
Note : When using layout repetition and you select this option the complete number of pages needs to
be calculated to output the correct pages.
Current Record : This option allows you to print the selected record, using Standard PostScript print
technology. No Credits will be charged from your hardware key.
Softproof PDF : This option generates a PDF file of the current record, using Standard PostScript print
technology. No Credits will be charged from your hardware key.
Note: When a non PostScript printer is selected, it will use the PostScript printer driver installed by th
PrintShop Mail installer to generate output.
Report Page : This option allows you to print a Report Page, using Standard PostScript print
technology. No Credits will be charged from your hardware key.
Variable Markers : This option allows you to print the current layout(s) with the variable markers on it,
using Standard PostScript print technology. No Credits will be charged from your hardware key.
Split job : This option allows you to split the job per record or per page in several outputs. Print speed
will be improved when using limited job sizes.
Note : When using "Adobe PDF" Print Technology, it is advised to activate "Split job" option for the best
performance.

Save Print Options : This option allows you to store specific print options with the PrintShop Mail
document.

3. PrintShop Mail specific Print Technology Options

Print Technology

Because every print technology uses PostScript Level 2, PrintShop Mail requires the use of a PostScript printer
driver (Page 12) and a PostScript Level 2 compatible RIP.

Some technologies are based on the PostScript standard, which means that they are supported by every type
of RIP available. Other technologies are based on extensions of PostScript, which are only supported by
specific RIP types.

Printing Technologies:

Standard PostScript (Page 71)

Optimized PostScript (Page 72)

Adobe PDF (Page 72)

RIP type and vendor dependent technologies:

AHT (Page 72)

Creo VPS (Page 72)

Fiery FreeForm (Page 73)

Fiery FreeForm 2 (Page 73)

PPML (Page 74)

PPML/VDX 7 (Page 76) (Windows only )

PrintStreamer (Page 76) (Mac OS only )
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VIPP (Page 77)

If you want to print to a non PostScript printer, you just have to select the printer driver for that printer.
PrintShop Mail will print through that printer driver non optimized output. Printing and spooling time will be
significantly slower compared to other print technologies like Optimized PostScript.

To select a print technology
1. (Windows ): From the Edit menu (Ctrl+K), select Preferences .

(Mac OS ): From the PrintShop Mail menu (Command,), select Preferences .
2. In the left pane, click the Print job icon.

The Print job settings (Page 154) dialog box appears.
3. Check if your RIP supports one of the RIP type and vendor dependent technologies. If so, you can select

that specific technology. If not, it is advisable to select Optimized PostScript.

To specify technology specific options
1. From the File menu, select Print .
2. On the Print dialog box, specify technology specific options .

Print dialog box settings

Use OPI, don't spool images : Most print technologies support OPI (Open Prepress I nterface), allowing you
to use an image substitution server to speed up the printing process. OPI only supports EPS and TIFF image
formats.

Store forms on printer's hard disk : Storing PostScript forms (cached reusable content) on hard disk will
prevent out of memory conditions if your document contains large high resolution images. Only use this option
if your RIP has access to a hard disk.

Custom cache size : Increasing the PostScript form cache size can help to improve performance. You may
want to experiment in order to determine the optimum value. Specifying a custom cache size only works if the
system settings of your RIP are not password protected.

Note : If you use the options "Store forms on printer's hard disk" or "Custom cache size", and the RIP
is password protected you might get a printer error. Consult the RIP manual or consult the
system administrator to change the settings on the RIP.

Related Topics

¥Installing a Printer Driver (Page 12)

¥Page Setup (Page 77)

¥Subset Finishing (Page 78)

5.15.2 Print Technologies

Standard PostScript

Standard PostScript does not use any special optimization mechanism, except that you can use OPI to speed
up spooling.

Use this technology if your system does not support any of the other technologies.
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Print dialog box settings (Page 69)

1. Use OPI, don't spool images.

Optimized PostScript

Optimized PostScript caches image data in reusable PostScript forms. This speeds up the printing process,
since each unique image is only sent once.

Note : Some printer drivers offer the possibility to change the PostScript Output Options : "Optimize
for Speed" or " Optimize for Portability". For a maximum print speed, change the PostScript
Output Option to "Optimize for Speed". You can find this property, in the Printer driver/
Advanced Options .

Print dialog box settings (Page 69)

1. Store forms on printer's hard disk
2. Custom cache size
3. Use OPI, don't spool images

Adobe PDF

Adobe PDF Print Technology allows you to save optimized PDF output files to disk directly from PrintShop Mail.
The PDF output files can be used for printing to PostScript level 3 printers and soft proofing when uploading
PrintShop Mail documents to PrintShop Web.

When using ÒAdobe PDFÓ Print Technology, it is advised to activate Split job option for the best performance.

AHT

Select this technology if you have an AHT RIP. AHT uses an optimization mechanism similar to Optimized
PostScript.

Print dialog box settings (Page 69)
1. Store forms on printer's hard disk
2. Custom cache size
3. Use OPI, don't spool images

Creo VPS

VPS ( Variable Print Specifications) is a PostScript language extension, created and maintained by Creo.

It allows PrintShop Mail to classify each element on a page as either reusable (occurring more than once) or
inline (occurring only once). This distinction allows the VPS RIP to decide when image data can be reused. This
avoids unnecessary repeated processing and speeds up the print process.

One of the main differences between Optimized PostScript and VPS is that VPS reuses rasterized data instead
of PostScript.

Print Technology specific setting

Use Automatic Picture Replacement : Automatic Picture Replacement (APR) allows you to speed up the
printing process by using the image substitution capabilities of your VPS RIP. The image format support of
APR is limited to EPS, but some RIP versions support other formats like TIFF and JPEG.
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Fiery FreeForm

FreeForm makes use of the fact that the data in your document is divided in two layers, which contain the text
and image objects in the document.

The master layer in a FreeForm job consists only of "static" objects, but the variable layer can contain a mix of
both variable and static objects, depending on the order of the objects on your layout. This is a consequence
of the fact that FreeForm does not allow data in the master layer to be printed on top of data in the variable
layer.

These layers are sent to the FreeForm RIP in two separate jobs, not necessarily at the same time. The master
data job is rasterized first, and stored under a user defined numeric ID. The RIP overlays the rasterized
master data with the rasterized data of any variable data job that references the same ID. In this way, you
can reuse the same master data for different variable data jobs.

How the objects are separated

Static objects have content that remains constant throughout the entire record set. An image object is static
when it has an expression with a constant result. A text object is static when it does not contain any variable
markers. A PDF object is always static. All other objects are considered to be variable. A variable object is
reusable when its content is the same for at least two different records in the record set.

At printing, PrintShop Mail tries to assign as many static objects to the master layer as possible, starting with
the object at the back of your layout, and working towards the front. All static objects up to (but not
including) the first variable object are put in the master layer. All other objects make up the variable layer.
Any reusable data in the variable layer will be cached in PostScript forms.

Note : When using Freeform, try to make sure that static objects are not placed on top of variable
objects in the object order on your layout.

Note : FreeForm does not fully support layout conditioning. In particular, it does not allow you to
conditionally skip layouts. When SKIP is used, a BLANK page will be printed instead.

Preference settings

Form number : A numeric ID used to identify the master data job.

Print dialog box settings (Page 69)
1. Store forms on printer's hard disk
2. Custom cache size
3. Use OPI, don't spool images

Print Technology specific settings
1. Send Master data
2. Send Variable data
3. Send Master and Variable data

Fiery FreeForm 2

FreeForm 2 makes use of the fact that the data in your document is divided in two layers, which contain the
text and image objects in the document.

How to - Print a Document

Objectif Lune Inc. © 2010 73



The master layer in a FreeForm 2 job consists only of "static" objects, but the variable layer can contain a mix
of both variable and static objects, depending on the order of the objects on your layout. This is a
consequence of the fact that FreeForm 2 does not allow data in the master layer to be printed on top of data
in the variable layer.

These layers are sent to the FreeForm 2 RIP in two separate jobs, not necessarily at the same time. The
master data job is rasterized first, and stored under a user defined numeric ID. The RIP overlays the
rasterized master data with the rasterized data of any variable data job that references the same ID. In this
way, you can reuse the same master data for different variable data jobs.

How the objects are separated

Static objects have content that remains constant throughout the entire record set. An image object is static
when it has an expression with a constant result. A text object is static when it does not contain any variable
markers. A PDF object is always static. All other objects are considered to be variable. A variable object is
reusable when its content is the same for at least two different records in the record set.

At printing, PrintShop Mail tries to assign as many static objects to the master layer as possible, starting with
the object at the back of your layout, and working towards the front. All static objects up to (but not
including) the first variable object are put in the master layer. All other objects make up the variable layer.
Any reusable data in the variable layer will be cached in PostScript forms.

Note : When using Freeform 2, try to make sure that static objects are not placed on top of variable
objects in the object order on your layout.

FreeForm 2 is an extension of FreeForm. The difference are:

1. FreeForm 2 fully supports layout conditioning.
2. The FreeForm 2 master ID consist of a name instead of a number.

Preference settings

Master ID : A name used to identify the master data job.

Print dialog box settings (Page 69)
1. Store forms on printer's hard disk
2. Custom cache size
3. Use OPI, don't spool images

Print Technology specific settings
1. Send Master data
2. Send Variable data
3. Send Master and Variable data

PPML

PPML is short for Personalized Printing Markup Language . A PPML file describes the entire personalized
printing job and contains all necessary elements to print the contents (layout and variable data).

The technology PPML in PrintShop Mail is very similar to PPML/VDX (Page 76) . The difference is that the
content (PDF) and page layout description (PPML) are sent separately.
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Windows

Print Technology specific settings
1. Create ZIP archive : When checked, the PDF and PPML files will be zipped before being sent to the

printer. This option is used for specific printers, which expect a PPML-ZIP file. The ZIP file contains the
PPML and the PDF file.

2. Embed images in PDF : When checked, all images will be embedded in the PDF.
3. Environment : The path specified in the Environment setting will place the images with a "Global

Scope" in the Environment. The Consumer (RIP) stores and/or caches the images for later use.
4. Send .

4.1- Send "All Images ": A PDF file will be created containing images that have a "Global Scope" or a
"Local Scope". This option also creates a PPML job, using this PDF, with instructions to use the Local and
the Global images. Images with a "Global Scope" are stored in the specified Environment. After this job
the "Global images" can be reused for recurring print projects, for example with the option "Send Local
Images".

4.2- Send "Global Images ": A PDF file will be created containing images that have a "Global Scope".
This option also creates a PPML job, using this PDF, with instructions for storing these images into the
specified Environment.

4.3- Send "Local Images ": A PDF file will be created containing images that have a "Local Scope". This
option also creates a PPML job, using this PDF, with instructions to use these Local images and the
Global Images that are stored in the specified Environment. For that reason, images that have a "Global
Scope" should be present in the specified Environment. Images with a "Global Scope" will only be
referenced in the PPML job.

Note : The settings "Environment " and "Send " should not be changed when you are not familiar with
PPML terms!

For more information about PPML, visit the Website of PODi (Print On Demand Initiative),
http://www.podi.org .

PrintShop Mail offers an option to define if an image should have a "Global Scope". If the Global Scope of an
image is set to "Yes " in the Properties Panel , the image will have a "Global Scope". For recurring print
projects, a central benefit of PPML is its ability to reference Reusable Objects using Global Scope. This feature
allows for transmitting smaller datasets and eliminates repetitive processing of the reusable content.

Note : Please make sure that your RIP supports at least PPML 1.5, including the "application/ pdf"
source format.

Printing speed can be improved by using a "Global Scope" for one or more images, or possibly (depending on
your RIP) by unchecking the " Embed images in PDF Õ" checkbox in the Print dialog .

Mac OS

When using PPML as Print Technology, printing directly to the printer/ RIP will result in the output being placed
o the Desktop (either a ZIP file or a folder), which conatins the PPML file and (if used)images recurring in the
document. In order to print the PrintShop Mail document you need to download the output to your printer/
RIP.
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PPML/VDX 7

PPML/VDX is an abbreviation for Personalized Print Markup Language/ Variable Data Exchange. The output
consists of an optimized PDF in which reusable content elements occur only once. The PDF also contains a
block of PPML data that describes the page layout.

Note : PPML/VDX 7 requires both Adobe Acrobat(r) and Distiller(r) to be installed on your system.

To help ensure correct output there are "PSMail joboptions" files for the Acrobat Distiller versions 5, 6, or 7 in
the Printshop Mail installation folder.

These settings will tell Acrobat Distiller how to handle fonts, color, images, etc., when it creates the optimized
PDF.

If so desired, you can change these output options for PPML and VDX by changing the Distiller joboptions.
Double click on the "joboptions" file you want to modify, change and save it.

Note : PSMailx.joboptions files should be saved in the PrintShop Mail installation folder, next to the
executable. The "x" specifies the Acrobat Distiller version that the file corresponds to.

More information about the Acrobat Distiller joboptions can be found in the online Help of the Acrobat Distiller.

Print Technology specific settings
1. Environment: The path specified in the Environment setting will place the images with a "Global Scope"

in the Environment. The Consumer (RIP) stores and/or caches the images for later use.
2. Send

2.1- Send "All Images" : A PDF file will be created containing images that have a "Global Scope" or a
"Local Scope". This option also creates a PPML job, using this PDF, with instructions to use the Local and
the Global images. Images with a "Global Scope" are stored in the specified "Environment". After this
job the "Global images" can be re-used for recurring print projects, for example with the option "Send
Local Images".

2.2- Send "Global Images : A PDF file will be created containing images that have a "Global Scope".
This option also creates a PPML job, using this PDF, with instructions for storing these images into the
specified Environment.

2.3- Send "Local Images" : A PDF file will be created containing images that have a "Local Scope".
This option also creates a PPML job, using this PDF, with instructions to use these Local images and the
Global Images that are stored in the specified Environment. For that reason, images that have a "Global
Scope" should be present in the specified Environment. Images with a "Global Scope" will only be
referenced in the PPML job.

PrintStreamer

This printing technology sends two separate files to the RIP, one master file and one with variable data.

Print dialog box settings (Page 69)

1. Use OPI, don't spool images

Print Technology specific settings
1. Send Master and variable data
2. Send Master data
3. Send Variable data
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VIPP

VIPP is an acronym for Variable data Intelligent PostScript Printware. The output of this technology consists of
a PostScript stream in which reusable images occur only once.

The main difference between VIPP and Optimized PostScript is that images are cached using a proprietary
VIPP specific mechanism instead of PostScript forms. The cached images are stored in print ready format.

Print Technology specific settings
1. Don't spool images (EPS, TIFF, JPEG) : This option allows you not to send the recurring images twice

to the RIP. The output will only contain references (by filename) to images stored in the project folder.
2. Project Folder :This option allows you to store recurring images on the fly, and before printing the job,

to a "project folder" on the (VIPP enabled) RIP. The folder name can be specified in the Print Dialog .

Encapsulated VIPP supports the following image formats: JPEG, TIFF, EPS and PDF.

Note : This technology requires a RIP that has been enabled for Encapsulated VIPP, and a hardware
key that has been upgraded to enable VIPP. For more information on how to upgrade the
hardware key, see Upgrading PrintShop Mail (Page 9) .

5.15.3 Page Setup

The Page Setup of your document allows you to specify which printer to print to, the paper size, source, and
other characteristics of your print media.

The settings in the Print dialog are applied to the current print job only, but the settings in the Page Setup
dialog will be stored in your document file.

You can specify a different Page Setup for each layout, but you can only send layouts to one printer. This
allows you to mix paper sizes (Windows only ), orientations, media types, and finishing options throughout
your document, provided that this is supported by your printer.

Windows

There are different ways of changing the Page Setup :

1. From the File menu, select Page Setup , and choose either:

Selected Layouts: layouts selected in the Layouts window.
Current layout : layout selected in the Layouts window.
This point forward : current layout and all layouts below it.
Whole document : all layouts in the document.

2. Select the Layouts tab in the Properties panel, select one or more layouts, select Page Size , and click
on the [...] button.

3. Right click on the layout and select Page Setup to open the dialog.

Use the Page Setup dialog box to specify printer options, as well as the media your job will be printed on.
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Mac OS

To change the Page Setup :

1. From the File menu, select Page Setup .
2. In the dialog box, you can change:
¥ Settings
¥ Format
¥ Orientation
¥ Scale

Use this dialog box to specify printer options, as well as the media your job will be printed on.

Related Topics

¥ Select Paper Trays (Page 47)

5.15.4 Subset Finishing

Subset finishing is the process of applying a finishing option (such as stapling or binding) to each subset in a
print job.

PrintShop Mail defines a subset as a set of pages belonging to the same record. If you are not using layout
repetition (Page 45) or layout conditioning (Page 42) , the number of pages in each subset will equal the
number of layouts in your document.

To use subset finishing

You can specify a finishing option in the printer driver, using the Properties button in the Print dialog or
using the Advanced button in the Print Setup dialog box.

PrintShop Mail can embed certain PostScript instructions in the output to signal that the finishing option
should be applied.

You can specify which instructions to embed in the Embed PostScript dialog box.

It is possible to write your own PostScript set and save them. If you go to New you can give the PostScript
set a name. The given instructions at the "Start of Page", "Start of Job" and "Between Sets" will be saved. You
can also turn it to the default setting by selecting the button " Set Default ".

Locating this dialog box

File > Embed PostScript

There are 4 options:

1. General : This option can be used to give the PostScript set a "Name" and write a "Description".
2. Start of Page : These instructions will be injected at the start of each page.
3. Start of Job : Instructions given there will be injected in the header of the job.
4. Between Sets : Instructions given in this field will be injected between the sets.

For stapling or binding, the default setting (Generic Subset Finishing) should suffice.
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5.15.5 Any Output Engine

Any Output Engine Print Technology allows you to print to a non PostScript Printer.

This option is not available in the Preferences panel as the others Print Technologies. Any Output Engine
will be automatically applied when selecting a non Postscript printer in the Page Setup or in the Print
Dialog .

When selecting a non PostScript printer the print output will not be optimized, printing and spooling time will
be significantly slower compared to other technologies.

The Print Dialog will show the following message:

"The selected printer driver is not a Postscript Level 2 compatible device. Printing speed will be reduced and
some features might not be supportedÓ.

The following features might not be supported by non Postscript printers:

-Subset finishing
-Color Management
-Spot color

5.15.6 Print To Web

Print to Web allows you to print PrintShop Mail documents to PrintShop Mail Web. The output will be
generated on the PrintShop Mail Web server, not on the computer where the PrintShop Mail document is
created.

From the File menu, select Print to WebÉ

When selecting Print to Web É option, the PrintShop Mail document can be saved before it is uploaded,
otherwise the original document will be sent to PrintShop Mail Web.

Print to Web allows you to print PrintShop Mail documents to PrintShop Mail Web. The output will be
generated on the PrintShop Mail Web server, not on the computer where the PrintShop Mail document is
created.

From the File menu, select Print to WebÉ
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When selecting Print to Web É option, the PrintShop Mail document can be saved before it is uploaded,
otherwise the original document will be sent to PrintShop Mail Web.

Company

This option list the available Companies. PrintShop Mail will store the last selected company with the
document.

Printer

This option list the available printers installed on the PrintShop Mail Web server. If no printers are installed,
the combo box will show ÒNo printers availableÓ and the print button will not be enabled.

Record range

This option allows you to print a certain range of records.

Copies

Indicates the number of copies you wish to print of your document.

Print

When printing the document and its related files will be sent to PrintShop Mail Web print queue.

Notes on Documents using DirectSmile

In order to print PrintShop Mail documents using DirectSmile objects with a PrintShop Mail Web server, you
must make sure that the PrintShop Mail Web server has the proper access to the DirectSmile server.
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5.15.7 Automated Printing

Overview

PrintShop Mail allows you to automate certain tasks, such as opening and printing documents.

Windows

When you right click on a PrintShop Mail document file in a Windows Explorer window, you will notice that the
menu contains the submenu Print . You can print the document without starting PrintShop Mail, and you can
drag a PrintShop Mail document to a specific printer.

More advanced ways of automate the printing process is to use one of the next available features:

¥ Automated Printing using Command-line Arguments (Page 81)
¥ Automated Printing using Extended Scripting (Page 83)
¥ Automated Printing using DDE (Page 88)

Note : To be able to use this feature, you need to activate the automated printing option. See
Upgrading PrintShop Mail (Page 9) to learn how to add this feature to your license.

Note :When using automated printing, any errors will be logged in the Autoprint.log file, which usually
is located in:

C:\Documents and Settings\User\Application Data\PrintShop Mail.

If you have installed .NET Framework 2.0, the errors will be logged in the Event Viewer.

To open the Even Viewer:

¥ Start/Run/eventvwr.msc, or
¥ Start/Control Panel/Administrator tools/Event Viewer

Note : Automated printing allows you to print PrintShop Mail documents and PrintShop Mail templates
automatically through the Command line or script file . Make sure to use the appropriate
extension (<document name>.psmd or <document name>.psmt) in the Command line or in the
script file.

Mac OS

PrintShop Mail allows you to automate the printing process to a high extend. Instead of opening a document
in PrintShop Mail and selecting the "Print" submenu, the program can be told to monitor a HotFolder and
execute print jobs as soon as the necessary files (a PrintShop Mail document and/ or a database file) are found
there.

¥ Automated Printing using the HotFolder (Page 89)

Command line Arguments

You can order PrintShop Mail to perform certain actions by specifying them on the command line.
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Supported command line arguments

Argument Description

<document name> Filename of a PrintShop Mail document.
Example: "Mailing November.psmd"

-p Prints the specified document to the default printer.
Example: "Mailing November.psmd" -p

-pt Prints the specified document to a specific printer, enclosed in quotes.
Example: "Mailing Novembert.psmd" -pt "Laserwriter 16/600"

-db <database> Links the specified document to a certain database.
Example: "Mailing November.psmd" -db "Database.mdb"

How to use command line arguments

A simple example using command line arguments can be created by following the next steps:

1. Create a PrintShop Mail document, for example "Sample.psmd"
2. Create a database you wish to use with this document, or copy an existing database to the folder where

you saved the PrintShop Mail document.
3. Create a shortcut to the PrintShop Mail executable usually located at "C:\Program Files\PrintShop Mail6

\PSMail6x.exe". Copy this shortcut to the same folder as you saved the document you created in step 1.
4. Right click on the shortcut and choose Properties . In the field Target , specify the document name by

adding it to the target. It should look something like "C:\Program Files\PrintShop Mail6\PSMail6x.exe"
Sample.psmd.

If you double click on the shortcut you've just created, PrintShop Mail will be started and the specified
document will be opened. You are now ready to use any of the other supported command line arguments by
adding them to the target.

A few examples

"C:\Program Files\PrintShop Mail6\PSMail6x.exe" Sample.psmd -db "Database.mdb"

"C:\Program Files\PrintShop Mail6\PSMail6x.exe" Sample.psmd -p

Dropping a database on a shortcut

You can create a shortcut that will make PrintShop Mail open any supported database you drop on it, by
specifying the next text in the target field of the Shortcut's properties:

"C:\Program Files\PrintShop Mail6\PSMail6x.exe" Sample.psmd -db

If you drop a database on the shortcut, PrintShop Mail will be started, opening the document "Sample.psmd"
with the database you just dropped.

Note : Automated printing allows you to print PrintShop Mail documents and PrintShop Mail templates
automatically through the Command line or script file . Make sure to use the appropriate
extension (<document name>.psmd or <document name>.psmt) in the Command line or in the
script file.
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Extended Scripting

Extended Scripting is a fast and flexible way of automating your print jobs. This feature allows you to print
any PrintShop Mail document, combined with any database to any printer. You can even schedule an Extended
Scripting job on a certain date and/or time where your printer is usually idle.

You specify a certain action, or a range of actions, in a plain text file and tell PrintShop Mail to use that file by
adding it to a shortcut:

1. Create a shortcut to the PrintShop Mail executable usually located at "C:\Program Files\PrintShop
Mail6\PSMail6x.exe".

2. Add " -script scriptfile.txt " to the Target in the properties of the shortcut.

Note : When the script file has a name with spaces ("My<space>Script.txt") be sure to enclose this
file name with quote marks ("") in the Target line of the PrintShop Mail shortcut: "C:\Program
Files\PrintShop Mail 6\PSMail6x.exeÓ -script ÒMy Script.txtÓ. Include the quote marks if you copy
this line.

In the script you can specify a set of predefined commands to perform certain actions.
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Supported Commands

Command Description

FileOpen name Opens the specified document. If another document is opened, it will be closed
by PrintShop Mail. Example: FileOpen C:\Documents\MassMailing.psmd
Opens the PrintShop Mail document MassMailing.psmd from the folder
C:\Documents.

FileClose Closes the currently opened document.
Example: FileClose

FilePrint Prints the currently opened document to the default printer.
Example: FilePrint

FilePrintTo
printername

Prints the currently opened document to the specified printer.
The name of the printer should equal the name specified in the Printer's
properties.
Example: FilePrint Adobe PDF
Prints the currently opened document to the Adobe PDF printer.

SetPrintTech
technology

Will change the current print technology.
Example: SetPrintTech Standard
If the document was saved using Optimized PostScript as PrintTechnology,
SetPrintTech Standard will print the document using Standard PostScript as
Print Technology.

FilePrintRange
start stop

Prints the specified record range to the default printer.
Note : It is not possible to print a record range to a non-default printer.

Example: FilePrintRange 5 10
Prints record 5 to 10 from the currently opened document.

FileExit Quits PrintShop Mail. No other scripting commands followed by this command
are executed.
Example: FileExit

DatabaseOpen file Opens the specified database. If any other database is opened, it will be closed
by PrintShop Mail.
Example: DatabaseOpen C:\Documents\Example.mdb
Opens the Microsoft Access database "Example" from the folder C:\Documents.

DatabaseOpenODBC
source

Opens the specified data source. If any other database is opened, it will be
closed by PrintShop Mail.
Example: DatabaseOpenODBC MyDSN
Opens the data source called "MyDSN"

DatabaseFilter filter Filters the database according to the specified filter.
Example: DatabaseFilter [CITY] = 'New York'
Filters the database, only records where the value of field "CITY" equals "New
York" will be used.

DatabaseClose Closes the currently opened database.
Example: DatabaseClose
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The argument <technology> must have one of the following predefined values.

Print Technology Script Value

Standard PostScript SetPrintTech Standard

Optimized PostScript SetPrintTech Optimized

Adobe PDF SetPrintTech PDF

AHT SetPrintTech AHT

Creo VPS SetPrintTech VPS

FreeForm SetPrintTech FreeForm

FreeForm2 SetPrintTech FreeForm2

PPML SetPrintTech PPML

PPML/VDX SetPrintTech PPMLVDX

VIPP SetPrintTech VIPP

How do I create an Extended Scripting job?

You create an extended scripting job by following the next steps:

1. Create a PrintShop Mail document and save it, for example "ScriptTest.psmd".
2. Create a textfile containing all commands you want to perform.
3. Create a shortcut to PrintShop Mail.
4. Add the argument "-script scriptfile.txt" to the command line (where "scriptfile.txt" is the textfile

containing the commands)

Note : It is advised to save your script file as "UNICODE" encoding.

Note : Automated printing allows you to print PrintShop Mail documents and PrintShop Mail templates
automatically through the Command line or script file . Make sure to use the appropriate
extension (<document name>.psmd or <document name>.psmt) in the Command line or in the
script file.

In the script file, you specify all commands you want to perform:

FileOpen ScriptTest.psmd

FilePrint

FileExit

This simple scriptfile opens the document "ScriptTest.psmd", prints it to the default printer and quits
PrintShop Mail.

You can create a batch process by telling PrintShop Mail to use another document:

FileOpen ScriptTest.psmd

FilePrint
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FileOpen AnotherDocument.psmd

FilePrint

FileExit

PrintShop Mail first opens the document, "ScriptTest.psmd" and prints it to the default printer. When this is
done, PrintShop Mail opens the second document, "AnotherDocument.psmd" and prints it to the same default
printer. Of course, you can choose to specify a different printer by using the command "FilePrintTo". Finally,
PrintShop Mail exits.

It's possible to use the same document with different databases:

FileOpen ScriptTest.psmd

FilePrint

DatabaseOpen AnotherDatabase.MDB

FilePrintTo Printer2

FileExit

This opens the document "ScriptTest.psmd" and prints it to the default printer. When this is done, PrintShop
Mail opens the database "AnotherDatabase.MDB" and prints it to another printer, called "Printer2". Finally,
PrintShop Mail exits.

A combination of the commands is also possible:

FileOpen ScriptTest.psmd

FilePrintRange 5 10

DatabaseOpen AnotherDatabase.MDB

FilePrintRange 10 15

DatabaseOpen ThirdDatabase.XLS

FilePrintTo Printer2

FileOpen Document2.psmd

FilePrint

FileExit

This opens the PrintShop Mail document "ScriptTest.psmd" and prints records 5 to 10 to the default printer.
When this is finished, it opens the database "AnotherDatabase.MDB" and records 10 to 15 are printed to the
default printer. Then, the database "ThirdDatabase.XLS" is opened and all records are printed to printer
"Printer2". Eventually, the PrintShop Mail document "Document2.psmd" is opened, printed to the default
printer and PrintShop Mail exits.

It's possible to change the Print Technology used when the document was created, or print the same
document using different Print Technologies:

FileOpen ScriptTest.psmd

SetPrintTech Optimized

FilePrint

FileOpen ScriptTest.psmd
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SetPrintTech Standard

FilePrint

Database Filters

A database filter consists of a field name , an operator and a condition . Suppose you have the following
database:

NAME CITY GENDER

Eddy New York M

Pamela Los Angeles F

Tim Washington M

Robert New Jersey M

The available field names in this database are " Name ", " City " and " Gender ". The database has 4 records.

An operator should be one of the ANSI SQL operators listed in the table below.

Operators Definition

= Equal

<> Not equal

< Less than

> Greater than

<= Less than or equal

>= Greater than or equal

A filter is used to construct the WHERE clause of an SQL statement. It does not include the reserved word
WHERE to filter the record set.

Except for "Distinct", "Like" and "Between", all SQL commands are supported. For more information about the
SQL commands, please visit www.sql.org .

If you want to select and print the records where the field name "City" equals "New York", the following line
should be added to the script file:

DatabaseFilter [CITY] = 'New York'

Result : One record will be printed.

Note : Please notice that we have used single quotes around the conditional values 'New York'. SQL
uses single quotes around text values. Numeric values should not be enclosed in quotes.

Suppose you want to send a mailing to all persons in the database where [GENDER] does not equal 'F'. The
filter should look like:

DatabaseFilter [GENDER] <> 'F'
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Result : Three records will be printed.

Or, you want to print all records where the [GENDER] equals 'F' OR where [CITY] does not equal
'Washington':

DatabaseFilter [GENDER] = 'F' OR [CITY] <> 'Washington'

Result : Three records will be printed

These are just three examples of a database filter. You can create very advanced and powerful database
filters. Please refer to your SQL manual or an online resource for advanced examples.

If you need to have data from more than one table in the database, you can make a query in SQL or MS
Access and export the result of this query into Excel, Access or a text file. This file can be used as a database
in PrintShop Mail.

Scheduling a job

It is possible to schedule a certain job on a certain date and time. This can be achieved by using the Windows
Scheduler. For more information about the Windows Scheduler and how to create a scheduled task, please
refer to your Microsoft Windows¨ manual.

DDE

DDE Dynamic Data Exchange is a more flexible way to automate printing than using command line
arguments, but it requires knowledge of a programming language that supports DDE, such as Visual Basic or
C++. Please refer to the Win32 API documentation to learn how to establish a DDE connection.

To connect to the PrintShop Mail DDE Server, make sure PrintShop Mail is running and open a DDE-connection
to server "PrintShopMail6".

Visual C++ 6.0

// include "ddeml.h"

UINT iReturn = DdeInitialize(&idInst, (PFNCALLBACK)DdeCallback,

APPCLASS_STANDARD | APPCMD_CLIENTONLY, 0 );

HSZ hszApp = ::DdeCreateStringHandle(idInst, "PrintShopMail6", 0);

HSZ hszTopic = ::DdeCreateStringHandle(idInst, "C:\\untitled.psmd", 0);

HCONV hConv = ::DdeConnect(idInst, hszApp, hszTopic, NULL);

::DDEExecute(idInst, hConv, "[FileExit]");

Visual Basic 6.0

TextBox.LinkTopic = "PrintShopMail6|Connect" ' Set link topic.

TextBox.LinkMode = vbLinkManual ' Set link mode.

On Error Resume Next 'TextBox thinks DDE is not executed,

'when actually it is.

TextBox.LinkExecute "[FileExit]"
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On Error GoTo 0

PrintShop Mail accepts the following DDE commands:

Command Description

[FileNew] Closes the current document (if any) and creates a new document.

[FileOpen "filename"] Opens the specified document.

[FileClose] Closes the current document.

[FilePrint] Prints the current document to the default printer.

[FilePrintRange "start", "end"] Prints a range or records to the default printer.

[FileExit] Closes PrintShop Mail.

[DatabaseOpen "filename"] Opens the specified database.

[DatabaseClose] Closes the current database.

[DatabaseOpenODBC "source"] Opens the specified ODBC data source.

Note : This only applies to PrintShop Mail 6.x or later. PrintShop Mail 4.x and 5.x are slightly different.
If desired, the text can be adapted for 4.x and 5.x by changing the word ÒPrintShopMail6Ó to
ÒPrintShopMail4.xÓ or PrintShopMail5.x (all 3 occurrences).

HotFolder

This feature allows more than one user to "drop" their database files and/ or documents into the "HotFolder",
causing a print job to start without further interaction (and without even needing access to the PrintShop Mail
program from their computers).

Initializing the HotFolder
1. From the PrintShop Mail menu, select Preferences and click on the HotFolder icon.
2. Click on Browse to select the folder containing the desire documents to monitor.
3. Click Apply.
4. From the File menu, select Monitor HotFolder .
5. To stop monitoring and automatic printing of the document, click on the Cancel button.

Using the HotFolder
1. Create a PrintShop Mail document and store it in the HotFolder .

Since there will not be any user interaction with the program when the document is automatically
printed, users should verify the document before saving it.

2. Drop the document or/and the database file into the HotFolder.
Within 30 seconds, PrintShop Mail combines the database with the available PrintShop Mail document
and starts the print job.

3. After PrintShop Mail has printed the document, the database file is moved to a folder "PSMPrinted", in
the HotFolder. The PrintShop Mail document remains in the same location and can be used again.
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4. PrintShop Mail writes a log of its actions into a log file. Since the timestamp of the log file is
automatically adjusted every time when PrintShop Mail becomes active, this timestamp can be used to
check whether PrintShop Mail is still running or not. If no PrintShop Mail document and/ or database file
was found, the log file is still updated. The log file is located in the folder /Users/ user name/ Library/
Logs/PSM.log.
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