Topic Options
#47415 - 04/02/14 11:28 AM <C=ANSI> when adding Fonts in Font resources
KP_ABD Offline
OL Newbie

Registered: 12/12/13
Posts: 25
Ever since Pres 6.0, when I go to my Fonts and Graphics resource setup and add a font, it now adds a tag to the end of the font:
D#<N=Times New Roman><P=12><C=ANSI>

A lot of my job layouts, in general, are copy/paste templates. So when I paste in a template that was created years ago in older versions of pres, and add the fonts I need to my resource, the FONT commands do not have the new Pres Font tags and the resource list does:
FONT "D#<N=Times New Roman><P=12>"

I then get an error in the Print Control:
-----------------------------------------
99-0-1-13-0001:
Unknown font D#<N=Times New Roman><P=12>
Job will be halted!
-----------------------------------------


With all the font commands in my script, it's just simply easier for me to remove that <C=ANSI> tag from the font in the resource list whenever I add a font.

Other than that, is there anyway to avoid that <C=ANSI> tag from being added by Pres whenever I add a font?


Edited by KP_ABD (04/02/14 11:29 AM)

Top
#47466 - 04/09/14 08:26 AM Re: <C=ANSI> when adding Fonts in Font resources [Re: KP_ABD]
Jeff_K
Unregistered


The CodePage flag is the new default. There is no ability to not include this unless, as you have, you delete it manually.

It would be better served to incorporate this change in any future work, to ensure compatibility. The use of Internal fields in lieu of literals will make this easier.

IE:
ALPHA ia_Font00 = "D#<N=Times New Roman><P=12><C=ANSI>"
ALPHA ia_Font01 = "D#<N=Arial><P=12><C=ANSI>"

...
Font ia_Font00
SETXY $Margin, 1.0
...
Font ia_Font01
SETXY $Margin, 1.0


This way only one edit is required to make the change. This will save you much editing if/when you get into Unicode processing.

Top