Topic Options
#54668 - 03/15/17 03:00 AM ASCII code invalid
PEPE Offline
OL Newbie

Registered: 03/15/17
Posts: 5
Hi,
Im new in this foro.
My English level is a little bit low so if you dont understand me please, sorry. But i will try to write and express my ideas correctly.

Well, my first post is about ASCII code. Usually i used PrintShop Mail 6 with windows 7, but recently i change O.S to windows 10.

When i used windows 7 printshop mail worked correctly with ascii code but the new version of windows doesnt work with ascii code.

i dont know why.

when i introduce the code ALT + 255 in printshop mail, it doesnt recognize it. it "recognize" in designer mode but when i change to previsualization mode( the mode that you see the document when you print) printshop mail dont recognize de nbsp (non breaking space) and put normal spaces in order to nbsp.

pd, can you say if my english is good or bad? i didnt write in english since 2015 so... i want to know if i must study more english or not...

greetings from your friend and neighbour, PETETE;)

Top
#54689 - 03/16/17 06:40 AM Re: ASCII code invalid [Re: PEPE]
MartinS Offline
OL User

Registered: 08/06/12
Posts: 87
Loc: Munich
First, as far as I know PSM 6 isn't supported on Win 10 at all, you should use at least version 7.2.7 on that OS.
Regarding character 255 I think it depends on the font used what character it prints.
If I'm putting this character on the page I get a special symbol printed: ÿ (PSM 7.2.8 on Win 10).

Top
#54690 - 03/16/17 08:35 AM Re: ASCII code invalid [Re: PEPE]
PEPE Offline
OL Newbie

Registered: 03/15/17
Posts: 5
So, if i want to resolve the problem i must change the operative system to windows 7 or update the printshop mail 6 to printshop mail 7.2.8?

another plan to resolve it?

what do you want to say with special symbol printed? what symbol??

thanks;)


Edited by PEPE (03/16/17 08:37 AM)

Top
#54723 - 03/17/17 05:26 AM Re: ASCII code invalid [Re: PEPE]
MartinS Offline
OL User

Registered: 08/06/12
Posts: 87
Loc: Munich
Yes you need to update PSM if you like to use it on Win 10, just to be sure it's working properly in any case. But not sure if it resolves your current issue with the character 255.

If I use Ascii 255 here in a PSM document I get printed "ÿ" on one machine but a different character on another machine, so it depends how the OS interprets the ALT+255 it seems.
It may also depend on the font used, so try with different fonts.
And also try with function CHR() in an expression for a variable: CHR(255).

Top
#54724 - 03/17/17 08:58 AM Re: ASCII code invalid [Re: PEPE]
PEPE Offline
OL Newbie

Registered: 03/15/17
Posts: 5
I have a question.

the function of ALT+255 is different depends of the software where you use it?

i tried with different fonts and always the same results...

and the last question..
the expression CHR(255) is the same that ALT+255? the same function?

thaanks;)

Top
#54737 - 03/21/17 11:32 AM Re: ASCII code invalid [Re: PEPE]
MartinS Offline
OL User

Registered: 08/06/12
Posts: 87
Loc: Munich
Sorry, wasn't precise enough.
The NBSP character for some codepages has value 160 (hex A0), so to use it with CHR() function you would need to enter CHR(160).

You also could use ALT+160 to get that character, and it seems also ALT+255 returns the same character of code value 160.

Top
#54751 - 03/22/17 10:09 AM Re: ASCII code invalid [Re: PEPE]
PEPE Offline
OL Newbie

Registered: 03/15/17
Posts: 5
I think that if i write CHR(160) in printshop mail the program will understand the characters no its function...

so, how can i used CHR(160)??

now i´m going to try to use the expression CHR(160) and CHR (155)
and when i know the results i will write a new post.

Thanks;))

Top
#54757 - 03/24/17 04:26 PM Re: ASCII code invalid [Re: PEPE]
PEPE Offline
OL Newbie

Registered: 03/15/17
Posts: 5
Finally i get the solution!

I s a litle biot xtreme but the expression ALT + 255 works correctly.

i change the operative system. i had windows 10 but now i have windows 7.

i have I7 processor with windows 7... the installation was difficult because the operative system doesnt support the new hardware. when i install it, it doesnt recognize the grapich tarjet, usb ports, the keyboard etc. So i must download drivers in another PC and then try to install...

Thanks for all!!!

greetings for your friend and neighbour,

PETETE;)

Top