Topic Options
#34517 - 01/11/11 05:04 PM Embed Fonts inside Postscripts
CGorman Offline
OL Toddler

Registered: 01/11/11
Posts: 40
Loc: Ricoh Production Print
Something that has come up lately, but I haven't a clear sure how to do this. Is there a button, switch or something that I need to hit so Postscript fonts are embeded within the script?
_________________________
Christopher Gorman
Software Developer
Ricoh Production Print
Boulder, CO

Top
#34525 - 01/12/11 02:12 PM Re: Embed Fonts inside Postscripts [Re: CGorman]
Raphael Lalonde Lefebvre Offline
OL Expert

Registered: 10/14/05
Posts: 4956
Loc: Objectif Lune Montreal
CGorman,

There is no switch or options to check for embedding fonts in .ps forms.

The way it works is host-based fonts, such as TrueType fonts or PostScript fonts that you've installed in PlanetPress, will automatically be embedded in the .ps file. However, printer-based fonts, such as the ones you can choose in your styles under "PS, Printer, single-byte", will NOT be embedded in the .ps, as they are printer-resident and cannot even be accessed at the compilation time. This means that if you use printer-based fonts, you must make sure that the printer has the font, otherwise, it will not be able to use that font.

Hope that helps!

Regards,
Raphaël Lalonde Lefebvre

Top
#34531 - 01/13/11 10:54 AM Re: Embed Fonts inside Postscripts [Re: Raphael Lalonde Lefebvre]
CGorman Offline
OL Toddler

Registered: 01/11/11
Posts: 40
Loc: Ricoh Production Print
Under this logic (I think) if I used PS, Host, Single-Byte and I have the font installed it is usable, right?
_________________________
Christopher Gorman
Software Developer
Ricoh Production Print
Boulder, CO

Top
#34563 - 01/14/11 03:13 PM Re: Embed Fonts inside Postscripts [Re: CGorman]
Raphael Lalonde Lefebvre Offline
OL Expert

Registered: 10/14/05
Posts: 4956
Loc: Objectif Lune Montreal
Yes, it should be able to embed it.

Top
#34721 - 01/27/11 09:12 AM Re: Embed Fonts inside Postscripts [Re: Raphael Lalonde Lefebvre]
SBJ Offline
OL Newbie

Registered: 01/27/11
Posts: 1
Is there any solution for the font activation issue in PlanetPress Production?

After installing a new font we need to restart our server with PlanetPress Production before it can embed the fonts. This is a big problem for a production system and should be solved ASAP!!!


Edited by SBJ (01/27/11 09:13 AM)

Top