Page 1 of 2 1 2 >
Topic Options
#37076 - 08/30/11 03:42 PM Error in creating PDF
Alain B Offline
OL Guru

Registered: 09/30/08
Posts: 101
Loc: Montreal
Hi we have an intermitent problem, it hapen abouth once a week and from different process.

When this happen we only have to reprocess the file again, it just anoying.

it look like the Digital Action in order to create the PDF it first create the PDF in a temporary folder then move it to the folder specified.

But Sometime it's like planetwatch try to move the file before the file is fully completed.

it is not a huge file : 89.5 KB (91,662 bytes) we have smaller and lagrer who process without any problem and has I said if I put the capture file into the capture folder it process without any problem.

here the logs

DEBUG: Starting plugin Digital Action - 11:40:32
DEBUG: Archive folder and filename: %{pdfpath}\20%{year}\%{custno}\%{custno}_return_%{line}_20%{year}_%{authno}.pdf
DEBUG: Parsed archive folder and filename: \\SRV01\DFS\General\Annual Return\2011\1518\1518_return_2011_2357.pdf
DEBUG: Archive Folder: \\SRV01\DFS\General\Annual Return\2011\1518\
DEBUG: Filename: 1518_return_2011_2357.pdf
DEBUG: Generating an Optimized PostScript Stream job.
DEBUG: Initializing state...
DEBUG: Loading data file C:\Documents and Settings\All Users\Application Data\Objectif Lune\PlanetPress Suite 7\PlanetPress Watch\Spool\104.tmp\job00ZG0I45VTUYL3336007B6.dat...
DEBUG: Initializing document RETURN_O.ptk...
DEBUG: Setting global variables...
DEBUG: Producing an Optimized PostScript document...
INFO : Initializing PlanetPress Alambic
INFO : Ripping file C:\Documents and Settings\All Users\Application Data\Objectif Lune\PlanetPress Suite 7\PlanetPress Watch\Spool\104.tmp\dig36007D5.ps to C:\Documents and Settings\All Users\Application Data\Objectif Lune\PlanetPress Suite 7\PlanetPress Watch\Spool\104.tmp\1518_return_2011_2357.pdf
DEBUG: Ripping successful : C:\Documents and Settings\All Users\Application Data\Objectif Lune\PlanetPress Suite 7\PlanetPress Watch\Spool\104.tmp\1518_return_2011_2357.pdf
ERROR: W3650 : Error moving file from the temporary folder: Error moving digital file.: Error code 32: The process cannot access the file because it is being used by another process.
ERROR: Digital Action: W1603 : Plugin failed - 11:40:43

INFO : File sent to error bin process Error_return_crtpdf_VADO
DEBUG: W1602 : Stopping execution of process
WPROC: RETURN_1_VADO complete - 11:40:43

Top
#37078 - 08/30/11 04:20 PM Re: Error in creating PDF [Re: Alain B]
Raphael Lalonde Lefebvre Offline
OL Expert

Registered: 10/14/05
Posts: 4953
Loc: Objectif Lune Montreal
Alain,

It could be difficult to troubleshoot if it's intermittent, but one thing you could try is maybe instead of using Digital Action, make a branch, and send to a PlanetPress Image output? Or, if you have Office or Production, try Create PDF instead, and see if that works better.

Regards,
Raphaël Lalonde Lefebvre

Top
#37084 - 08/30/11 09:40 PM Re: Error in creating PDF [Re: Raphael Lalonde Lefebvre]
Marc-André
Unregistered


Hi Alain,

Have you had any luck with what Raphaël suggested?

I do have a few questions of my own.

What version of Planet Press are you using?

Do you use any self replicating processes? (7.2.x or higher)

And could you please give us a bit more details about the actual hardware of the Planet Press server.

I also ran into a very similar issue with a customer, it seems his anti-virus was locking up files for a fraction of a second just when PlanetPress was trying to move them.

Hope this helps.

Marc

Top
#37087 - 08/31/11 10:36 AM Re: Error in creating PDF [Re: ]
Alain B Offline
OL Guru

Registered: 09/30/08
Posts: 101
Loc: Montreal
Hi Marc-André No I Didnt have time to check on Raphael Solution

But now i will delete the whole process and recreate it again

what is strange is that we have like 70 process running
24 of them use the Digital Plugin Action but only 3 of them fails

The 3 process that fail was copied from a process and we just changed the input, output, and document (PTK) file.

So why only 3 fails, that the question.
This is why i want to delete one of the failing process then recreate it again to see if it fail again.

It fail randomly, it can be once every 3 days, it can fail twice the same day and if we put the same file in the input it process without any problem.

About the version it was doing thin on version 7.0.1 and is still doing the same error on 7.3.1 version

here the config we have
Window server 2003
Standard Edition
Service Pack 2

CPU Intel Xeon E5345 @ 2.33Ghz
2.00 GB Ram

Top
#37088 - 08/31/11 11:32 AM Re: Error in creating PDF [Re: Alain B]
Alain B Offline
OL Guru

Registered: 09/30/08
Posts: 101
Loc: Montreal
Ok I recreated the process in error will see if it correct thing

Top
#37089 - 08/31/11 11:39 AM Re: Error in creating PDF [Re: Alain B]
Alain B Offline
OL Guru

Registered: 09/30/08
Posts: 101
Loc: Montreal
Raphael I have a question about PlanetPress Image output

I remember having a problem once using something like Planetpress Image but im not sure it was This.

The problem was that the process who created the pdf was running like a stand alone process, in clear during the pdf creation the rest of the process was continuing.

So if we have a process who create a pdf and then move it somewhere else whe it was moving the PDF it was not completed.

This is why we decided to use the digital plugin because the process wait for the digital plugin action complete before continuing the process.

Am i Right ?

Top
#37091 - 08/31/11 01:44 PM Re: Error in creating PDF [Re: Alain B]
Raphael Lalonde Lefebvre Offline
OL Expert

Registered: 10/14/05
Posts: 4953
Loc: Objectif Lune Montreal
Alain,

Indeed, the Digital Action will wait until it's finished before moving to the next action, whereas Image is an independant service, so that's why when using Image, the process was continuing it's run while the pdf files were being made.

Regards,
Raphaël Lalonde Lefebvre

Top
#37110 - 09/06/11 01:51 PM Re: Error in creating PDF [Re: Raphael Lalonde Lefebvre]
Alain B Offline
OL Guru

Registered: 09/30/08
Posts: 101
Loc: Montreal
Hi Raphael so If i understand If I use image the problem will be worst

Update : After deleting one process and recreated it I still have the same error : ERROR: W3650 : Error moving file from the temporary folder: Error moving digital file.: Error code 32: The process cannot access the file because it is being used by another process.
ERROR: Digital Action: W1603 : Plugin failed - 13:40:45

What I find strange it the new process was recreated last week by copying a process that dont give error.

Top
#37111 - 09/06/11 02:18 PM Re: Error in creating PDF [Re: Alain B]
Marc-André
Unregistered


Hi Alain,

Are you using the same form for multiple processes?

If so - It would be worth a try to save the form under a different name and using that new form on that process only and see if you have the same issue.

Could be because another process is trying to use the same form at the same time.

Let me know if that is possible to try.

Marc

Top
#37112 - 09/06/11 03:53 PM Re: Error in creating PDF [Re: ]
Alain B Offline
OL Guru

Registered: 09/30/08
Posts: 101
Loc: Montreal
Ok I just copied the form under a new name and changed the planetpress talk id to a different one

Will see

Top
#37124 - 09/07/11 01:08 PM Re: Error in creating PDF [Re: Alain B]
Alain B Offline
OL Guru

Registered: 09/30/08
Posts: 101
Loc: Montreal
Hi same problem...

Top
Page 1 of 2 1 2 >