Topic Options
#49093 - 08/20/14 11:06 AM HTTP Services hanging after a few POSTS
Alikeware Offline
OL Newbie

Registered: 02/14/08
Posts: 26
Loc: USA, Maryland
Hi everyone...

I am having an issue with PP Watch 7.5.3 using the HTTP Input service. I have a web site that is POSTING data to a process in PPW which after 3 or 4 POSTS the service goes under a "hanging" state. But it does not stop receiving POSTS, but when I need to restart PPW, that is when I notice the problem because PPW will not stop normally. I have to "kill" it in order to do so and I will have a few of "HTTP7 services waiting to be stopped" messages in the log.

Any ideas?

Windows 2008 Server R2 x64
PPW Office - Latest version

Top
#49103 - 08/20/14 05:39 PM Re: HTTP Services hanging after a few POSTS [Re: Alikeware]
Alikeware Offline
OL Newbie

Registered: 02/14/08
Posts: 26
Loc: USA, Maryland
This is the error in the log:
INFO : All Processes have terminated.
INFO : Waiting for "HTTP7" to stop...
INFO : Waiting for "HTTP7" to stop...
INFO : Killing Service...
INFO : Service has stopped

As you can see I had two of the HTTP7 hanging...

Help anyone?!?!

Top
#49104 - 08/21/14 09:34 AM Re: HTTP Services hanging after a few POSTS [Re: Alikeware]
Raphael Lalonde Lefebvre Offline
OL Expert

Registered: 10/14/05
Posts: 4953
Loc: Objectif Lune Montreal
Hi Alikeware,

It seems like somehow, something is getting stuck and never finishes processing, so the service is stuck in some sort of infinite loop and cannot restart. Or it may be that it's processing something big and it just takes a long time to process, and it's waiting until it's done before moving forward. And as you said, it will still accept new POSTS during that time, they will be queue and will be processed after it's done with it's current job.

It would probably be best if someone took at look at your process and see what it's doing to see what could cause this issue. I suggest that you contact Technical Support. You may call 1-866-348-5863 and ask for Support, or go through the web:

http://planetpress.objectiflune.com/en/resources/support

Regards,
Raphaël Lalonde Lefebvre

Top
#49105 - 08/21/14 09:35 AM Re: HTTP Services hanging after a few POSTS [Re: Alikeware]
Benoit Potvin Offline
OL Expert

Registered: 01/02/08
Posts: 490
Loc: Montréal, Canada
Hi,

When a request is made to an HTTP Server Input Process, PlanetPress temporarily stores files in

C:\ProgramData\Objectif Lune\PlanetPress Suite 7\PlanetPress Watch\http\YOURPROCESSNAME

Once the process is done executing, those files should be deleted. So one thing you could do is to go in this folder to see if there are any residual files still there. if so, try to delete those files, then restart the service.

Hope this helps.
_________________________
Knowledge is capital
http://twitter.com/benoitpotvin

Top
#49114 - 08/22/14 12:08 PM Re: HTTP Services hanging after a few POSTS [Re: Alikeware]
Alikeware Offline
OL Newbie

Registered: 02/14/08
Posts: 26
Loc: USA, Maryland
No luck... There are no files left... All clean, and still getting HTTP7 process in hanging state...

Anything else?!?!?

Thanks...

Top
#49115 - 08/22/14 12:13 PM Re: HTTP Services hanging after a few POSTS [Re: Alikeware]
Alikeware Offline
OL Newbie

Registered: 02/14/08
Posts: 26
Loc: USA, Maryland
Also, this process is receiving a very small amounts of data and they are simplistic in nature: Just a HTTP Input a branch to save the data into a folder and the last piece returns a HTML file with a Delete Permanently process at the very end.

Top
#49167 - 08/29/14 11:10 AM Re: HTTP Services hanging after a few POSTS [Re: Alikeware]
Alikeware Offline
OL Newbie

Registered: 02/14/08
Posts: 26
Loc: USA, Maryland
Ok guys...

After rebuilding my PPress Watch server(I had to since did not get anywhere), I found out that the latest Windows updates were the culprit. I do not know which one, but in this new server I only applied the latest SECURITY patches not the windows updates.

That did the trick. The system is stable and no more HTTP7 services hanging...

Cheers,

Alberto

Top
#49278 - 09/09/14 06:28 PM Re: HTTP Services hanging after a few POSTS [Re: Alikeware]
Benoit Potvin Offline
OL Expert

Registered: 01/02/08
Posts: 490
Loc: Montréal, Canada
Thanks for sharing the solution. Always appreciated.
_________________________
Knowledge is capital
http://twitter.com/benoitpotvin

Top