Topic Options
#51131 - 03/13/15 12:35 PM PP Image error I1013: No Documents Defined
Kalor Offline
OL Newbie

Registered: 03/13/15
Posts: 3
Loc: Ohio
Hello,

We are using Watch v7.3 and have a work flow for creating a pdf for archive purposes. A db emulated file is read creating a PS file within watch then output to Image for conversion to a pdf.

Occasionally one of the PS files created by watch causes the error I1013L No pages defined in the index file(i.e. pdi/xml).

What causes this error on PS files created by Watch and How can I prevent them from happening.

Top
#51134 - 03/16/15 08:59 AM Re: PP Image error I1013: No Documents Defined [Re: Kalor]
Raphael Lalonde Lefebvre Offline
OL Expert

Registered: 10/14/05
Posts: 4956
Loc: Objectif Lune Montreal
Hi Kalor,

This error probably means that no pages were in the pdf produced by Image, in which case you will get an error, rather than an empty pdf. There could be many reasons, such as invalid data, all pages having conditions and all of them being false, etc...

To troubleshoot this, right before your Image ourput, insert a branch, and save a backup of the current data right before it makes it to Image. Then, when you get the error, open the PlanetPress document in Design, then load the data file that caused the error, and try to see if there's anything wrong with it. Maybe it's invalid, maybe it's causing page conditions to be false, etc...

Let us know how it goes!

Regards,
Raphaël Lalonde Lefebvre

Top
#51139 - 03/16/15 05:52 PM Re: PP Image error I1013: No Documents Defined [Re: Kalor]
Kalor Offline
OL Newbie

Registered: 03/13/15
Posts: 3
Loc: Ohio
I have implemented the Branch. Next time a data file errors on the image I will load the data file in design and let you know.

Thanks,
Kalor

Top
#51148 - 03/18/15 12:25 PM Re: PP Image error I1013: No Documents Defined [Re: Kalor]
Kalor Offline
OL Newbie

Registered: 03/13/15
Posts: 3
Loc: Ohio
So we have a record type that doesn't actually produce anything. It was done that way intentionally and we have actually had no problems with printing. It was when we started archiving into a pdf that we suspect this record started casuing the majority of the errors we have experienced. Usually it is when that record in question is the only record in the batch.

Thanks for the help in identifying the problem. We are implementing a change to exclude this record but it probably won't be in production until 4/9/2015. I will let you know if we have further issues.

Top