These forums were permanently set to read-only mode on July 20, 2022. From that day onwards, no new posting or comment is allowed on the site, but the historical content remains intact and searchable.

A new location for posting questions about PlanetPress Suite is now available:

OL Learn - PlanetPress Classic (opens in new tab)

Topic Options
#55225 - 08/31/17 05:02 AM Error when opening Database
3ma Offline
OL Newbie

Registered: 08/31/17
Posts: 2

Since few days, i've got troubles when i'm trying to open a database file on PSM. An error message is displayed : "Object invalid or no longer set" frown
I'm currently using PSM version 7.2.4 on Windows 10 (build 1703)

Does anyone already encountered the problem ?


#55234 - 09/01/17 03:55 PM Re: Error when opening Database [Re: 3ma]
Raphael Lalonde Lefebvre Offline
OL Expert

Registered: 10/14/05
Posts: 4956
Loc: Objectif Lune Montreal
Hi 3ma,

While I am not entirely sure why you are getting this error, I'd like to point out that PSM version 7.2.4 is not officially supported on Windows 10, and you could potentially get errors trying to make it work. However, there is a new version, 7.2.8, that does have official support for Windows 10, so maybe you should try upgrading to 7.2.8, and see if that fixes the problem.

Raphaël Lalonde-Lefebvre

#55274 - 09/11/17 04:36 AM Re: Error when opening Database [Re: 3ma]
3ma Offline
OL Newbie

Registered: 08/31/17
Posts: 2

Thanks for your answer. I tried to update to the version mentioned, unfortunately the problem is still here, so i've got some precisions that I can add:
- The database opens randomly in the first try, or sometimes i have to try to open it 10 times in a row until it works ...
- I uninstalled Microsoft updates which are linked with Access but the problem persists.
- I installed Access 2016 instead of Access 2010, and the error was still displayed.
- I tried to update Microsoft Office Acces Database Engine, because PSM 7.2.8 works with 2007, but it doesn’t change the problem.
- When I open the database with Access and save it again, I can open it with PSM without problems, but if I close PSM and reopen the software, the database won’t open in PSM.

Do you know how to solve this problem ?


#55312 - 09/19/17 09:05 PM Re: Error when opening Database [Re: 3ma]
Mosquitocoils Offline
OL Newbie

Registered: 09/19/17
Posts: 1
Hi 3ma, we recently had this issue with using W10, Access 2016, and PrintShop Mail 7.1.3.

We finally figured out that the Visual Basic reference to Access 2016 is not enabled by default. To fix -

- Open Access - may need to open a database, not sure
- Go to Database Tools - Visual Basic
- Tools - References
- Scroll down to PrintShop Mail 6.0 and tick the box

This fixed the problem for us for good. Hope that helps.