Topic Options
#55343 - 09/26/17 09:14 AM Watch service not start automatically after reboot
jwbf Offline
OL Toddler

Registered: 09/14/11
Posts: 43
Our PlanetPress server is scheduled to reboot on a regular basis. The startup type is set to 'Automatic' on PlanetPress Watch 7 service.
However, the service doesn't start automatically after the reboot.
In the 'Configure Services' window, the Account is set up with Domain and Username. Services start automatically box is checked.
The same account is used in PlanetPress Watch 7 service.
What else should be done to have the service start automatically after the reboot?
Thank you,

Top
#55348 - 09/26/17 11:07 AM Re: Watch service not start automatically after reboot [Re: jwbf]
MartinS Offline
OL Guru

Registered: 08/06/12
Posts: 106
Loc: Munich
Try with a different local user if that let's the service start automatically. If yes it's an issue with windows user privileges I guess.

Top
#55351 - 09/26/17 03:24 PM Re: Watch service not start automatically after reboot [Re: jwbf]
jwbf Offline
OL Toddler

Registered: 09/14/11
Posts: 43
Thank you for the response.
The account in use is an Administrator account that has complete and unrestricted access to the computer/domain.
We are hesitate to change to a another account since it might break the workflow in some processes.
Are there any suggestions?

Thank you,

Top
#55356 - 09/27/17 06:22 AM Re: Watch service not start automatically after reboot [Re: jwbf]
MartinS Offline
OL Guru

Registered: 08/06/12
Posts: 106
Loc: Munich
You just could try with a local user (instead of a domain one) to see if this would helps. If yes there's any restriction on the domain user.
Did you check the service in the Windows Services list if it's really set to start automatically (Startup Type = Automatic)?
Are there any errors in the Windows event log?
If Windows cannot start the service after reboot it's an issue with the Windows service host.

Top
#55367 - 10/03/17 08:51 AM Re: Watch service not start automatically after reboot [Re: jwbf]
jwbf Offline
OL Toddler

Registered: 09/14/11
Posts: 43
Thanks for pointing out the Windows event log. There are errors in the log after the reboot.
After some research on the errors, the Startup Type for PlanetPress Watch 7 service was changed to 'Automatic(Delayed Start)' and that solved the problem.

Thank you,

Top