Page 1 of 3 1 2 3 >
Topic Options
#55579 - 12/21/17 04:25 PM Error creating Temp File
Duane Sellers Offline
OL Toddler

Registered: 12/18/13
Posts: 45
The last 3 days this has appeared in the Image logs and Planet Press Watch and Image has stopped working. The resolution was to reboot the Planet Press server and it will work fine for a while. Then back to the error and the issue.
any idea why? The file folder that it is distilling the PDF to is local, not networked. Not sure where the Temp File resides on the local machine.

DEBUG: Error creating temp file: (267) The directory name is invalid.
DEBUG:
ERROR: I1007 : Error while converting to PDF : Error converting file: Error getting a temporary file.
ERROR: I1005 : Error while processing job; moving file to error folder: 34D7428.ps


Edited by Duane Sellers (12/21/17 04:26 PM)

Top
#55580 - 12/22/17 06:13 PM Re: Error creating Temp File [Re: Duane Sellers]
Jean-Cédric Offline
OL Expert

Registered: 10/03/16
Posts: 650
Loc: Québec, Canada
This is an issue when the Alambic.exe (PPAlambic) instance gets corrupted in memory. Once that happens, any other PDF process through that instance will give the same error. It needs to be killed (thus, working after a reboot).

The file that were sent in the error folder of PlanetPress Image (C:\ProgramData\Objectif Lune\PlanetPress Suite 7\PlanetPress Image\error) can now be drop back in the In folder of PlanetPress Image (C:\ProgramData\Objectif Lune\PlanetPress Suite 7\PlanetPress Image\In) and should process normally.

If that happens often, I suggest you open a technical support call at 1-866-348-5863 or through our website.
_________________________
♪♫♪♫
99 frigging bugs in my code
99 frigging bugs
Take one down
Code around
127 frigging bugs in my code
♪♫♪♫

Top
#55582 - 12/27/17 12:49 PM Re: Error creating Temp File [Re: Duane Sellers]
Duane Sellers Offline
OL Toddler

Registered: 12/18/13
Posts: 45
Thanks Jean. I reconfigured the network printer ports that feed into the PP processes and that seemed to have solved the issue. This happen after a Windows 10 update Dec 12. Not sure what went south with the ports, but all seems to be well currently.

Top
#55591 - 01/03/18 06:19 PM Re: Error creating Temp File [Re: Duane Sellers]
Duane Sellers Offline
OL Toddler

Registered: 12/18/13
Posts: 45
@jean-Cedric
Jean, i have had 2 clients report this issue in the last 3 weeks. Both since a Windows 10 Update. Do you know of anything that is being experienced because of the latest update.???

Top
#55592 - 01/03/18 06:23 PM Re: Error creating Temp File [Re: Duane Sellers]
Jean-Cédric Offline
OL Expert

Registered: 10/03/16
Posts: 650
Loc: Québec, Canada
We seem to see that error with customer who has migrate to a Windows 10 machine or done an upgrade on it.
We are still investigating.
We will keep you posted on this.
_________________________
♪♫♪♫
99 frigging bugs in my code
99 frigging bugs
Take one down
Code around
127 frigging bugs in my code
♪♫♪♫

Top
#55594 - 01/04/18 01:18 PM Re: Error creating Temp File [Re: Duane Sellers]
Duane Sellers Offline
OL Toddler

Registered: 12/18/13
Posts: 45
thank you

Top
#55694 - 02/14/18 11:47 PM Re: Error creating Temp File [Re: Duane Sellers]
Martijn Offline
OL Newbie

Registered: 01/21/18
Posts: 21
Afternoon
Has there been any progress regarding this issue? I am also getting the same error.

Error while converting to PDF : Error converting file: Error getting a temporary file
_________________________
Martijn

Top
#55702 - 02/15/18 11:54 AM Re: Error creating Temp File [Re: Martijn]
Duane Sellers Offline
OL Toddler

Registered: 12/18/13
Posts: 45
Martin, the latest i have been able to get out of OL support are these 2 things.

1) Limit the # of Alambics that are able to run (Preferences,Messenger). That helped a little, but not much.

2) Set a Dos Run Plugin right before any PDF Image creation objectin the process tree and have it run the following command.

taskkill /f /im ppalmbic.exe

That seems to have done the trick. Although it does generate(at least on my system) a few Recoverable errors. I get a few Alambic Crash errors, but they are flagged as recoverable and the Alambic restarts and completes the job.

Top
#55768 - 03/08/18 01:53 PM Re: Error creating Temp File [Re: Duane Sellers]
Yannick Fortin Offline
OL Expert

Registered: 08/25/00
Posts: 351
Loc: Objectif Lune Montréal
You guys are funny. ;-)

The problem has been traced to the DiskCleanup scheduled task. It is supposed to clean up files and folders from the Temp folders (user and system) that are not in use and that are at least 7 days old (by default; the value is configurable).

For some reason, some installs of Windows 10 1709 (Fall Creators Update), but not all of them, delete everything immediately, causing ppalmbic.exe to lose its temp folder, which it (wrongly) assumes is always there.

The taskkill trick works because it triggers a restart of the ppalmbic.exe process, thus recreating its temp folder.

As of this writing, we don't know what introduced this new behavior in Windows 10 1709 or why it only happens on some systems and others not.

However, the problem is fixed in the coming release of Connect. A patch should also be made available shortly for both PlanetPress 7.6 and Connect 1.7/1.8.


Edited by Yannick Fortin (03/08/18 01:54 PM)
_________________________
Yannick Fortin, Team OL

Top
#56941 - 04/08/19 11:49 PM Re: Error creating Temp File [Re: Duane Sellers]
gfischer Offline
OL Newbie

Registered: 04/08/19
Posts: 2
We are getting this exact error suddenly. How do I determine if we have received this patch? We currently have version 7.6.2.9999. When I run update client, says no new updates.

The system is running Windows 10 1803 and started suddenly when running 1703 a week ago, so I updated to 1803 and its still an issue. Randomly our system stops sending emails and we get the same error in logs:
Error creating temp file: (267) The directory name is invalid.

A reboot will clear it up for a short time, maybe a day. I doubt its a permissions issue since a reboot resolved the problem temporarily. But the perms are correct regardless.

I tried disabling the task for DiskCleanup, still have the problem.

I appreciate any help,
Greg

Top
Page 1 of 3 1 2 3 >