Topic Options
#55852 - 04/05/18 01:52 PM ptk files not loading into workflow, stuck in 'in'
Dave-Ohio Offline
OL Newbie

Registered: 03/18/15
Posts: 23
Loc: Ohio, USA
I'm migrating to a new PlanetPress server and decided to go into designer for each document, validate data/pictures/etc are present in the expected location, send to workflow to create ptk files. This was working fine until recently when I had an error in one of the documents. I corrected the error and sent to workflow but it doesn't show up. I looked in the ProgramData\Objectif Line\PlanetPress Suite 7\PlanetPress Watch\Documents folder and found some files in the 'In' folder. The *.form documents have the form names in the file followed by 'ptz'. How do I get these to post into workflow as ptk files?

Top
#55853 - 04/05/18 02:00 PM Re: ptk files not loading into workflow, stuck in 'in' [Re: Dave-Ohio]
Jean-Cédric Offline
OL Expert

Registered: 10/03/16
Posts: 471
Loc: Québec, Canada
The "Documents\In" folder is where the forms are being sent for Workflow to integrate them. It can happen that it doesn't do it if the server is too busy while running jobs, the actual form you are trying to update is already in uses, or there is a problem with it.

You could try to stop your services and restart them, which will trigger the import of any new form (an update as well).

However, if the form are still "stuck" there, you might wan to delete them and resend them from your Designer.

If the problem persist, I suggest you open a technical support call at 1-866-348-5863 or through our website.

Top
#55854 - 04/05/18 02:09 PM Re: ptk files not loading into workflow, stuck in 'in' [Re: Dave-Ohio]
Raphael Lalonde Lefebvre Offline
OL Expert

Registered: 10/14/05
Posts: 4953
Loc: Objectif Lune Montreal
Hi Dave-Ohio,

If you want to force a .ptk, you can go in Design, and when you do Send To->PlanetPress Suite Workflow, you can click "Save to File", and then choose to save as a .ptk instead of a .ptz. Then from Workflow, import that .ptk file, and it should load the new form.

That said, .ptz should also work. Have you tried stopping the Workflow services if they are running, and then try to send the updated document? Sometimes, I have noticed that if Workflow is running, trying to send an updated template to it doesn't always work, so you might want to try stopping the services first, then send your form, see if it shows up and then restart the services.

Regards,
Raphaël Lalonde-Lefebvre

Top
#55855 - 04/05/18 02:21 PM Re: ptk files not loading into workflow, stuck in 'in' [Re: Raphael Lalonde Lefebvre]
Dave-Ohio Offline
OL Newbie

Registered: 03/18/15
Posts: 23
Loc: Ohio, USA
Workflow services are not running. I don't plan to start these until I review all workflows, load documents, printers, fonts, ppd's. Until recently, the ptk files were immediately showing up in workflow after sending local from designer - run on the same server. The designer doesn't show any planetpress talk messages for these documents, which was the reason that the first one failed during the local send.

Top
#55856 - 04/05/18 02:36 PM Re: ptk files not loading into workflow, stuck in 'in' [Re: Dave-Ohio]
Dave-Ohio Offline
OL Newbie

Registered: 03/18/15
Posts: 23
Loc: Ohio, USA
Starting the workflow service allowed the new .ptk files to post.

Top
#55873 - 04/10/18 10:20 AM Re: ptk files not loading into workflow, stuck in 'in' [Re: Dave-Ohio]
Dave-Ohio Offline
OL Newbie

Registered: 03/18/15
Posts: 23
Loc: Ohio, USA
I have a set of ptk documents moved to a new server where I don't have the original document present. The ptk file is present in workflow on the old server with the ptk file present in program data\objectif line\planetpress suite 7\planetpress watch\documents. A folder for each document is present as well: <FORM>.ptk_files.

If I copy the ptk file to the new server desktop and use the workflow 'import - planet press document' it appears to insert the form in workflow but the sample data files (activated by '+' next to the document) do not appear. Do I have to also move the "<FORM>.ptk_files" folder and files into 'documents' as well or is the a better way to transfer the ptk with related documents onto the new sever?

Top
#55875 - 04/10/18 10:43 AM Re: ptk files not loading into workflow, stuck in 'in' [Re: Dave-Ohio]
Jean-Cédric Offline
OL Expert

Registered: 10/03/16
Posts: 471
Loc: Québec, Canada
The best thing would be to make a PTZ from the Design tool so all that is needed is included in it. (Send to Workflow and click on Save to file).

If that proves to be problematic, you could move the whole Documents folder and have it replace the one on your new server.

Top