Topic Options
#55894 - 04/16/18 01:17 PM Image only using data from 1st record
melmckee72 Offline
OL Newbie

Registered: 03/19/07
Posts: 7
I'm trying to create a process where a data file is split and then each page is emailed separately to the recipient. There are text conditions that control the body of the email. While these conditions appear to be working, the dynamic data selections are only utilizing the first record in the data file. Any thoughts on what I might be doing wrong?

Top
#55895 - 04/16/18 01:20 PM Re: Image only using data from 1st record [Re: melmckee72]
Raphael Lalonde Lefebvre Offline
OL Expert

Registered: 10/14/05
Posts: 4956
Loc: Objectif Lune Montreal
Hi melmckee72,

Are you doing your data selections before or after your splitter? If you do them before the splitter, then the same data selection will be repeated for every splits, because it can only extract one record at a time. You need to put your data selections after the splitter, so that they will be different on every splits.

Regards,
Raphaël Lalonde-Lefebvre

Top
#55896 - 04/16/18 01:40 PM Re: Image only using data from 1st record [Re: melmckee72]
melmckee72 Offline
OL Newbie

Registered: 03/19/07
Posts: 7
The selections are being done after the splitter. I have the data splitter, and then a series of text conditions, based on the text conditions, a different planetpress image is created. The text conditions are working because the parts of the email body that aren't data selections are correct, but the data selections within the body of the email and the planetpress image itself are using the 1st record.

Top
#55897 - 04/16/18 02:56 PM Re: Image only using data from 1st record [Re: melmckee72]
melmckee72 Offline
OL Newbie

Registered: 03/19/07
Posts: 7
Actually, I was wrong, I had the text conditions set up incorrectly. The problem seems to reside in the fact that I am using a delimited file output. The only way the process seems to work is by using the Emulated Data Splitter to split on a page and checking off the CSV emulation box to add a header to each output file. My data file doesn't have a header so it is making the first data row the header and the data selections are being done based on the header. Any ideas on how to get around this?

Top
#55898 - 04/16/18 03:51 PM Re: Image only using data from 1st record [Re: melmckee72]
melmckee72 Offline
OL Newbie

Registered: 03/19/07
Posts: 7
I figured this out. Apparently the generic splitter was adding a quote delimiter. Once I fixed that it is working properly.

Top