IMPORTANT ANNOUNCEMENT

These forums were permanently set to read-only mode on July 20, 2022. From that day onwards, no new posting or comment is allowed on the site, but the historical content remains intact and searchable.

A new location for posting questions about PlanetPress Suite is now available:

OL Learn - PlanetPress Classic (opens in new tab)

Page 1 of 2 1 2 >
Topic Options
#57270 - 10/31/19 10:45 AM Problem with xml and planet press design
sygui Offline
OL Expert

Registered: 11/02/10
Posts: 170
In design, emulation xm: the data I need is all on one line. What can I do?

I see: <InvoiceDate>2019-10-31</InvoiceDate>" <Order>12153169</Order>"

instead of:

<InvoiceDate>2019-03-29</InvoiceDate>
<OrderNo>12153169</OrderNo>

Top
#57271 - 10/31/19 04:37 PM Re: Problem with xml and planet press design [Re: sygui]
jim3108 Offline
OL Expert

Registered: 04/19/10
Posts: 316
Loc: London, UK
The quotes mean that the data is not in true XML format. You would need to preprocess the data the remove the offending quotes from what I can tell.

Top
#57272 - 11/01/19 09:31 AM Re: Problem with xml and planet press design [Re: sygui]
sygui Offline
OL Expert

Registered: 11/02/10
Posts: 170
Jim

By "preprocess" the data: you mean replace the quotes ? It looks like more of a paragraph sign.

Top
#57273 - 11/01/19 09:39 AM Re: Problem with xml and planet press design [Re: sygui]
jim3108 Offline
OL Expert

Registered: 04/19/10
Posts: 316
Loc: London, UK
Yes. Whatever the character which is breaking the XML structure, use Search/Replace in the workflow to remove the offending item and restore it to parseable XML.

Let me know if you have any issues.

Top
#57274 - 11/01/19 09:40 AM Re: Problem with xml and planet press design [Re: sygui]
sygui Offline
OL Expert

Registered: 11/02/10
Posts: 170
thks Jim

Top
#57275 - 11/01/19 10:54 AM Re: Problem with xml and planet press design [Re: sygui]
sygui Offline
OL Expert

Registered: 11/02/10
Posts: 170
Jim by what should I replace \n ?

Top
#57276 - 11/01/19 12:06 PM Re: Problem with xml and planet press design [Re: sygui]
jim3108 Offline
OL Expert

Registered: 04/19/10
Posts: 316
Loc: London, UK
A new line statement should be read by the XML parser. It might not be a correct line-ending.

Try removing it - replace with nothing, just leave the box blank.

If that doesn't work, send me the file and I'll take a look.

Top
#57277 - 11/01/19 12:51 PM Re: Problem with xml and planet press design [Re: sygui]
sygui Offline
OL Expert

Registered: 11/02/10
Posts: 170
when I replace \n, the " is not there anymore but still on one line.

<InvoiceDate>2019-10-31</InvoiceDate> <Order>12153169</Order>

Top
#57278 - 11/01/19 12:57 PM Re: Problem with xml and planet press design [Re: sygui]
Jean-Cédric Offline
OL Expert

Registered: 10/03/16
Posts: 681
Loc: Québec, Canada
Maybe it would be good at this point to have a technician from OL to look at it.

I suggest you open a technical support ticket through our website.
_________________________
♪♫♪♫
99 frigging bugs in my code
99 frigging bugs
Take one down
Code around
127 frigging bugs in my code
♪♫♪♫

Top
#57281 - 11/04/19 10:14 AM Re: Problem with xml and planet press design [Re: sygui]
sygui Offline
OL Expert

Registered: 11/02/10
Posts: 170
Jean-Cedric, we don't have ol care. Can we pay to have someone from OL help us ?

Top
#57282 - 11/04/19 10:59 AM Re: Problem with xml and planet press design [Re: sygui]
Jean-Cédric Offline
OL Expert

Registered: 10/03/16
Posts: 681
Loc: Québec, Canada
That is kind of what OL Care is, paying service that not only gives you access to our support, but also give you access to updates of the software.

I suggest you contact your OL Reseller and inform them that you want OLCare for your product. As soon as they confirm your OLCare is valid, you will have access to our support, and a technician will be able to look at your data and/or remote at your site and see what the problem is.

Believe me, it is worth it!! wink
_________________________
♪♫♪♫
99 frigging bugs in my code
99 frigging bugs
Take one down
Code around
127 frigging bugs in my code
♪♫♪♫

Top
Page 1 of 2 1 2 >