These forums were permanently set to read-only mode on July 20, 2022. From that day onwards, no new posting or comment is allowed on the site, but the historical content remains intact and searchable.

A new location for posting questions about PlanetPress Suite is now available:

OL Learn - PlanetPress Classic (opens in new tab)

Topic Options
#57709 - 10/01/20 10:05 AM printer centric to OPS causing issues
morgan Offline
OL Newbie

Registered: 04/25/16
Posts: 13

I have a watch process we've been using for about 8 years that's having issues since I made some changes.

The watch process uses 1 of 12 planet press images to create a pdf that’s emailed based on some IF logic. Every year we change the design documents to modify text on the pdf. I made some changes to the 12 design documents this year, and the changes included adding a hyperlink using some code I found on the forums. I tested the changes and everything was working fine, I got all 12 emails when I dropped my 12 test files in. I had to go back to a previous version of the design documents because we weren’t ready to go live with the changes yet. So I copied the 12 design documents to a backup folder and moved the older versions to the live folder. I tested again and everything still worked correctly.

I needed to rename the newer versions of the design documents and I wanted to test again to make sure everything still worked correctly. So I renamed the design documents in the backup folder to 2021 versions and copied and pasted them into the live working folder. I then opened them 1 by 1 and sent the config through design so they would be available in watch. I opened up my test watch process and changed all 12 of the design documents to the 2021 versions. I noticed that as I was changing them the setting on the first page of the properties of the image was now defaulted to optimized post script instead of printer centric, as it was before.

I sent the config of the watch and did some testing by dropping my 12 test files into the folder capture folder specified. I should have received 12 emails with each of the different pdf’s, but I only received 5 of the 12. Some of the PDF’s are English versions and some are French versions. It’s funny that I received the 5 English versions but none of the French versions, possibly a French character in the text of the pdf is causing some kind of issue. When I look at the log file, it says that each of the 12 pdf’s processed correctly.

I went into the watch process and changed all of the properties of each of the images from OPS back to printer centric. When I looked at my older version of the process, they were all set to printer centric by default. When I made the change, it gave me a warning, so I clicked yes to go ahead with the change. This didn’t fix my issue, I got 7 out of the 12 letters now. And on the 2 French letter I got, my hyperlink I created with the sample code I found on the forums didn’t work now.

I made some changes on the design documents and resent the configs of them and got my coded links working again but still I’m not getting all 12 letters.

So then I tried creating a new watch process to try to fix the issue. I’ve been using the test version of the watch process to test so far. So I copied the live version of the watch process and named it ‘test watch process 2’. I disabled the test watch process, changed the folder capture of ‘test watch process 2’ to the folder capture of my original test watch process, sent the config in watch and tested again. I am still only getting 7 emails when I should be getting 12, 1 for each test file.

Then I tried changing the images on the watch process back from the 2021 versions to the older versions before I made any changes. The older versions did not include the code to create the hyperlink. I sent the config of the watch and tested. I am still only getting 6 or 7 emails when I should be getting 12.

I tested my test watch process on the live server, where I haven’t touched anything yet, and it still works properly, I drop my 12 test files and I get 12 emails.

I should also mention that on the new server it isn’t live yet and I am using a trial license.

I’m not sure what to try next. I was going to grab the ppwatch.cfg file from my live server and put it on the new server and see if that fixes my problem.

#57730 - 10/22/20 02:49 PM Re: printer centric to OPS causing issues [Re: morgan]
Jean-Cédric Offline
OL Expert

Registered: 10/03/16
Posts: 681
Loc: Québec, Canada
You would definitely be better to open a technical support ticket. A lot of tests you did but some more to do while actually seeing your whole setup would be required...

Edited by Jean-Cédric (10/22/20 02:50 PM)
99 frigging bugs in my code
99 frigging bugs
Take one down
Code around
127 frigging bugs in my code