Topic Options
#57753 - 11/12/20 10:59 PM Incorrect result after use emulated data splitter
Andy1974 Offline
OL Guru

Registered: 03/26/08
Posts: 122
Loc: Hong Kong
Hello everyone,

I create one process to do below procedures.
1. Capture the invoice text data
2. Split on customer code when change
3. Generate pdf and save into folder.

Process :
==========
Folder Capture
|
Change Emulation ASCII
|
Emulated Data Splitter (Split on word change)
|
Set Job Infos and Variable
|
Digital Action (Generate PDF and save into folder)
|
Delete


However, after run, I get incorrect pdf generated result.
For below example, one invoice text data have 5 pages. First three are customer 'FSH003' and next is 'FST016' and last is 'FST022'.

Invoice text data :
-------------------
FSH003
FSH003
FSH003
FST016
FST022

After run, it generated 10 pdf, but actually I expect to generate 3 pdf, each customer code should only be generated one pdf.

Incorrect result of PDF generate :
==================================
Invoice__20201113_112949.PDF <---- Blank page
Invoice__20201113_113001.PDF <---- Blank page
Invoice__20201113_113010.PDF <---- Blank page
Invoice__20201113_113018.PDF <---- Blank page
Invoice__20201113_113027.PDF <---- Blank page
Invoice_FSH003_20201113_112945.PDF <---- 1 page
Invoice_FSH003_20201113_112952.PDF <---- 1 page
Invoice_FSH003_20201113_113007.PDF <---- 1 page
Invoice_FST016_20201113_113014.PDF <---- 1 page
Invoice_FST022_20201113_113022.PDF <---- 1 page


I expect this correct result :
==============================
Invoice_FSH003_20201113_112945.PDF <---- 3 pages
Invoice_FST016_20201113_113014.PDF <---- 1 page
Invoice_FST022_20201113_113022.PDF <---- 1 page

Do anyone can tell me what wrong in my process ?

Thank you !

Regards,
Andy









Edited by Andy1974 (11/12/20 11:32 PM)

Top
#57754 - 11/13/20 07:54 AM Re: Incorrect result after use emulated data splitter [Re: Andy1974]
Jean-Cédric Offline
OL Expert

Registered: 10/03/16
Posts: 650
Loc: Québec, Canada
Your logic is sound BUT without seeing the actual data and testing it against the actual Workflow config makes it a little hard to troubleshoot.

I suggest you open a technical support ticket on our website. A technician will be able to remote in and look at your settings. Most likely something in your data or emulation like a CR or LF too many, or a FF forgotten.
_________________________
♪♫♪♫
99 frigging bugs in my code
99 frigging bugs
Take one down
Code around
127 frigging bugs in my code
♪♫♪♫

Top
#57762 - 11/22/20 09:34 PM Re: Incorrect result after use emulated data splitter [Re: Andy1974]
Andy1974 Offline
OL Guru

Registered: 03/26/08
Posts: 122
Loc: Hong Kong
Hello Mr.Jean-Cedric,

Many thanks your reply on my question.

Regards,
Andy

Top