I played a bit with this...

Interestingly, it was working when I first started a new document. I didn't even need to use any expressions, it was formatting the 1214.44 number properly, with the commas and the space. In the properties of the variable, the "Digit Grouping Symbol" was set to a space by default. However, I changed it, and when I tried switching back to the space, it instead gave me an empty character, and I couldn't put back the space again.

I wonder if the space's default selection has something to do with the system's regional settings? (mine is a french environment) Pspdfppd, maybe you can try creating a new variable to display your field, and see if the space is selected as the grouping symbol? If not, try maybe closing PSM, set your system's regional settings to a french environment temporarely(it shouldn't turn all menus to french, don't worry), and then recreate the variable. If it adds the space properly, save the document, then revert back to english environment. Do not change the grouping symbol again for that variable. I do think that this should be fixed for the next release, and that we should be able to put whatever we want as the grouping symbol.


With that said, Sander's code also seems to work for me for the first number. For the second, however, it doesn't seem to add the space, probably because in 1200.50, it doesn't display the 0 after the 5. In your case, does 1200.50 shows up as this, or does it shows up as 1200.5 or something else?

Hope that helps.

Regards,
Rapha