All PSM 7.0 builds have the same so-called release date: 09-2009. Since your dongle has an OL-Care date of 07-2010, it is valid for 7.0. This will not change after July.

Now suppose we release PSM 7.1 in 09-2010. Its release date would most likely be set to 09-2010. Since your dongle has an OL-Care date of 07-2010, when you download and try 7.1 it will run in demo mode.

In that case you have a choice between upgrading your dongle so you can use 7.1, or sticking with 7.0 which will still work with your dongle.