It sounds like PSM doesn't know you're printing duplex.

In that case PSM will make no effort to keep certain layouts together. Assuming 'Front to Back' has the highest priority (the default setting), the sequence of layouts in the output will depend on the number of sheets, which in turn depends on the number of records.

It might help if you set Preferences > Repetition > Duplex Mode to 'Flip on Long Edge'. The default setting 'Based on driver settings' is not guaranteed to work because not all drivers actually let PSM know that they have been configured to print duplex.