According to the release notes, I also need to install V7.1.0 before proceeding to V7.2.3.

Your suggestion of using the latest installer, will go immediately to V7.2.3.

Do I need to go via V7.1.0 or not? If so, how do I get it?

I am installing Watch only.

thanks for your help