I don't know which options you selected to generate your self-signed certificate, but here's what I usually do when I need one:

  • Go to http://www.selfsignedcertificate.com/
  • Specify localhost as your server name
  • Click Generate
  • Copy the two certificate files to a local folder. Make sure the folder can be accessed with the user credentials specified for your workflow services
  • In the Workflow Preferences, set both the Root Certificate and the Certificate fields to point to the .cert file you copied to your local folder. Set the Key field to point to the .key file
  • Don't specify anything in the Password field
  • Send to configuration to Workflow

I have just followed this procedure on my system and it works as expected.

If it still doesn't work for you, check if any other application or service is currently listening on port 443. You can do so by opening a command line window and typing:
Code:
netstat -ano | findstr /i ".*:443.*listening"


Also, you may want to check if your firewall is allowing applications to listen on port 443. By default, you shouldn't have to make any allowances for it, but perhaps your IT department disabled it.


Edited by Philippe F. (03/28/18 12:36 PM)
Edit Reason: fixed typos
_________________________
Technical Product Manager
I don't want to achieve immortality through my work; I want to achieve immortality through not dying - Woody Allen