Dear Sir/Madam,

Due to our company windows server plan to upgrade, so I want to confirm that is planetpress suite 7 can both compatible with 'Windows server 2012' or 'Windows server 2016' ?

Is there any expected time that it would be ?

Also, what is the minimum version of planetpress suite can be worked in 'Windows server 2012' or 'Windows server 2016' ?

Below is our current planetpress version.
- Planetpress design version 7.5.3.8067
- Planetpress production version 7.5.3.8067

Where can I find this kind of information in your website ?

Many thanks !

Best Regards,
Andy...