You mean .NET 3.5? That also includes .NET 2.0 so it should be fine for PSM.

In Windows 10 .NET 3.5 (and .NET 2.0) should be installed by default. It is listed as a feature in the "Turn Windows features on or off" dialog.

If .NET 3.5 is present I'm not surewhy the PSM installer would complain. It's probably a good idea to ensure that the OS is up-to-date through Windows Update.