We just ran into this error message and are trying to fix it. The only difference is that PP is running on a 2012 server.